[18.10 FEAT] zcrypt DD: introduce APQN tags to support deterministic driver binding - s390tools part

Bug #1800867 reported by bugproxy on 2018-10-31
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
High
Canonical Foundations Team
s390-tools (Ubuntu)
Undecided
Skipper Bug Screeners
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
Undecided
Skipper Bug Screeners

Bug Description

[Impact]

 * HW enablement
 * Kernel supports alternate zcrypt device drivers, hence lszcrypt (an information tool) should show if a driver is bound, and which one, given that it is no longer unambiguous.

[Test Case]

 * Run lszcrypt, ensure it shows info about crypto cards, and a driver name.

$ lszcrypt -V
CARD.DOMAIN TYPE MODE STATUS REQUESTS PENDING HWTYPE QDEPTH FUNCTIONS DRIVER
--------------------------------------------------------------------------------------------
01 CEX5C CCA-Coproc online 1 0 11 08 ---D----- cex4card
01.0001 CEX5C CCA-Coproc online 1 0 11 08 ---D----- cex4queue

[Regression Potential]

 * Changes are to an informational lszcrypt tool, output of which is now chnaged, but is not typically parsed in an automated fashion. (automation is usually done with lszdev/chzdev commands)

[Other Info]

 * Original bug report:

With the introduction of KVM crypto virtualization the driver bound to an AP queue device is no longer unique determined.
This feature provides a deterministic hot plugging semantics of AP queues that may be bound to multiple drivers.
In particular it enables to configure an AP queue (APQN) as being bound to a particular driver even if the associate HW gets intermittently lost and reconnected.

s390-tools part.
Backport from 2.7.0 to 2.6.0
Git commit: for s390-tools 2.7.0

https://github.com/ibm-s390-tools/s390-tools/commit/0a0b4c382693cded5652404e8fa2c0e483aa33df

lszcrypt: support for alternate zcrypt device drivers

It needs to be applied to 2.6.0 for Ubuntu 18.10, which will apply seamlessly

bugproxy (bugproxy) on 2018-10-31
tags: added: architecture-s39064 bugnameltc-172750 severity-high targetmilestone-inin1810
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Frank Heimes (frank-heimes) wrote :

@IBM: Does this also need to land in 18.04?
I assume yes, but the headline of the ticket 18.10 only.

Changed in ubuntu-z-systems:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)

------- Comment From <email address hidden> 2018-11-06 02:43 EDT-------
@Canonical: Yes it should also be added to 18.04.

affects: linux (Ubuntu) → s390-tools (Ubuntu)
Changed in s390-tools (Ubuntu):
status: New → Confirmed
Changed in ubuntu-z-systems:
status: Triaged → Confirmed
information type: Private → Public
Changed in s390-tools (Ubuntu Disco):
status: Confirmed → Fix Committed
Changed in ubuntu-z-systems:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-tools - 2.7.1-0ubuntu1

---------------
s390-tools (2.7.1-0ubuntu1) disco; urgency=medium

  * New upstream release:
    - zkey: Enhance error message about missing CCA library. LP: #1808520
    - Extended access controls for AP queue LP: #1804019
    - PCI error reporting tool LP: #1802499
    - zcrypt DD: introduce APQN tags to support deterministic driver
    binding LP: #1800867

 -- Dimitri John Ledkov <email address hidden> Tue, 15 Jan 2019 14:23:22 +0000

Changed in s390-tools (Ubuntu Disco):
status: Fix Committed → Fix Released
tags: added: id-5bfbdb035c39d84ac9cef195
description: updated
Changed in s390-tools (Ubuntu Cosmic):
status: New → In Progress
description: updated

Hello bugproxy, or anyone else affected,

Accepted s390-tools into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/s390-tools/2.6.0-0ubuntu7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in s390-tools (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Frank Heimes (frank-heimes) wrote :

I could successfully verify package s390-tools version 2.6.0-0ubuntu7.1 on cosmic.

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic

The verification of the Stable Release Update for s390-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-tools - 2.6.0-0ubuntu7.1

---------------
s390-tools (2.6.0-0ubuntu7.1) cosmic; urgency=medium

  * lszcrypt: Apply upstream patch to display bound driver name, if any,
    since the kernel supports alternate zcrypt drivers now. LP: #1800867

 -- Dimitri John Ledkov <email address hidden> Wed, 23 Jan 2019 11:56:12 +0000

Changed in s390-tools (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Changed in s390-tools (Ubuntu Bionic):
status: New → In Progress

Hello bugproxy, or anyone else affected,

Accepted s390-tools into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/s390-tools/2.3.0-0ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in s390-tools (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-done
Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Frank Heimes (frank-heimes) wrote :

Successfully verified package s390-tools 2.3.0-0ubuntu3.2 on bionic.
Adjusting tags accordingly ...

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-tools - 2.3.0-0ubuntu3.2

---------------
s390-tools (2.3.0-0ubuntu3.2) bionic; urgency=medium

  * lstape, lsluns: handle non-zfcp & lin_tape multiple paths. Many
    cherrypicks from upstream. LP: #1790831
  * lszcrypt: support for alternate zcrypt device drivers. LP: #1800867
  * lsqeth: resolve core dump when called without any eth devices. LP:
    #1813888

 -- Dimitri John Ledkov <email address hidden> Tue, 12 Feb 2019 15:17:08 +0000

Changed in s390-tools (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released

------- Comment From <email address hidden> 2019-03-07 07:45 EDT-------
IBM bugzilla status-> closed, Fix released for all required distros

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers