fix postinst in s390-tools in xenial

Bug #1608927 reported by Dimitri John Ledkov on 2016-08-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
s390-tools (Ubuntu)
Undecided
Dimitri John Ledkov
Xenial
Low
Dimitri John Ledkov

Bug Description

[Impact]

 * On each upgrade there is an attempt to remove bogus directory which has been gone since 1.34.0-0ubuntu8.1, thus the guard to remove the directory should use the correct version number for xenial, i.e. 1.34.0-0ubuntu8.1 not 1.34.0-0ubuntu10.

 * as per infinity, the version check is wrong firing on every upgrade.

[Test Case]

 * install s390-tools from updates
 * upgrade to this new version from proposed
 * during this upgrade one should not see error message from rmdir

Setting up s390-tools (1.34.0-0ubuntu8.5) ...
rmdir: failed to remove '/3770': No such file or directory

[Regression Potential]

 * This is a fixup of a typo in version check, it is a cosmetic change to make sure pointless warnings are not shown. There is little harm in trying to remove the bogus/gone directory. And even less harm in stopping to try to remove it going further.

Changed in s390-tools (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in s390-tools (Ubuntu):
status: New → Invalid
description: updated
Changed in s390-tools (Ubuntu Xenial):
status: Triaged → In Progress

Hello Dimitri, or anyone else affected,

Accepted s390-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/s390-tools/1.34.0-0ubuntu8.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in s390-tools (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
tags: added: id-596dec9e67253d56bc47d9d4
Dimitri John Ledkov (xnox) wrote :

Upgrading 8 -> 8.4 removes the stray directory. Reinstalling 8.4 shows the warning. (Original bug is reproduced)

Upgrading 8.4 -> 8.5 is without warnings, reinstalling 8.5 shows no warnings. (Confirms that 8.5 fixes this bug)

Upgrading s390-tools 1.34.0-0ubuntu8 -> 1.34.0-0ubuntu8.5 removes the stray /3770 dir.
Reinstalling 1.34.0-0ubuntu8.5 does not have any warnings. (Confirming that cleanup of stray /3770 directory since 16.04.0 has not regressed, aka 8.1 test-case)

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial

The verification of the Stable Release Update for s390-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-tools - 1.34.0-0ubuntu8.5

---------------
s390-tools (1.34.0-0ubuntu8.5) xenial; urgency=medium

  * Correct postinst, which cleans up erroneous directory from
    1.34.0-0ubuntu8 upload and earlier. LP: #1608927

 -- Dimitri John Ledkov <email address hidden> Wed, 21 Feb 2018 16:44:02 +0000

Changed in s390-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers