Rygel does not autostart

Bug #827030 reported by Reuben Thomas
78
This bug affects 17 people
Affects Status Importance Assigned to Milestone
rygel (Ubuntu)
Low
Unassigned

Bug Description

Having installed rygel and configured DLNA/UPnP to be on, I expect it to autostart, but it does not.

Further, it is not in the list of Startup Applications (perhaps because its desktop file is not under /etc/xdg/autostart, like most, but under /usr/share/autostart (the only other .desktop files in this directory appear to be for KDE)?

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: rygel 0.8.3-2
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
Architecture: amd64
Date: Tue Aug 16 00:34:58 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB:en
SourcePackage: rygel
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Reuben Thomas (rrt) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rygel (Ubuntu):
status: New → Confirmed
Revision history for this message
Andreas Henriksson (andreas-fatal) wrote :

Is this still true with a recent version of rygel?

Revision history for this message
Reuben Thomas (rrt) wrote : Re: [Bug 827030] Re: rygel does not autostart, and not listed in Startup Applications

On Jul 6, 2012 6:50 PM, "Andreas Henriksson" <email address hidden> wrote:
>
> Is this still true with a recent version of rygel?

Why don't you try and see? Then you'll both know if it's reproducible.
(I'll try too when I get back to my computer) .

Revision history for this message
Andreas Henriksson (andreas-fatal) wrote : Re: rygel does not autostart, and not listed in Startup Applications

What makes you think I haven't tried? Thanks for the demotivation.....

Revision history for this message
Reuben Thomas (rrt) wrote : Re: [Bug 827030] Re: rygel does not autostart, and not listed in Startup Applications

On 6 July 2012 21:49, Andreas Henriksson <email address hidden> wrote:
> What makes you think I haven't tried?

Because you didn't say you had.

> Thanks for the demotivation.....

I'm sorry I was demotivating; I meant only to give a friendly suggestion.

It would also have been more motivating to me if you'd revealed that
you'd tried, and what the result was (indeed, it still would!): if you
tried and reproduced my problem, then there's no need for me to try;
if on the other hand you couldn't reproduce my problem then I have the
motivation to check as my problem may well have been solved!

I'll have a look now and report back.

--
http://rrt.sc3d.org

Revision history for this message
Reuben Thomas (rrt) wrote :

I can confirm that in 12.04 rygel does not autostart in my desktop
session (I tried logging out and back in) and there's no entry for it
in gnome-session-properties (startup applications).

--
http://rrt.sc3d.org

Revision history for this message
Andreas Henriksson (andreas-fatal) wrote : Re: rygel does not autostart, and not listed in Startup Applications

ubuntu 12.04, that means you have package version 0.14.0-1 right? It definitely works here, so If it's not too much trouble for you could you also try the latest package version?

Revision history for this message
Reuben Thomas (rrt) wrote : Re: [Bug 827030] Re: rygel does not autostart, and not listed in Startup Applications

On 6 July 2012 23:42, Andreas Henriksson <email address hidden> wrote:
> ubuntu 12.04, that means you have package version 0.14.0-1 right?

Yes.

> It definitely works here, so If it's not too much trouble for you could you
> also try the latest package version?

Sure, do you mean just install the current quantal version?

--
http://rrt.sc3d.org

Revision history for this message
Andreas Henriksson (andreas-fatal) wrote : Re: rygel does not autostart, and not listed in Startup Applications

yes please

Revision history for this message
Reuben Thomas (rrt) wrote : Re: [Bug 827030] Re: rygel does not autostart, and not listed in Startup Applications

Exactly the same result as with the precise package.

Revision history for this message
Thomas Hood (jdthood) wrote : Re: rygel does not autostart, and not listed in Startup Applications

Rygel does not autostart in Ubuntu 12.10.

As originally posted, it is rather interesting that rygel.desktop is the only file in /usr/share/autostart/ whereas all the other .desktop files are in /etc/xdg/autostart/. I don't use KDE.

If I add the symbolic link

    ln -s /usr/share/autostart/rygel.desktop /etc/xdg/autostart

then rygel does autostart on login.

summary: - rygel does not autostart, and not listed in Startup Applications
+ Rygel does not autostart
Revision history for this message
Thomas Hood (jdthood) wrote :

I wrote:
> If I add the symbolic link [...] then rygel does autostart on login.

Not only that, another rygel process is started on every login. After logging in three times as foouser.

$ ps -elf|grep rygel
0 S foouser 3909 1 0 80 0 - 123082 poll_s 13:21 ? 00:00:00 /usr/bin/rygel
0 S foouser 5215 1 0 80 0 - 123088 poll_s 13:30 ? 00:00:00 /usr/bin/rygel
0 S foouser 6523 1 0 80 0 - 123086 poll_s 13:34 ? 00:00:00 /usr/bin/rygel

Revision history for this message
Kai Mast (kai-mast) wrote :

 Mh... rygel does autostart here fine? Have you tried a clean reinstall with the packages from raring?

Revision history for this message
Reuben Thomas (rrt) wrote :

It is unlikely that anyone who is subscribed to this bug has tried a clean reinstall with the packages from raring (I certainly haven't), since if they had, they would probably have reported the result to this bug thread. So I presume that what you (Kai Mast) really mean is "please try again with raring packages"?

That's all very well, only up to now, the only action from maintainers has been to suggest trying the latest version (resp. 11.10, 12.04, 12.10 and now 13.04), and none has addressed the precise description of the problem, nor the apparent error in the location of the startup file. That gives me no confidence that the original bug report has been understood, or that when various people have said "it works OK for me", the "it" is the same "it" as in the report, namely Rygel autostarting on login (for example, "it" could also mean "system instance of Rygel starting on boot").

Since it hasn't worked before on four occasions, and since the desktop file is still apparently in the wrong place in the raring package of Rygel, I see no reason to try again at least until I've installed raring (which I will do when it's released), when it will be just a moment's work. On the other hand, it would be nice to see the bug fixed in raring, so if a maintainer would like actually to address the report, rather than just saying "it works for me, try the latest packages", I'd be happy to perform further experiments.

Let me be clear: the suggestion to simply try the latest packages is not in itself a bad idea, and often has a place. The difference in this bug is that the suggestion has already been made (without success) four times, while no attempt seems to have been made to look at a diagnosis of and partial solution to the actual problem.

Revision history for this message
Jens Georg (yg-jensge) wrote :

There are two problems you describe in the initial report:

a) Enabling in rygel and thus making it autostart through the preferences UI does not actually enable it.

This was fixed in rygel 0.15.0 and so is included in current quantal/raring packages.

b) IF the autostart file was in /etc/xdg/autostart, it would run for every user on login, maybe unnoticed, and share things. I'm not sure that this is a sensible thing to do.

Revision history for this message
Reuben Thomas (rrt) wrote :

Thanks for the elaboration, Jens. Unfortunately, rygel is still not autostarting for me in 12.10 (see also Thomas Hood's similar experience in comment #13 above).

I performed the following steps:

1. Install rygel in Ubuntu 12.10.

2. Check that "Make local sound devices available as DNLA/UPnP Media Server" is ticked in paprefs.

3. Check that "Share media through DLNA" is ticked in rygel-preferences.

4. Log out and back in.

rygel is not running.

As for point b), that's a perfectly good point. If rygel should be started automatically as a result of configuring sharing, there's no need in any case to make it available as a user-visible service.

Revision history for this message
Jens Georg (yg-jensge) wrote :

Ok. This is a rather ugly bug in the settings app. Work-around:

install, start rygel preferences, exit rygel preferences.
start Rygel preferences, untick the "Share Media through DLNA" button, exit Rygel preferences
then start Rygel preferences, tick the checkbox and exit it again and it should work.

Will be fixed upstream in some next version.

Revision history for this message
Sven Arnold (sven-internetallee) wrote :

The above procedure (Comment #18) works for me (rygel 0.22.3-1 on 14.04), but I would like to add that IMHO the autostart behaviour of rygel should not be dependent on the option to export media:

In my use case I would like to use rygel *as a renderer only*, thus I do not turn on the option "Share Media". Obviously, rygel should autostart on login nevertheless. I propose to fix this issue by adding an explicit "autostart" option to the preferences UI.

Revision history for this message
Sven Arnold (sven-internetallee) wrote :

Sorry, the version information in comment #19 was wrong. I meant Ubuntu 14.10.

Revision history for this message
Mike (0x656b694d) wrote :

Hi,
17.10 here. Rygel does not autostart. The checkbox in the gnome share media preferences gets turned off.
There is no /usr/share/autostart folder here, and there's nothing about rygel in /etc/xdg/autostart.
Thanks for your attention.

Changed in rygel (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers