'network interface is down' when trying to connect to network using rt73

Bug #164058 reported by Max Blagg on 2007-11-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rutilt (Ubuntu)
Low
Unassigned
Gutsy
Medium
Unassigned
Hardy
Low
Unassigned

Bug Description

Binary package hint: rutilt

Using rt73 ( on advent laptop)

This was previously working fine until the last upgrade.

It will scan and find wireless networks, and how can it do that if the interface is down?(it might be possible it just seems counter intuitive)
tried ifconfig no wlan0, oh great how did that happen?
does appear if I check iwconfig
tried ifdown & ifup yeah that does little of import...

downloaded compiled and installed latest serialmonkey driver (I thought it could be a problem so best to be as up to date as possible)
no joy exactly same symptoms and behaviour

current solution:-
if you downgrade to the previous version of rutilt it works perfectly again (currently using the latest serialmonkey driver)

TEST CASE:

note: you need a wireless card with the ralink r73 (aka RT2501USB) chipset to test this.

1) Start rutilt, check that the version is 0.15-0ubuntu5.1 (Options tab -> About).
2) In rutilt, select a profile (Profiles tab) and hit apply (you should be prompted for the admin password).
3) A window with 'network interface is down' will appear immediately; no wireless connection will be established.
4) Quit rutilt.
5) Add the gutsy-proposed repository by adding this line to your /etc/apt/sources.list file:

  deb http://archive.ubuntu.com/ubuntu/ gutsy-proposed universe

6) Update and upgrade with your preferred package manager.
7) Start rutilt, check that the version is 0.15-0ubuntu5.2 (Options tab -> About).
8) In rutilt, select a profile (Profiles tab) and hit apply (you should be prompted for the admin password).
9) The wireless connection should be established immediately without any error prompt.

Cesare Tirabassi (norsetto) wrote :

First of all, thank you for contacting us.
I'm trying to understand your report, especially what problem you are reporting.
In the last update we added a patch to improve the behavior with legacy drivers, and I'm wondering if what you are seeing are some side effects of it.
Can you perhaps describe more in details what is the problem you are experiencing?

Changed in rutilt:
status: New → Incomplete

Thanks, sorry I wasn't clear enough

'improve the behavior with legacy drivers' yes that was one reason I upgraded, and also why I was surprised when it didn't work.

pre update

 rutilt would be started with X and I would select the profile hit apply (prompted for admin password ie not running sudo) and it would connect fine.

after the update

 rutilt would be started with X and I would select the profile hit apply (prompted for admin password ie not running sudo) and it quickly brings up an application modal window 'network interface is down'
(actually when you first do this it brings up 2, which is interesting) and then continues to do this for a while (presumably it retries and fails each time)

I tried running sudo rutilt
still doesnt work

tried sudo rutilt and created a new profile ( just in case you had changed the format)
still doesnt work

it can scan for networks (and oddly it found more that previously, but I don't think that's relevant, they are all on channel 11 , I'm on 13 so no interference) so the hardware is working at this point.
it can't connect to any of them.

just in case it was because my driver wasn't the latest
I downloaded the latest serialmonkey driver
followed instructions here http://ubuntuforums.org/showthread.php?t=400236

removed the kernel driver (sudo modprobe -r rt73)
then loaded the new one
still no joy it wont connect

used command line to issue ifconfig /iwconfig commands to get it to connect this works so its not an issue with the driver

opened synaptic package manager and forced install of previous rutilt

works first time

Cesare Tirabassi (norsetto) wrote :

OK, thanks, now is very clear.
Could you try to upgrade once again rutilt and see if this behavior persists?
Please check as well what version is giving you the problem (Options tab -> About).

working version is 0.15-0ubuntu5
non working version is 0.15-0ubuntu5.1

reinstalled update
networking still working, this is expected it hasn't tried to re-connect yet its still just using the existing connection.
run rutilt select profile press apply
errors with 'Failed : network interface is down.' as described previously
checked it was using right interface wlan0, it is.

manually configured network ( so glad I wrote this as a script yesterday! )
and then downgraded again to 0.15-0ubuntu5
run rutilt select profile press apply it works ( but that wasn't a surprise)

Changed in rutilt:
importance: Undecided → Low
status: Incomplete → Triaged
Changed in rutilt:
assignee: nobody → norsetto
status: Triaged → In Progress
importance: Undecided → Medium
status: New → Confirmed
Cesare Tirabassi (norsetto) wrote :

rutilt (0.15-0ubuntu7) hardy; urgency=low

  * Revised 018_up_and_down.diff (LP: #164058) :
    remove the change to configuration code that would bring the interface
    down before setting ESSID, as this is not necessary and does not work
    with all drivers (notably the r73 one).
    Thanks to Debian/Ben Hutchings.

 -- Cesare Tirabassi <email address hidden> Thu, 22 Nov 2007 10:18:58 +0100

Changed in rutilt:
assignee: norsetto → nobody
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
description: updated
Cesare Tirabassi (norsetto) wrote :

In support of the SRU request:
The bug makes the application unusable for all users with the r73 chipset.
The bug has been fixed in Debian unstable and in the Development release, and the patch for the -proposed repository is attached to this bug (package has already been uploaded).
Detailed instructions on how to reproduce the bug have been added to bug description (under the TEST CASE: header).
No regression potential has been identified.
Changes file is pasted:

Format: 1.7
Date: Thu, 22 Nov 2007 10:18:58 +0100
Source: rutilt
Binary: rutilt
Architecture: source
Version: 0.15-0ubuntu5.2
Distribution: gutsy-proposed
Urgency: low
Maintainer: Ubuntu MOTU Developers <email address hidden>
Changed-By: Cesare Tirabassi <email address hidden>
Description:
rutilt - Configuration tool for rt2x00 wireless network cards
Launchpad-Bugs-Fixed: 164058
Changes:
 rutilt (0.15-0ubuntu5.2) gutsy-proposed; urgency=low
 .
   * Revised 018_up_and_down.diff (LP: #164058) :
     remove the change to configuration code that would bring the interface
     down before setting ESSID, as this is not necessary and does not work
     with all drivers (notably the r73 one).
     Thanks to Debian/Ben Hutchings.
Files:
 3733493a3f3c9550bc7f20df4bb0e803 720 net optional rutilt_0.15-0ubuntu5.2.dsc
 2a3858a24d0a1affa4b12c87e7015716 155644 net optional rutilt_0.15.orig.tar.gz
 b7848c63219261223f5ab601217fb48e 12648 net optional rutilt_0.15-0ubuntu5.2.diff.gz
Original-Maintainer: Cesare Tirabassi <email address hidden>

Martin Pitt (pitti) wrote :

*grumble* Such regressions are *precisely* the reason why such patches are entirely unappropriate for an SRU and I asked for a sanitation of the MOTU SRU policy. I accepted this because it's a regression introduced in SRU.

description: updated
Changed in rutilt:
status: Confirmed → Fix Committed
Cesare Tirabassi (norsetto) wrote :

If you would like to test it, please add the following lines
to /etc/apt/sources.list:

  deb http://archive.ubuntu.com/ubuntu/ gutsy-proposed universe

Then update and install (or upgrade) rutilt with your preferred package manager.
Note that we need at least 2 positive tests for this to be accepted in gutsy-updates.

Andres Rodriguez (andreserl) wrote :

Hi Cesare!

I have tried it using a ipw2200 on Gutsy amd64 and it is able to apply the
choosen profile without any error being displayed.

tested version 0.15-0ubuntu5.2 with rt73(aka RT2501USB) chipset
and can confirm that it works
fixing all issues raised in my original bug description

many thanks!

 I have also tested 0.15-0ubuntu5.2 on rt73 as well. I had the problem described above on 5.1 but resolved with 5.2

Cesare Tirabassi (norsetto) wrote :

Thanks all for testing!
We have 3 positives (plus myself) and more than 7 days have elapsed since the fix is in -proposed therefore I'm asking the archive admins to copy it to gutsy-updates.

Jonathan Riddell (jr) wrote :

Copied 0.15-0ubuntu5.2 to gutsy-updates

Changed in rutilt:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers