rustc 1.47 and cargo 0.47 required by firefox 85

Bug #1901571 reported by Olivier Tilloy
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cargo (Ubuntu)
Undecided
Canonical Foundations Team
Xenial
Undecided
Canonical Foundations Team
Bionic
Undecided
Canonical Foundations Team
Focal
Undecided
Canonical Foundations Team
Groovy
Undecided
Canonical Foundations Team
rustc (Ubuntu)
Undecided
Michael Hudson-Doyle
Xenial
Undecided
Canonical Foundations Team
Bionic
Undecided
Canonical Foundations Team
Focal
Undecided
Canonical Foundations Team
Groovy
Undecided
Canonical Foundations Team

Bug Description

Firefox 85+ will require rustc 1.47 and cargo 0.47 to build¹.

The beta phase for Firefox 85.0 begins on 2020-12-10 and release candidates will be available from 2021-01-21.

We will need these in hirsute and all supported releases (xenial, bionic, focal, and groovy).

¹ https://bugzilla.mozilla.org/show_bug.cgi?id=1671545

Olivier Tilloy (osomon)
Changed in cargo (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in cargo (Ubuntu Xenial):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in cargo (Ubuntu Bionic):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in cargo (Ubuntu Focal):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in cargo (Ubuntu Groovy):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu Xenial):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu Bionic):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu Focal):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu Groovy):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Michael Hudson-Doyle (mwhudson)
status: New → In Progress
tags: added: fr-961
Revision history for this message
Olivier Tilloy (osomon) wrote :

The new rustc requirement is now targetting firefox 85 (https://hg.mozilla.org/mozilla-central/rev/500f3c5615e5), I'm updating the title and description accordingly.

summary: - rustc 1.47 and cargo 0.47 required by firefox 84
+ rustc 1.47 and cargo 0.47 required by firefox 85
description: updated
Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote :

So this is in hirsute or the rust-updates PPA now. Need to rebootstrap rustc on 1.47 on riscv but that's not really relevant for this bug.

Changed in cargo (Ubuntu):
status: New → Fix Committed
Changed in cargo (Ubuntu Bionic):
status: New → Fix Committed
Changed in cargo (Ubuntu Xenial):
status: New → Fix Committed
Changed in cargo (Ubuntu Focal):
status: New → Fix Committed
Changed in cargo (Ubuntu Groovy):
status: New → Fix Committed
Changed in rustc (Ubuntu):
status: In Progress → Fix Committed
Changed in rustc (Ubuntu Xenial):
status: New → Fix Committed
Changed in rustc (Ubuntu Bionic):
status: New → Fix Committed
Changed in rustc (Ubuntu Focal):
status: New → Fix Committed
Changed in rustc (Ubuntu Groovy):
status: New → Fix Committed
Revision history for this message
Olivier Tilloy (osomon) wrote :

Thanks Michael!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cargo - 0.47.0-1~exp1ubuntu1~20.10.1

---------------
cargo (0.47.0-1~exp1ubuntu1~20.10.1) groovy; urgency=medium

  * Backport to Groovy. (LP: #1901571)

 -- Michael Hudson-Doyle <email address hidden> Thu, 10 Dec 2020 20:42:47 +1300

Changed in cargo (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cargo - 0.47.0-1~exp1ubuntu1~20.04.1

---------------
cargo (0.47.0-1~exp1ubuntu1~20.04.1) focal; urgency=medium

  * Backport to Focal. (LP: #1901571)

 -- Michael Hudson-Doyle <email address hidden> Thu, 10 Dec 2020 20:43:34 +1300

Changed in cargo (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cargo - 0.47.0-1~exp1ubuntu1~16.04.1

---------------
cargo (0.47.0-1~exp1ubuntu1~16.04.1) xenial; urgency=medium

  * Backport to Xenial. (LP: #1901571)
  * Drop ssh_key_from_memory from the git2 default features, as that results
    in the libgit2 build depending on a version of libssh2 that is too recent
    - add debian/patches/git2-no-ssh_key_from_memory.patch
    - update debian/patches/series
  * Do not use the http2 feature of the curl crate, and warn rather than fail
    on errors caused by a too-old curl.
    - add debian/patches/ignore-libcurl-errors.patch
    - update debian/patches/series
  * Relax debhelper requirement.

 -- Michael Hudson-Doyle <email address hidden> Fri, 11 Dec 2020 19:30:12 +1300

Changed in cargo (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rustc - 1.47.0+dfsg1+llvm-1ubuntu1~20.04.1

---------------
rustc (1.47.0+dfsg1+llvm-1ubuntu1~20.04.1) focal; urgency=medium

  * Backport to Focal. (LP: #1901571)

 -- Michael Hudson-Doyle <email address hidden> Wed, 09 Dec 2020 11:22:41 +1300

Changed in rustc (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rustc - 1.47.0+dfsg1+llvm-1ubuntu1~18.04.1

---------------
rustc (1.47.0+dfsg1+llvm-1ubuntu1~18.04.1) bionic; urgency=medium

  * Backport to Bionic. (LP: #1901571)
  * Relax debhelper requirement.

 -- Michael Hudson-Doyle <email address hidden> Wed, 09 Dec 2020 11:27:21 +1300

Changed in rustc (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cargo - 0.47.0-1~exp1ubuntu1~18.04.1

---------------
cargo (0.47.0-1~exp1ubuntu1~18.04.1) bionic; urgency=medium

  * Backport to Bionic. (LP: #1901571)
  * Relax debhelper requirement.

 -- Michael Hudson-Doyle <email address hidden> Thu, 10 Dec 2020 20:43:51 +1300

Changed in cargo (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rustc - 1.47.0+dfsg1+llvm-1ubuntu1~16.04.1

---------------
rustc (1.47.0+dfsg1+llvm-1ubuntu1~16.04.1) xenial; urgency=medium

  * Backport to Xenial. (LP: #1901571)
  * Relax the gdb build requirement
    - update debian/control
  * Relax the dependency on xz-utils by commenting out some unused code
    - add debian/patches/d-relax-xz-utils-dependency.patch
    - update debian/patches/series
  * Disable multithreaded compressor in rust-installer
    - adds debian/patches/d-rust-installer-no-threaded-compressor.patch
    - updates debian/patches/series
  * Relax debhelper requirement.
  * Build with clang on armhf to avoid crashes in stage1 compiler
    - updates debian/control
    - updates debian/rules
  * d/patches/clang-3.8-compat.patch: Lightly hack OptParserEmitter.cpp
    to be compatible with clang 3.8.

 -- Michael Hudson-Doyle <email address hidden> Thu, 10 Dec 2020 20:35:42 +1300

Changed in rustc (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rustc - 1.47.0+dfsg1+llvm-1ubuntu1~20.10.1

---------------
rustc (1.47.0+dfsg1+llvm-1ubuntu1~20.10.1) groovy; urgency=medium

  * Backport to Groovy. (LP: #1901571)
  * Build with clang on armhf to avoid crashes building LLVM
    - updates debian/control
    - updates debian/rules

 -- Michael Hudson-Doyle <email address hidden> Wed, 09 Dec 2020 11:02:19 +1300

Changed in rustc (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cargo - 0.47.0-1~exp1ubuntu2

---------------
cargo (0.47.0-1~exp1ubuntu2) hirsute; urgency=medium

  * No change rebuild against new glibc-32 ABI.

 -- Dimitri John Ledkov <email address hidden> Mon, 15 Feb 2021 22:39:26 +0000

Changed in cargo (Ubuntu):
status: Fix Committed → Fix Released
Olivier Tilloy (osomon)
Changed in rustc (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers