rustc 1.43 and cargo 0.44 required by firefox 79

Bug #1876942 reported by Olivier Tilloy on 2020-05-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cargo (Ubuntu)
Undecided
Canonical Foundations Team
Xenial
Undecided
Canonical Foundations Team
Bionic
Undecided
Canonical Foundations Team
Focal
Undecided
Canonical Foundations Team
rustc (Ubuntu)
Undecided
Canonical Foundations Team
Xenial
Undecided
Canonical Foundations Team
Bionic
Undecided
Canonical Foundations Team
Focal
Undecided
Canonical Foundations Team

Bug Description

Firefox 78+ will require rustc 1.43 and cargo 0.44 to build¹.

The beta phase for Firefox 78.0 begins on 2020-05-28 and release candidates will be available from 2020-06-26.

We will need these in groovy and all supported releases (xenial, bionic, eoan and focal).

¹ https://bugzilla.mozilla.org/show_bug.cgi?id=1632723

Olivier Tilloy (osomon) on 2020-05-05
Changed in cargo (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in cargo (Ubuntu Xenial):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in cargo (Ubuntu Bionic):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in cargo (Ubuntu Eoan):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in cargo (Ubuntu Focal):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu Xenial):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu Bionic):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu Eoan):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in rustc (Ubuntu Focal):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
tags: added: id-5eb240342d033a7416baa45f
Michael Hudson-Doyle (mwhudson) wrote :

I've just uploaded rustc 1.42 everywhere, will move onto cargo 0.43 and then rustc 1.43 next. There is a wrinkle around buildability on riscv but that doesn't matter for firefox.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cargo - 0.43.1-3ubuntu1

---------------
cargo (0.43.1-3ubuntu1) groovy; urgency=medium

  * Merge from Debian unstable (LP: #1876942): Remaining changes:
    - Don't use the bootstrap.py script for bootstrapping as it no longer
      works.
      - remove debian/bootstrap.py
      - update debian/make_orig_multi.sh

 -- Michael Hudson-Doyle <email address hidden> Thu, 21 May 2020 21:14:18 +1200

Changed in cargo (Ubuntu):
status: New → Fix Released
Changed in cargo (Ubuntu):
status: Fix Released → In Progress
Łukasz Zemczak (sil2100) wrote :

Hey Michael! Just a quick question: normally we were doing all the rustc uploads via security, meaning those needed building in a security-enabled PPA and then bin-copying. But this time I see you're doing a direct upload to -proposed. Is that on purpose? Did anything change that I am not aware of?

Changed in rustc (Ubuntu):
status: New → Incomplete
Michael Hudson-Doyle (mwhudson) wrote :

Yes that's true. The reason for the proposed upload is that the new rustc does not build on riscv, so getting it into proposed lets us see if this regresses installability of any other packages in focal. Or at least I think this was the idea -- I discussed this with vorlon but didn't write anything down :(

Łukasz Zemczak (sil2100) wrote :

Ok, that makes sense. But I think in this case we would still need this to be built in a security-enabled PPA and then copy it over to -proposed. Since if in the end we'd want to release this into both -updates and -security, we can't do that if we build it against -proposed. So in this case we'd need: upload to security-ppa (or tinkered bileto), bin sync to -proposed, testing in -proposed, release to -updates/-security.

Does that make sense? Or is the plan different?

On Tue, 26 May 2020 at 22:15, Łukasz Zemczak <email address hidden>
wrote:

> Ok, that makes sense. But I think in this case we would still need this
> to be built in a security-enabled PPA and then copy it over to
> -proposed. Since if in the end we'd want to release this into both
> -updates and -security, we can't do that if we build it against
> -proposed. So in this case we'd need: upload to security-ppa (or
> tinkered bileto), bin sync to -proposed, testing in -proposed, release
> to -updates/-security.
>

Oh in that case, reject the one in the queue and copy-with-binaries from
https://launchpad.net/~ubuntu-mozilla-security/+archive/ubuntu/rust-updates/+packages
--
the packages are usually copied from here into -security.

An upload of rustc to focal-proposed has been rejected from the upload queue for the following reason: "Rejected as per request.".

Unfortunately cargo 0.44.1 fails tests on s390x, because rustc 1.43.1 is segfaulting. The traceback is this:

https://paste.ubuntu.com/p/Ckykd9Mvz7/

which looks upsettingly like a real problem :( I'll try to report it upstream next week I guess.

Rico Tzschichholz (ricotz) wrote :

@mwhudson It seems the anticipated requirement bump won't happen for 78. So there is less pressure on this toolchain update. :-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cargo - 0.44.1-0ubuntu1

---------------
cargo (0.44.1-0ubuntu1) groovy; urgency=medium

  * New upstream version. (LP: #1876942)
  * Update scripts/debian-cargo-vendor to invoke python3 and cope with V2
    format Cargo.lock files.
  * Refresh patches.
  * Embed libgit2 1.0.0 which is not yet in Debian or Ubuntu.
    - add debian/libgit2
    - add debian/patches/use-system-libhttp-parser.patch
    - update debian/control
    - update debian/copyright
    - update debiab/patches/series
    - update debian/README.source
    - update debian/rules

 -- Michael Hudson-Doyle <email address hidden> Wed, 24 Jun 2020 12:40:56 +1200

Changed in cargo (Ubuntu):
status: In Progress → Fix Released
Rico Tzschichholz (ricotz) wrote :

Firefox 79 Beta now requires rustc 1.43

https://bugzilla.mozilla.org/show_bug.cgi?id=1648343

summary: - rustc 1.43 and cargo 0.44 required by firefox 78
+ rustc 1.43 and cargo 0.44 required by firefox 79
Olivier Tilloy (osomon) on 2020-07-01
no longer affects: cargo (Ubuntu Eoan)
no longer affects: rustc (Ubuntu Eoan)

I think this is fixed now, fwiw. I'll update the bug status in the morning.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cargo - 0.44.1-0ubuntu1~20.04.1

---------------
cargo (0.44.1-0ubuntu1~20.04.1) focal; urgency=medium

  * Backport to Focal. (LP: #1876942)

 -- Michael Hudson-Doyle <email address hidden> Thu, 25 Jun 2020 07:55:14 +1200

Changed in cargo (Ubuntu Focal):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cargo - 0.44.1-0ubuntu1~18.04.1

---------------
cargo (0.44.1-0ubuntu1~18.04.1) bionic; urgency=medium

  * Backport to Bionic. (LP: #1876942)
  * Relax debhelper requirement.

 -- Michael Hudson-Doyle <email address hidden> Thu, 25 Jun 2020 07:53:54 +1200

Changed in cargo (Ubuntu Bionic):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cargo - 0.44.1-0ubuntu1~16.04.1

---------------
cargo (0.44.1-0ubuntu1~16.04.1) xenial; urgency=medium

  * Backport to Xenial. (LP: #1876942)
  * Drop ssh_key_from_memory from the git2 default features, as that results
    in the libgit2 build depending on a version of libssh2 that is too recent
    - add debian/patches/git2-no-ssh_key_from_memory.patch
    - update debian/patches/series
  * Do not use the http2 feature of the curl crate, and warn rather than fail
    on errors caused by a too-old curl.
    - add debian/patches/ignore-libcurl-errors.patch
    - update debian/patches/series
  * Relax debhelper requirement.

 -- Michael Hudson-Doyle <email address hidden> Thu, 25 Jun 2020 07:53:21 +1200

Changed in cargo (Ubuntu Xenial):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rustc - 1.43.0+dfsg1+llvm-1~exp1ubuntu2~18.04.1

---------------
rustc (1.43.0+dfsg1+llvm-1~exp1ubuntu2~18.04.1) bionic; urgency=medium

  * Backport to Bionic. (LP: #1876942)
  * Relax debhelper requirement.
  * Disable wasm build as build dependencies only available in 20.10.

 -- Michael Hudson-Doyle <email address hidden> Wed, 24 Jun 2020 12:59:50 +1200

Changed in rustc (Ubuntu Bionic):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rustc - 1.43.0+dfsg1+llvm-1~exp1ubuntu2~16.04.1

---------------
rustc (1.43.0+dfsg1+llvm-1~exp1ubuntu2~16.04.1) xenial; urgency=medium

  * Backport to Xenial. (LP: #1876942)
  * Relax the gdb build requirement
    - update debian/control
  * Relax the dependency on xz-utils by commenting out some unused code
    - add debian/patches/d-relax-xz-utils-dependency.patch
    - update debian/patches/series
  * Disable multithreaded compressor in rust-installer
    - adds debian/patches/d-rust-installer-no-threaded-compressor.patch
    - updates debian/patches/series
  * Build with clang on armhf to avoid crashes in stage1 compiler
    - updates debian/control
    - updates debian/rules
  * Relax debhelper requirement.
  * Disable wasm build as build dependencies only available in 20.10.

 -- Michael Hudson-Doyle <email address hidden> Wed, 24 Jun 2020 13:02:11 +1200

Changed in rustc (Ubuntu Xenial):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rustc - 1.43.0+dfsg1+llvm-1~exp1ubuntu1~20.04.1

---------------
rustc (1.43.0+dfsg1+llvm-1~exp1ubuntu1~20.04.1) focal; urgency=medium

  * Backport to Focal. (LP: #1876942)
  * Disable wasm build as build dependencies only available in 20.10.

 -- Michael Hudson-Doyle <email address hidden> Wed, 24 Jun 2020 12:51:21 +1200

Changed in rustc (Ubuntu Focal):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rustc - 1.43.0+dfsg1+llvm-1~exp1ubuntu2

---------------
rustc (1.43.0+dfsg1+llvm-1~exp1ubuntu2) groovy; urgency=medium

  * Fix mismerge preventing tests from running.
  * Backport patch fixing miscompliation and subsequent crash on s390x
    (adapted from https://src.fedoraproject.org/rpms/llvm/pull-request/49):
    - add debian/patches/0001-InstCombine-Fix-big-endian-miscompile-of-bitcast-zex.patch
    - update debian/patches/series

 -- Michael Hudson-Doyle <email address hidden> Tue, 23 Jun 2020 19:35:09 +1200

Changed in rustc (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.