rust-doc from -updates is uninstallable on 16.04 and 18.04

Bug #1721425 reported by Jan Claeys on 2017-10-05
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
rustc (Ubuntu)
Undecided
Canonical Foundations Team

Bug Description

The package 'rust-doc' version '1.17.0+dfsg2-8~ubuntu0.17.04.1' in zesty-updates depends on the package 'fonts-open-sans', which doesn't exist in zesty.

This makes the package uninstallable and prevents upgrades.

Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I can confirm this issue on Ubuntu 17.04, both locally but also as listed on https://packages.ubuntu.com/zesty/rust-doc.

Changed in rustc (Ubuntu):
status: New → Confirmed
tags: added: trusty xenial zesty
Hans Joachim Desserud (hjd) wrote :

Same issue is affecting 16.04 as well as 14.04 and I see that the latter is also lacking libjs-highlight.js https://packages.ubuntu.com/trusty/rust-doc. I suppose this was introduced when rustc was backported to older releases.

Manfred Hampl (m-hampl) wrote :

Why not just backporting fonts-open-sans to the older LTS releases?

Olivier Tilloy (osomon) wrote :

zesty has long been EOL, but xenial is still supported, and similarly affected.

summary: - package rust-doc in zesty depends on package fonts-open-sans which
+ package rust-doc in xenial depends on package fonts-open-sans which
doesn't exist
Changed in rustc (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
summary: - package rust-doc in xenial depends on package fonts-open-sans which
- doesn't exist
+ rust-doc from -updates is uninstallable on 16.04 and 18.04
tags: added: rls-x-incoming
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions