package runit 2.0.0-1ubuntu2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #406621 reported by Kirtis Bakalarczyk on 2009-07-29
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
runit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: runit

This applies to a karmic alpha 3 installation, which is up to date as of July 29, 2009.

I was trying to install git-daemon-run, which apparently depends on runit. The runit installation failed for some reason. The following is from /var/log/apt/term.log

Log started: 2009-07-29 17:29:40
Setting up runit (2.0.0-1ubuntu2) ...
start: Unknown job: runsvdir
dpkg: error processing runit (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of git-daemon-run:
 git-daemon-run depends on runit (>= 1.8.0-2); however:
  Package runit is not configured yet.
dpkg: error processing git-daemon-run (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 runit
 git-daemon-run
Log ended: 2009-07-29 17:29:41

ProblemType: Package
Architecture: amd64
Date: Wed Jul 29 17:28:36 2009
Dependencies:

DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 1
Package: runit 2.0.0-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
SourcePackage: runit
Title: package runit 2.0.0-1ubuntu2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
Uname: Linux 2.6.31-3-generic x86_64

Related branches

description: updated
Joshua Timberman (jtimberman) wrote :

It looks like the problem is that the runit package is using the old upstart directory, /etc/event.d/ for runsvdir. I copied the file to /etc/init and runit was able to start.

$ sudo initctl start runsvdir
initctl: Unknown job: runsvdir
$ sudo initctl list | grep runsvdir
$ sudo cp /etc/event.d/runsvdir /etc/init/runsvdir.conf
$ sudo initctl list | grep runsvdir
runsvdir stop/waiting
$ sudo start runsvdir
runsvdir start/running, process 9531

A patch is attached that fixes the directory location of the runsvdir file in the package's rules file on karmic.

Changed in runit (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package runit - 2.0.0-1ubuntu3

---------------
runit (2.0.0-1ubuntu3) karmic; urgency=low

  * Place upstart script in the correct directory with the correct name (LP: #406621)

 -- Thom May <email address hidden> Wed, 12 Aug 2009 10:07:55 +0100

Changed in runit (Ubuntu):
status: Confirmed → Fix Released
Kenny Strawn (realkstrawn93) wrote :

Someone nominate this bug for Raring; it's revealing its ugly head again...

geek.de.nz (th-heuer) wrote :

For me this was triggered by installing the package git-all.

This fixed my problem:

sudo apt-get remove git git-all
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade

geek.de.nz (th-heuer) wrote :

You can then install just git:
sudo apt-get install git

and add any git packages you need but not more.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers