package runit 2.1.2-3ubuntu1 failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück

Bug #1703220 reported by Rudolf Ziegaus on 2017-07-09
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
runit (Ubuntu)
Undecided
Unassigned

Bug Description

1)
Description: Ubuntu 16.04.2 LTS
Release: 16.04

2)
runit:
  Installiert: 2.1.2-3ubuntu1
  Installationskandidat: 2.1.2-3ubuntu1
  Versionstabelle:
 *** 2.1.2-3ubuntu1 500
        500 http://de.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

This error message shows up after starting the system. It says than an unexpected error happened.
I get a similar error when I try to update my system via apt-get update.
The error message says there is an error for git-daemon-run (--configure) but that seems to be an error due to previous error:

runit (2.1.2-3ubuntu1) wird eingerichtet ...
start: Verbindung zu Upstart nicht möglich: Failed to connect to socket /com/ubuntu/upstart: Verbindungsaufbau abgelehnt
dpkg: Fehler beim Bearbeiten des Paketes runit (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von git-daemon-run:
 git-daemon-run hängt ab von runit; aber:
  Paket runit ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes git-daemon-run (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Es wurde kein Apport-Bericht verfasst, da die Fehlermeldung darauf hindeutet, dass dies lediglich ein Folgefehler eines vorherigen Problems ist.
                                                                Fehler traten auf beim Bearbeiten von:
 runit
 git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)

The problem seems to occur when configuring runit - it can't connect to /com/ubuntu/upstart (connection refused).

What can I do about this error? It occurs since I tried to install git. git itself is running (version 2.7.4) but I always get this annoying error.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: runit 2.1.2-3ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-58.63~16.04.1-generic 4.8.17
Uname: Linux 4.8.0-58-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.6
Architecture: amd64
Date: Sun Jul 9 14:36:23 2017
Dependencies:
 fgetty 0.7-1
 gcc-6-base 6.0.1-0ubuntu1
 libc6 2.23-0ubuntu9
 libgcc1 1:6.0.1-0ubuntu1
ErrorMessage: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
InstallationDate: Installed on 2017-04-22 (77 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215.2)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt 1.2.20
SourcePackage: runit
Title: package runit 2.1.2-3ubuntu1 failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
UpgradeStatus: No upgrade log present (probably fresh install)

Rudolf Ziegaus (rz259) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in runit (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers