adt test was insufficient to catch failed docker.io on s390x

Bug #1658150 reported by Dimitri John Ledkov on 2017-01-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
docker.io (Ubuntu)
Undecided
Unassigned
runc (Ubuntu)
High
Dimitri John Ledkov

Bug Description

adt test was insufficient to catch failed docker.io on s390x

https://bugs.launchpad.net/ubuntu/+source/runc/+bug/1658009

Changed in runc (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Tyler Hicks (tyhicks) wrote :

I've subscribed ubuntu-archive, at nacc's suggestion, as the fix for this bug is blocked due to a test failure on armhf. xnox's changelog entry describes the situation on armhf and that the test failure is known/expected. The hope is that someone on the ubuntu-archive team can hint the armhf failure away and leave a link to this bug and/or xnox's changelog entry.

Tyler Hicks (tyhicks) wrote :

Switched the subscription from ubuntu-archive to ubuntu-release since that's who is in charge of hinting.

Iain Lane (laney) wrote :

This was confusing because the bug is filed against 'runc', but you're asking for a skip of 'docker.io'.

I'll put that in place for this upload, but IMHO it's better documentation if you 'expect' a test to fail to express that in the test itself: on armhf, make the test be skipped (with or without running it, as you see fit).

ubuntu-fan still has a failure that needs fixing, so docker.io isn't going to migrate.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 1.12.6-0ubuntu4

---------------
docker.io (1.12.6-0ubuntu4) zesty; urgency=medium

  * Revert 1.12.6-0ubuntu2 as it does not achieve the stated goal on both
    s390x and armhf. And lxc/lxd adt runners are too restrictive to
    e.g. import an ubuntu-base container for a minimal functional test.

 -- Dimitri John Ledkov <email address hidden> Tue, 14 Mar 2017 09:41:30 +0000

Changed in docker.io (Ubuntu):
status: New → Fix Released
Changed in docker.io (Ubuntu):
status: Fix Released → Confirmed
Changed in runc (Ubuntu):
milestone: ubuntu-17.02 → ubuntu-17.05
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 1.13.1-0ubuntu1~16.04.2

---------------
docker.io (1.13.1-0ubuntu1~16.04.2) xenial; urgency=medium

  * Rebuild with golang-1.6 1.6.2-0ubuntu5~16.04.4 which uses the correct page
    size on arm64 for use with Ubuntu kernels. (LP: #1702979)

docker.io (1.13.1-0ubuntu1~16.04.1) xenial; urgency=medium

  * Backport to Xenial. (LP: #1712954)
  * Install the service file with .install again, fixing service activation
    on install.
  * Use golang.org/x/net/context instead of stdlib context to enable building
    with Go 1.6.

 -- Michael Hudson-Doyle <email address hidden> Thu, 02 Nov 2017 11:43:13 +1300

Changed in docker.io (Ubuntu):
status: Confirmed → Fix Released
Iain Lane (laney) wrote :

unsubscribing ubuntu-release; not sure what there is for us to do here - please take this bug from there :-)

Michael Hudson-Doyle (mwhudson) wrote :

We run full autopkgtests on all architectures now so closing.

Changed in runc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers