rubygems-integration does not see newer versions of a gem

Bug #1405108 reported by Wybo Dekker on 2014-12-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rubygems-integration (Ubuntu)
Undecided
Unassigned

Bug Description

In Xubuntu 14.10, Ruby 2.1.2, when I install package ruby-colorize, I get colorize-0.6.0.
This version has bugs.
When I then install version 0.7.5 (the newest version) with:

$ gem install -r colorize

I have both version 0.6.0 and version 0.7.5 and I expect that the ruby statement:

require 'colorize'

will load version 0.7.5
This is not true: version 0.6.0 is loaded.
I can solve that by uninstalling the ruby-colorize package, which should not be
necessary.

I suspect (but am not sure) that the rubygems-integration package is the cause
of this problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers