autopkgtest fails in bionic

Bug #1907955 reported by Balint Reczey
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Auto Package Testing
Fix Released
Undecided
Unassigned
ruby2.5 (Ubuntu)
Invalid
Undecided
Unassigned
Bionic
Fix Released
Undecided
Unassigned
Focal
Invalid
Undecided
Unassigned

Bug Description

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/amd64/r/ruby2.5/20201213_113027_86a64@/log.gz

...
Finished
--------
   Tests executed: 748
             PASS: 712
             FAIL: 3
EXPECTED FAILURES: 33

autopkgtest [11:29:55]: test run-all: -----------------------]
run-all FAIL non-zero exit status 1
...

Revision history for this message
Balint Reczey (rbalint) wrote :

The test is passing locally, this may be only a proxy setting issue.

Revision history for this message
Balint Reczey (rbalint) wrote :

[21/21] URI::TestGeneric#test_use_proxy_p = 0.00 s

  1) Failure:
URI::TestGeneric#test_find_proxy [/tmp/autopkgtest.RLBJhW/autopkgtest_tmp/test/uri/test_generic.rb:830]:
<#<URI::HTTP http://127.0.0.1:8080>> expected but was
<nil>.

  2) Failure:
URI::TestGeneric#test_find_proxy_case_sensitive_env [/tmp/autopkgtest.RLBJhW/autopkgtest_tmp/test/uri/test_generic.rb:909]:
<#<URI::HTTP http://127.0.0.1:8080>> expected but was
<nil>.

  3) Failure:
URI::TestGeneric#test_find_proxy_get [/tmp/autopkgtest.RLBJhW/autopkgtest_tmp/test/uri/test_generic.rb:844]:
<#<URI::HTTP http://127.0.0.1:8080>> expected but was
<nil>.

Finished tests in 0.129418s, 162.2644 tests/s, 3623.9042 assertions/s.
21 tests, 469 assertions, 3 failures, 0 errors, 0 skips

Changed in ruby2.5 (Ubuntu Focal):
status: New → Invalid
Changed in ruby2.5 (Ubuntu):
status: New → Invalid
Balint Reczey (rbalint)
tags: added: update-excuse-bionic
removed: update-excuse
Revision history for this message
Lucas Kanashiro (lucaskanashiro) wrote :

As you may have noticed the ruby2.5 tests were fixed on Bionic in version 2.5.1-1ubuntu1.7 (accepted in Dec 1st). I am wondering if this is nothing related to the glibc changes because the same tests passed during the SRU process (you can see the log here [1]), and the test log above mention 127.0.0.1 as something expected and 127.0.0.1 is already added to the $no_proxy (check the autopkgtest call in the log you linked).

Anyway, I am going to tweak the $no_proxy content and try to re-trigger the test on LP to see if it can get sorted out.

[1] https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/amd64/r/ruby2.5/20201124_211114_f8f94@/log.gz

Revision history for this message
Balint Reczey (rbalint) wrote :

I don't think it is related to glibc changes, it is failing in the release pocket. I saw several new proxy related failures, so I suspect an infra change triggered that.

Revision history for this message
Iain Lane (laney) wrote :

can you link to the several please?

We made a change to proxy handling recently, so you might want to follow up with Steve, in case that is wrong in some way:

https://git.launchpad.net/autopkgtest-cloud/commit/?id=f3679e7609b2f03d59aca28fe7329e4228350200

Revision history for this message
Balint Reczey (rbalint) wrote :

Maybe a dup of LP: #1908136.

Iain Lane (laney)
Changed in auto-package-testing:
status: New → Fix Released
Revision history for this message
Lucas Kanashiro (lucaskanashiro) wrote :

The last test re-trigger from laney passed so I am considering this is not an issue anymore.

Changed in ruby2.5 (Ubuntu Bionic):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers