ruby uses broken internal get/setcontext routines on precise/ARM

Bug #1021604 reported by Adam Conrad on 2012-07-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ruby1.9.1 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Adam Conrad

Bug Description

[Impact]

On precise/arm*, we had to disable ruby's testsuite so that it would build. The reason for this was that, at the time, precise's eglibc didn't have get/setcontext routines for ARM, and ruby was forced to select its own (broken) implementation instead.

Later in the precise development, eglibc grew support for get/setcontext on ARM, but we never rebuilt ruby to pick this up and fix itself. The obvious solution to this is to turn on the testsuite again and SRU so a rebuilt ruby fixes itself on ARM.

[Testcase]

If ruby passes its testsuite on both ARM builds, it's clearly ahead of where it was before, and that's pretty much all the test needed to prove the above is fixed.

[Regression Potential]

For all arches other than ARM, this is just a rebuild with precise's current toolchain. For ARM, this is a rebuild that will flip ruby from using a broken internal implementation to using a much saner glibc implementation of the same thing, so any potential for regression here is between nonexistant and tiny.

Adam Conrad (adconrad) wrote :

This is already fixed in Quantal, as newer versions of ruby have been synced from Debian since our eglibc was fixed.

Changed in ruby1.9.1 (Ubuntu):
status: New → Fix Released
Changed in ruby1.9.1 (Ubuntu Precise):
assignee: nobody → Adam Conrad (adconrad)

Hello Adam, or anyone else affected,

Accepted ruby1.9.1 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ruby1.9.1/1.9.3.0-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ruby1.9.1 (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

The testsuite passed on all arches, and I did a quick smoketest install on all arches, and the packages seem sane. Not sure there's much more validation required here, given that there were no code changes, so I call it good.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ruby1.9.1 - 1.9.3.0-1ubuntu2

---------------
ruby1.9.1 (1.9.3.0-1ubuntu2) precise; urgency=low

  * Revert the previous upload, re-enabling the testsuite on ARM,
    which should now work as we're rebuilding against a version
    of eglibc with a working getcontext/setcontext (LP: #1021604)
 -- Adam Conrad <email address hidden> Fri, 06 Jul 2012 00:42:46 -0600

Changed in ruby1.9.1 (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers