ruby1.8: ruby crashes, preventing Apache2 from being used

Bug #22521 reported by Debian Bug Importer on 2005-09-25
4
Affects Status Importance Assigned to Milestone
ruby1.8 (Debian)
Fix Released
Unknown
ruby1.8 (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #330070 http://bugs.debian.org/330070

Vincent Lefevre wrote:
> Package: ruby1.8
> Version: 1.8.2-9
> Severity: grave
> Justification: renders package unusable
>
> I get the following error:
>
> # /etc/init.d/apache2 start
> Starting web server: Apache2/usr/sbin/apache2ctl: line 78: 26554 Aborted
> (core dumped) $HTTPD -k start -DSSL

ruby1.8_1.8.3-1 is in unstable. please try it.
If you get SEGV with 1.8.3-1, please send the backtrace.

Thank you.
--
akira yamada

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #330070 http://bugs.debian.org/330070

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 25 Sep 2005 19:09:37 +0200
From: Vincent Lefevre <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: ruby1.8: ruby crashes, preventing Apache2 from being used

Package: ruby1.8
Version: 1.8.2-9
Severity: grave
Justification: renders package unusable

I get the following error:

# /etc/init.d/apache2 start
Starting web server: Apache2/usr/sbin/apache2ctl: line 78: 26554 Aborted
         (core dumped) $HTTPD -k start -DSSL

/var/log/apache2/error.log contains:

ruby: [BUG] Segmentation fault
ruby 1.8.3 (2005-06-23) [powerpc-linux]

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (900, 'testing'), (900, 'stable'), (200, 'unstable')
Architecture: powerpc (ppc)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-20050829
Locale: LANG=POSIX, LC_CTYPE=en_US.ISO8859-1 (charmap=ISO-8859-1)

Versions of packages ruby1.8 depends on:
ii libc6 2.3.5-6 GNU C Library: Shared libraries an
ii libruby1.8 1.8.2-9 Libraries necessary to run Ruby 1.

ruby1.8 recommends no packages.

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 26 Sep 2005 02:47:02 +0900
From: akira yamada <email address hidden>
To: Vincent Lefevre <email address hidden>, <email address hidden>
Cc: Debian Bug Tracking System <email address hidden>
Subject: Re: Bug#330070: ruby1.8: ruby crashes, preventing Apache2 from being
 used

Vincent Lefevre wrote:
> Package: ruby1.8
> Version: 1.8.2-9
> Severity: grave
> Justification: renders package unusable
>
> I get the following error:
>
> # /etc/init.d/apache2 start
> Starting web server: Apache2/usr/sbin/apache2ctl: line 78: 26554 Aborted
> (core dumped) $HTTPD -k start -DSSL

ruby1.8_1.8.3-1 is in unstable. please try it.
If you get SEGV with 1.8.3-1, please send the backtrace.

Thank you.
--
akira yamada

I'm closing the bug since I still got a crash without xmlrpc (but
nothing written to error.log), and the crash disappeared after
removing mod_perl and reenabling xmlrpc. So, I assume that mod_perl
was making ruby crash (or something got wrong in the logs).

--
Vincent Lefèvre <email address hidden> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / SPACES project at LORIA

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 25 Sep 2005 21:37:11 +0200
From: Vincent Lefevre <email address hidden>
To: akira yamada <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#330070: ruby1.8: ruby crashes, preventing Apache2 from being used

I'm closing the bug since I still got a crash without xmlrpc (but
nothing written to error.log), and the crash disappeared after
removing mod_perl and reenabling xmlrpc. So, I assume that mod_perl
was making ruby crash (or something got wrong in the logs).

--
Vincent Lef�e <email address hidden> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / SPACES project at LORIA

perl/mod_perl screwage in sid..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.