libgettext-ruby-util: rgettext does not work

Bug #20653 reported by Debian Bug Importer on 2005-08-31
4
Affects Status Importance Assigned to Milestone
ruby1.8 (Debian)
Fix Released
Unknown
ruby1.8 (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #321189 http://bugs.debian.org/321189

CVE References

reassign 321189 irb1.8
thanks.

>>> In Message "Bug#321189: libgettext-ruby-util: rgettext does not work"
>>> <email address hidden>,
>>> Taku YASUI <email address hidden> said;
> I ran rgettext but it does not work anyway.

> libgettext-ruby-0.8.1% rgettext bin/rgettext -o rgettext.pot
> numeric literal without digits

That problem comes from lexer of irb.

$ echo "0" | ruby -rirb/ruby-lex -e 'RubyLex.new.lex'
/usr/lib/ruby/1.8/irb/ruby-lex.rb:970:in `identify_number': numeric literal without digits (RubyLex::SyntaxError)
        from /usr/lib/ruby/1.8/irb/ruby-lex.rb:721:in `lex_int2'
        from /usr/lib/ruby/1.8/irb/ruby-lex.rb:717:in `call'
        from /usr/lib/ruby/1.8/irb/slex.rb:237:in `match_io'
        from /usr/lib/ruby/1.8/irb/slex.rb:76:in `match'
        from /usr/lib/ruby/1.8/irb/ruby-lex.rb:287:in `token'
        from /usr/lib/ruby/1.8/irb/ruby-lex.rb:263:in `lex'
        from -e:1

fixed in upstream,
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-dev/26410
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-dev/26413

--
Tatsuki Sugiura mailto:<email address hidden>

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #321189 http://bugs.debian.org/321189

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Thu, 04 Aug 2005 08:42:36 +0900
From: Taku YASUI <email address hidden>
To: <email address hidden>
Subject: libgettext-ruby-util: rgettext does not work

Package: libgettext-ruby-util
Version: 0.8.1-2
Severity: grave
Tags: sid

I ran rgettext but it does not work anyway.

libgettext-ruby-0.8.1% rgettext bin/rgettext -o rgettext.pot
numeric literal without digits

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.11-rc4-swsusp-2.1.7-pcc
Locale: LANG=ja_JP.EUC-JP, LC_CTYPE=ja_JP.EUC-JP (charmap=EUC-JP)

Versions of packages libgettext-ruby-util depends on:
ii irb 1.8.2-1 Interactive Ruby (irb)
ii libgettext-ruby1.8 [libgettex 0.8.1-2 Gettext for ruby1.8
ii ruby 1.8.2-1 An interpreter of object-oriented

libgettext-ruby-util recommends no packages.

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 06 Aug 2005 13:46:51 +0900
From: Tatsuki Sugiura <email address hidden>
To: Taku YASUI <email address hidden>,
 <email address hidden>,
 <email address hidden>
Subject: Re: Bug#321189: libgettext-ruby-util: rgettext does not work

reassign 321189 irb1.8
thanks.

>>> In Message "Bug#321189: libgettext-ruby-util: rgettext does not work"
>>> <email address hidden>,
>>> Taku YASUI <email address hidden> said;
> I ran rgettext but it does not work anyway.

> libgettext-ruby-0.8.1% rgettext bin/rgettext -o rgettext.pot
> numeric literal without digits

That problem comes from lexer of irb.

$ echo "0" | ruby -rirb/ruby-lex -e 'RubyLex.new.lex'
/usr/lib/ruby/1.8/irb/ruby-lex.rb:970:in `identify_number': numeric literal without digits (RubyLex::SyntaxError)
        from /usr/lib/ruby/1.8/irb/ruby-lex.rb:721:in `lex_int2'
        from /usr/lib/ruby/1.8/irb/ruby-lex.rb:717:in `call'
        from /usr/lib/ruby/1.8/irb/slex.rb:237:in `match_io'
        from /usr/lib/ruby/1.8/irb/slex.rb:76:in `match'
        from /usr/lib/ruby/1.8/irb/ruby-lex.rb:287:in `token'
        from /usr/lib/ruby/1.8/irb/ruby-lex.rb:263:in `lex'
        from -e:1

fixed in upstream,
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-dev/26410
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-dev/26413

--
Tatsuki Sugiura mailto:<email address hidden>

Matt Zimmerman (mdz) wrote :

     irb1.8 | 1.8.2-9 | http://us.archive.ubuntu.com breezy/universe Packages

Download full text (6.5 KiB)

Source: ruby1.8
Source-Version: 1.8.3-1

We believe that the bug you reported is fixed in the latest version of
ruby1.8, which is due to be installed in the Debian FTP archive:

irb1.8_1.8.3-1_all.deb
  to pool/main/r/ruby1.8/irb1.8_1.8.3-1_all.deb
libdbm-ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libdbm-ruby1.8_1.8.3-1_i386.deb
libgdbm-ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libgdbm-ruby1.8_1.8.3-1_i386.deb
libopenssl-ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libopenssl-ruby1.8_1.8.3-1_i386.deb
libreadline-ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libreadline-ruby1.8_1.8.3-1_i386.deb
libruby1.8-dbg_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libruby1.8-dbg_1.8.3-1_i386.deb
libruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libruby1.8_1.8.3-1_i386.deb
libtcltk-ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libtcltk-ruby1.8_1.8.3-1_i386.deb
rdoc1.8_1.8.3-1_all.deb
  to pool/main/r/ruby1.8/rdoc1.8_1.8.3-1_all.deb
ri1.8_1.8.3-1_all.deb
  to pool/main/r/ruby1.8/ri1.8_1.8.3-1_all.deb
ruby1.8-dev_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/ruby1.8-dev_1.8.3-1_i386.deb
ruby1.8-elisp_1.8.3-1_all.deb
  to pool/main/r/ruby1.8/ruby1.8-elisp_1.8.3-1_all.deb
ruby1.8-examples_1.8.3-1_all.deb
  to pool/main/r/ruby1.8/ruby1.8-examples_1.8.3-1_all.deb
ruby1.8_1.8.3-1.diff.gz
  to pool/main/r/ruby1.8/ruby1.8_1.8.3-1.diff.gz
ruby1.8_1.8.3-1.dsc
  to pool/main/r/ruby1.8/ruby1.8_1.8.3-1.dsc
ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/ruby1.8_1.8.3-1_i386.deb
ruby1.8_1.8.3.orig.tar.gz
  to pool/main/r/ruby1.8/ruby1.8_1.8.3.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
akira yamada <email address hidden> (supplier of updated ruby1.8 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Wed, 21 Sep 2005 12:43:50 +0900
Source: ruby1.8
Binary: libtcltk-ruby1.8 libruby1.8-dbg rdoc1.8 libgdbm-ruby1.8 ruby1.8-dev ruby1.8-elisp ruby1.8-examples libdbm-ruby1.8 irb1.8 ruby1.8 libreadline-ruby1.8 libopenssl-ruby1.8 libruby1.8 ri1.8
Architecture: source i386 all
Version: 1.8.3-1
Distribution: unstable
Urgency: high
Maintainer: akira yamada <email address hidden>
Changed-By: akira yamada <email address hidden>
Description:
 irb1.8 - Interactive Ruby (for Ruby 1.8)
 libdbm-ruby1.8 - DBM interface for Ruby 1.8
 libgdbm-ruby1.8 - GDBM interface for Ruby 1.8
 libopenssl-ruby1.8 - OpenSSL interface for Ruby 1.8
 libreadline-ruby1.8 - Readline interface for Ruby 1.8
 libruby1.8 - Libraries necessary to run Ruby 1.8
 libruby1.8-dbg - Debugging libraries for Ruby 1.8
 libtcltk-ruby1.8 - Tcl/Tk interface for Ruby 1.8
 rdoc1.8 - Generate documentation from Ruby source files (for Ruby 1.8)
 ri1.8 - Ruby Interactive reference (for Ruby 1.8)
 ruby1.8 - Inte...

Read more...

Debian Bug Importer (debzilla) wrote :
Download full text (6.7 KiB)

Message-Id: <email address hidden>
Date: Tue, 20 Sep 2005 21:47:14 -0700
From: akira yamada <email address hidden>
To: <email address hidden>
Subject: Bug#321189: fixed in ruby1.8 1.8.3-1

Source: ruby1.8
Source-Version: 1.8.3-1

We believe that the bug you reported is fixed in the latest version of
ruby1.8, which is due to be installed in the Debian FTP archive:

irb1.8_1.8.3-1_all.deb
  to pool/main/r/ruby1.8/irb1.8_1.8.3-1_all.deb
libdbm-ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libdbm-ruby1.8_1.8.3-1_i386.deb
libgdbm-ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libgdbm-ruby1.8_1.8.3-1_i386.deb
libopenssl-ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libopenssl-ruby1.8_1.8.3-1_i386.deb
libreadline-ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libreadline-ruby1.8_1.8.3-1_i386.deb
libruby1.8-dbg_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libruby1.8-dbg_1.8.3-1_i386.deb
libruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libruby1.8_1.8.3-1_i386.deb
libtcltk-ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/libtcltk-ruby1.8_1.8.3-1_i386.deb
rdoc1.8_1.8.3-1_all.deb
  to pool/main/r/ruby1.8/rdoc1.8_1.8.3-1_all.deb
ri1.8_1.8.3-1_all.deb
  to pool/main/r/ruby1.8/ri1.8_1.8.3-1_all.deb
ruby1.8-dev_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/ruby1.8-dev_1.8.3-1_i386.deb
ruby1.8-elisp_1.8.3-1_all.deb
  to pool/main/r/ruby1.8/ruby1.8-elisp_1.8.3-1_all.deb
ruby1.8-examples_1.8.3-1_all.deb
  to pool/main/r/ruby1.8/ruby1.8-examples_1.8.3-1_all.deb
ruby1.8_1.8.3-1.diff.gz
  to pool/main/r/ruby1.8/ruby1.8_1.8.3-1.diff.gz
ruby1.8_1.8.3-1.dsc
  to pool/main/r/ruby1.8/ruby1.8_1.8.3-1.dsc
ruby1.8_1.8.3-1_i386.deb
  to pool/main/r/ruby1.8/ruby1.8_1.8.3-1_i386.deb
ruby1.8_1.8.3.orig.tar.gz
  to pool/main/r/ruby1.8/ruby1.8_1.8.3.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
akira yamada <email address hidden> (supplier of updated ruby1.8 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Wed, 21 Sep 2005 12:43:50 +0900
Source: ruby1.8
Binary: libtcltk-ruby1.8 libruby1.8-dbg rdoc1.8 libgdbm-ruby1.8 ruby1.8-dev ruby1.8-elisp ruby1.8-examples libdbm-ruby1.8 irb1.8 ruby1.8 libreadline-ruby1.8 libopenssl-ruby1.8 libruby1.8 ri1.8
Architecture: source i386 all
Version: 1.8.3-1
Distribution: unstable
Urgency: high
Maintainer: akira yamada <email address hidden>
Changed-By: akira yamada <email address hidden>
Description:
 irb1.8 - Interactive Ruby (for Ruby 1.8)
 libdbm-ruby1.8 - DBM interface for Ruby 1.8
 libgdbm-ruby1.8 - GDBM interface for Ruby 1.8
 libopenssl-ruby1.8 - OpenSSL interface for Ruby 1.8
 libreadline-ruby1.8 - Readline interface for Ruby 1.8
 libruby1.8 - Libraries necessary to run Ruby 1.8
 libruby1.8-dbg - Debugging libraries for Rub...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.