ruby1.8: autoload fails with 'wrong argument type'

Bug #11787 reported by Debian Bug Importer on 2005-01-09
4
Affects Status Importance Assigned to Milestone
ruby1.8 (Debian)
Fix Released
Unknown
ruby1.8 (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #289302 http://bugs.debian.org/289302

reassign 289302 libruby1.8
retitle 289302 ruby1.8: autoload fails with 'wrong argument type'
severity 289302 serious
thanks

* Yusei [Sat, 08 Jan 2005 12:47:18 +0100]:
> Package: irb1.8
> Version: 1.8.2-1

> I get this error when I try to launch irb1.8:

> $ irb1.8
> /usr/lib/ruby/1.8/irb/locale.rb:13:in `autoload': wrong argument type
> false (expected Class) (TypeError)
> from /usr/lib/ruby/1.8/irb/locale.rb:13
> from /usr/lib/ruby/1.8/irb.rb:21:in `require'
> from /usr/lib/ruby/1.8/irb.rb:21
> from /usr/bin/irb1.8:10:in `require'
> from /usr/bin/irb1.8:10

> I used it yesterday, so it broke with the upgrade to 1.8.2-1

  I can reproduce this. As the version in sarge works fine, this is a
  regression, and thus I'm raising the severity this bug to RC (with the
  approval of a member of the Release Team).

  I've reasigned to libruby1.8 too, since that's where the problem is.
  Downgrading libruby1.8 to 1.8.1+1.8.2pre4-1 is a temporary workaround.

  Thanks for reporting.

--
Adeodato Simó
    EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621

He who has not a good memory should never take upon himself the trade of lying.
                -- Michel de Montaigne

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #289302 http://bugs.debian.org/289302

Debian Bug Importer (debzilla) wrote :

Message-Id: <1105184838.10754.8.camel@lapondux>
Date: Sat, 08 Jan 2005 12:47:18 +0100
From: Yusei <email address hidden>
To: <email address hidden>
Subject: irb1.8 broken in unstable

Package: irb1.8
Version: 1.8.2-1

I get this error when I try to launch irb1.8:

$ irb1.8
/usr/lib/ruby/1.8/irb/locale.rb:13:in `autoload': wrong argument type
false (expected Class) (TypeError)
        from /usr/lib/ruby/1.8/irb/locale.rb:13
        from /usr/lib/ruby/1.8/irb.rb:21:in `require'
        from /usr/lib/ruby/1.8/irb.rb:21
        from /usr/bin/irb1.8:10:in `require'
        from /usr/bin/irb1.8:10

I used it yesterday, so it broke with the upgrade to 1.8.2-1

I'm using version 1.8.2-1 of ruby, too, on x86.
Thanks.

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 9 Jan 2005 14:54:53 +0100
From: Adeodato =?iso-8859-1?Q?Sim=F3?= <email address hidden>
To: <email address hidden>, Yusei <email address hidden>
Cc: <email address hidden>
Subject: Re: irb1.8 broken in unstable

reassign 289302 libruby1.8
retitle 289302 ruby1.8: autoload fails with 'wrong argument type'
severity 289302 serious
thanks

* Yusei [Sat, 08 Jan 2005 12:47:18 +0100]:
> Package: irb1.8
> Version: 1.8.2-1

> I get this error when I try to launch irb1.8:

> $ irb1.8
> /usr/lib/ruby/1.8/irb/locale.rb:13:in `autoload': wrong argument type
> false (expected Class) (TypeError)
> from /usr/lib/ruby/1.8/irb/locale.rb:13
> from /usr/lib/ruby/1.8/irb.rb:21:in `require'
> from /usr/lib/ruby/1.8/irb.rb:21
> from /usr/bin/irb1.8:10:in `require'
> from /usr/bin/irb1.8:10

> I used it yesterday, so it broke with the upgrade to 1.8.2-1

  I can reproduce this. As the version in sarge works fine, this is a
  regression, and thus I'm raising the severity this bug to RC (with the
  approval of a member of the Release Team).

  I've reasigned to libruby1.8 too, since that's where the problem is.
  Downgrading libruby1.8 to 1.8.1+1.8.2pre4-1 is a temporary workaround.

  Thanks for reporting.

--
Adeodato Sim� EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621

He who has not a good memory should never take upon himself the trade of lying.
                -- Michel de Montaigne

# Automatically generated email from bts, devscripts version 2.8.5
 # tagging according to bug report
tags 289302 sid

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Mon, 10 Jan 2005 15:31:29 +0100
From: Frank Lichtenheld <email address hidden>
To: <email address hidden>
Subject: tagging 289302

# Automatically generated email from bts, devscripts version 2.8.5
 # tagging according to bug report
tags 289302 sid

Hi

I found a patch mentioned which may solve the problem quickly (and
it is small).
See: http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-core/4101

I've this is already known to the maintainer, then I have not said a
thing.

Greetings,
Missing irb ;),

Paul

--
Student @ Eindhoven | JID: <email address hidden>
University of Technology, The Netherlands | email: <email address hidden>
>>> Using the Power of Debian GNU/Linux <<< | GnuPG: finger <email address hidden>

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 10 Jan 2005 23:42:48 +0100
From: Paul van Tilburg <email address hidden>
To: <email address hidden>
Subject: irb1.8 has broken before with Ruby 1.8.2 CVS

Hi

I found a patch mentioned which may solve the problem quickly (and
it is small).
See: http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-core/4101

I've this is already known to the maintainer, then I have not said a
thing.

Greetings,
Missing irb ;),

Paul

--
Student @ Eindhoven | JID: <email address hidden>
University of Technology, The Netherlands | email: <email address hidden>
>>> Using the Power of Debian GNU/Linux <<< | GnuPG: finger <email address hidden>

Download full text (10.3 KiB)

Source: ruby1.8
Source-Version: 1.8.2-2

We believe that the bug you reported is fixed in the latest version of
ruby1.8, which is due to be installed in the Debian FTP archive:

irb1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/irb1.8_1.8.2-2_all.deb
libbigdecimal-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libbigdecimal-ruby1.8_1.8.2-2_i386.deb
libcurses-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libcurses-ruby1.8_1.8.2-2_i386.deb
libdbm-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libdbm-ruby1.8_1.8.2-2_i386.deb
libdl-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libdl-ruby1.8_1.8.2-2_i386.deb
libdrb-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/libdrb-ruby1.8_1.8.2-2_all.deb
liberb-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/liberb-ruby1.8_1.8.2-2_all.deb
libgdbm-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libgdbm-ruby1.8_1.8.2-2_i386.deb
libiconv-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libiconv-ruby1.8_1.8.2-2_i386.deb
libopenssl-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libopenssl-ruby1.8_1.8.2-2_i386.deb
libpty-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libpty-ruby1.8_1.8.2-2_i386.deb
libracc-runtime-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libracc-runtime-ruby1.8_1.8.2-2_i386.deb
libreadline-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libreadline-ruby1.8_1.8.2-2_i386.deb
librexml-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/librexml-ruby1.8_1.8.2-2_all.deb
libruby1.8-dbg_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8-dbg_1.8.2-2_i386.deb
libruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8_1.8.2-2_i386.deb
libsdbm-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libsdbm-ruby1.8_1.8.2-2_i386.deb
libsoap-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/libsoap-ruby1.8_1.8.2-2_all.deb
libstrscan-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libstrscan-ruby1.8_1.8.2-2_i386.deb
libsyslog-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libsyslog-ruby1.8_1.8.2-2_i386.deb
libtcltk-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libtcltk-ruby1.8_1.8.2-2_i386.deb
libtest-unit-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/libtest-unit-ruby1.8_1.8.2-2_all.deb
libtk-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libtk-ruby1.8_1.8.2-2_i386.deb
libwebrick-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/libwebrick-ruby1.8_1.8.2-2_all.deb
libxmlrpc-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/libxmlrpc-ruby1.8_1.8.2-2_all.deb
libyaml-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libyaml-ruby1.8_1.8.2-2_i386.deb
libzlib-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libzlib-ruby1.8_1.8.2-2_i386.deb
rdoc1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/rdoc1.8_1.8.2-2_all.deb
ri1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/ri1.8_1.8.2-2_all.deb
ruby1.8-dev_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/ruby1.8-dev_1.8.2-2_i386.deb
ruby1.8-elisp_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/ruby1.8-elisp_1.8.2-2_all.deb
ruby1.8-examples_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/ruby1.8-examples_1.8.2-2_all.deb
ruby1.8_1.8.2-2.diff.gz
  to pool/main/r/ruby1.8/ruby1.8_1.8.2-2.diff.gz
ruby1.8_1.8.2-2.dsc
  to pool/main/r/ruby1.8/ruby1.8_1.8.2-2.dsc
ruby1....

Debian Bug Importer (debzilla) wrote :
Download full text (10.5 KiB)

Message-Id: <email address hidden>
Date: Mon, 10 Jan 2005 20:47:56 -0500
From: akira yamada <email address hidden>
To: <email address hidden>
Subject: Bug#289302: fixed in ruby1.8 1.8.2-2

Source: ruby1.8
Source-Version: 1.8.2-2

We believe that the bug you reported is fixed in the latest version of
ruby1.8, which is due to be installed in the Debian FTP archive:

irb1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/irb1.8_1.8.2-2_all.deb
libbigdecimal-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libbigdecimal-ruby1.8_1.8.2-2_i386.deb
libcurses-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libcurses-ruby1.8_1.8.2-2_i386.deb
libdbm-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libdbm-ruby1.8_1.8.2-2_i386.deb
libdl-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libdl-ruby1.8_1.8.2-2_i386.deb
libdrb-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/libdrb-ruby1.8_1.8.2-2_all.deb
liberb-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/liberb-ruby1.8_1.8.2-2_all.deb
libgdbm-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libgdbm-ruby1.8_1.8.2-2_i386.deb
libiconv-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libiconv-ruby1.8_1.8.2-2_i386.deb
libopenssl-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libopenssl-ruby1.8_1.8.2-2_i386.deb
libpty-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libpty-ruby1.8_1.8.2-2_i386.deb
libracc-runtime-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libracc-runtime-ruby1.8_1.8.2-2_i386.deb
libreadline-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libreadline-ruby1.8_1.8.2-2_i386.deb
librexml-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/librexml-ruby1.8_1.8.2-2_all.deb
libruby1.8-dbg_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8-dbg_1.8.2-2_i386.deb
libruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8_1.8.2-2_i386.deb
libsdbm-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libsdbm-ruby1.8_1.8.2-2_i386.deb
libsoap-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/libsoap-ruby1.8_1.8.2-2_all.deb
libstrscan-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libstrscan-ruby1.8_1.8.2-2_i386.deb
libsyslog-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libsyslog-ruby1.8_1.8.2-2_i386.deb
libtcltk-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libtcltk-ruby1.8_1.8.2-2_i386.deb
libtest-unit-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/libtest-unit-ruby1.8_1.8.2-2_all.deb
libtk-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libtk-ruby1.8_1.8.2-2_i386.deb
libwebrick-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/libwebrick-ruby1.8_1.8.2-2_all.deb
libxmlrpc-ruby1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/libxmlrpc-ruby1.8_1.8.2-2_all.deb
libyaml-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libyaml-ruby1.8_1.8.2-2_i386.deb
libzlib-ruby1.8_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/libzlib-ruby1.8_1.8.2-2_i386.deb
rdoc1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/rdoc1.8_1.8.2-2_all.deb
ri1.8_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/ri1.8_1.8.2-2_all.deb
ruby1.8-dev_1.8.2-2_i386.deb
  to pool/main/r/ruby1.8/ruby1.8-dev_1.8.2-2_i386.deb
ruby1.8-elisp_1.8.2-2_all.deb
  to pool/main/r/ruby1.8/ruby1.8-elisp_1.8.2-2_all.deb
ruby1.8-examples_1.8.2-2_all...

Matt Zimmerman (mdz) wrote :

Seems likely that this bug was introduced in a later version of ruby

Changed in ruby1.8:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.