ruby1.8: Patch for dir.c required.

Bug #10785 reported by Debian Bug Importer on 2004-11-29
4
Affects Status Importance Assigned to Milestone
ruby1.8 (Debian)
Fix Released
Unknown
ruby1.8 (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #283565 http://bugs.debian.org/283565

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #283565 http://bugs.debian.org/283565

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Mon, 29 Nov 2004 09:00:56 +0530
From: Warren Brian Noronha <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: ruby1.8: Patch for dir.c required.

Package: ruby1.8
Version: 1.8.1+1.8.2pre3-1
Severity: grave
Justification: renders package unusable

You will need to apply the dic.c patch, this renders a
number of ruby packages and ruby gems unusable. There is a
quick fix for rubygems but I do not think it has been tested.

gorillaz:/usr/lib/ruby/gems/1.8/cache# gem install rails
Attempting local installation of 'rails'
Local gem file not found: rails*.gem
Attempting remote installation of 'rails'
ERROR: executing gem ... (ArgumentError)
string contains null byte

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.9-1-k7
Locale: LANG=en_IN, LC_CTYPE=en_IN (charmap=UTF-8)

Versions of packages ruby1.8 depends on:
ii libc6 2.3.2.ds1-18 GNU C Library: Shared libraries an
ii libruby1.8 1.8.1+1.8.2pre3-1 Libraries necessary to run the Rub

-- no debconf information

Download full text (12.6 KiB)

Source: ruby1.8
Source-Version: 1.8.1+1.8.2pre3-2

We believe that the bug you reported is fixed in the latest version of
ruby1.8, which is due to be installed in the Debian FTP archive:

irb1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/irb1.8_1.8.1+1.8.2pre3-2_all.deb
libbigdecimal-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libbigdecimal-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libcurses-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libcurses-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libdl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdrb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libdrb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
liberb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/liberb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libgdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libgdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libiconv-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libiconv-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libopenssl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libopenssl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libpty-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libpty-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libracc-runtime-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libracc-runtime-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libreadline-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libreadline-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
librexml-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/librexml-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libruby1.8-dbg_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8-dbg_1.8.1+1.8.2pre3-2_i386.deb
libruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libsdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsoap-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libsoap-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libstrscan-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libstrscan-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsyslog-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libsyslog-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libtcltk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libtcltk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libtest-unit-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libtest-unit-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libtk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libtk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libwebrick-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libwebrick-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libxmlrpc-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libxmlrpc-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libyaml-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libyaml-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libzlib-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libzlib-ruby1.8_1.8.1+1.8.2pre3-2_i386...

Debian Bug Importer (debzilla) wrote :
Download full text (12.8 KiB)

Message-Id: <email address hidden>
Date: Mon, 06 Dec 2004 13:32:13 -0500
From: akira yamada <email address hidden>
To: <email address hidden>
Subject: Bug#283565: fixed in ruby1.8 1.8.1+1.8.2pre3-2

Source: ruby1.8
Source-Version: 1.8.1+1.8.2pre3-2

We believe that the bug you reported is fixed in the latest version of
ruby1.8, which is due to be installed in the Debian FTP archive:

irb1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/irb1.8_1.8.1+1.8.2pre3-2_all.deb
libbigdecimal-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libbigdecimal-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libcurses-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libcurses-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libdl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdrb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libdrb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
liberb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/liberb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libgdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libgdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libiconv-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libiconv-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libopenssl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libopenssl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libpty-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libpty-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libracc-runtime-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libracc-runtime-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libreadline-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libreadline-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
librexml-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/librexml-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libruby1.8-dbg_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8-dbg_1.8.1+1.8.2pre3-2_i386.deb
libruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libsdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsoap-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libsoap-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libstrscan-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libstrscan-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsyslog-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libsyslog-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libtcltk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libtcltk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libtest-unit-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libtest-unit-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libtk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libtk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libwebrick-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libwebrick-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libxmlrpc-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libxmlrpc-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
...

Matt Zimmerman (mdz) wrote :

   ruby1.8 | 1.8.1+1.8.2pre4-1 | http://archive.ubuntu.com hoary/main Packages

Changed in ruby1.8:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.