[ruby1.8] dup'ed string may be modified

Bug #10767 reported by Debian Bug Importer on 2004-11-29
4
Affects Status Importance Assigned to Milestone
ruby1.8 (Debian)
Fix Released
Unknown
ruby1.8 (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #283192 http://bugs.debian.org/283192

At Sat, 27 Nov 2004 13:49:21 +0900,
Ryuichi Arafune wrote:

> migemo cannot work in som ecases. Please test the following.
>
>
> type 'migemo /usr/share/migemo/migemo-dict'
>
> try 'a'
> response: many characters which shuld be pronouced "a" appear.
> try 'ai'
> responce: many characters which shuld be pronouced "ai" appear.
> But...
> try 'aki'
> responce: No responce.
> I believe this problem should be set as important because of unusability
> of this package.

confirmed

ruby1.8 1.8.1+1.8.2pre2-7 works and ruby1.8 1.8.1+1.8.2pre3 reproduce
this bug.

Regards,
Fumitoshi UKAI

reassign 283192 ruby1.8
tags 283192 grave
retitle 283192 [ruby1.8] dup'ed string may be modified
thanks

Package: ruby1.8
Version: 1.8.1+1.8.2pre3-1
Severity: grave

In ruby1.8 1.8.1+1.8.2pre3-1, modifycation on string that is dupped from
original string may modify original string.

For example,
 % ruby -e 'a="str"; b=a.dup; b[0]=?S; p a'
 "Str"

It should be "str".

This bug affects various ruby programs such as migemo (Bug#283192).

For more detailed discussion, see upstream development mailing-list
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-dev/24984
(in Japanese). It is confirmed by upstream author Matz, and will be
fixed in next release.

For a workaround of Bug#283192, use optimize level 0, that is,
"migemo -O0 /usr/share/migemo/migemo-dict.idx" or downgrade ruby1.8.

Regards,
Fumitoshi UKAI

severity 283192 grave
tags 283192 confirmed fixed-upstream
thanks

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #283192 http://bugs.debian.org/283192

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Sat, 27 Nov 2004 13:49:21 +0900
From: Ryuichi Arafune <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: Not respond in some cases

Package: migemo
Version: 0.40-7
Severity: important

migemo cannot work in som ecases. Please test the following.

type 'migemo /usr/share/migemo/migemo-dict'

try 'a'
 response: many characters which shuld be pronouced "a" appear.
try 'ai'
 responce: many characters which shuld be pronouced "ai" appear.
But...
try 'aki'
 responce: No responce.
I believe this problem should be set as important because of unusability
of this package.

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.9
Locale: LANG=ja_JP.eucJP, LC_CTYPE=ja_JP.eucJP (charmap=EUC-JP)

Versions of packages migemo depends on:
ii apel 10.6+0.20040418-1 a portable Emacs library
ii emacs21 [emacsen] 21.3+1-8 The GNU Emacs editor
ii libbsearch-ruby1.8 1.5-5 a binary search library for Ruby
ii libromkan-ruby1.8 0.4-5 a Romaji <-> Kana conversion libra
ii ruby1.8 1.8.1+1.8.2pre3-1 Interpreter of object-oriented scr
ii xemacs21-gnome-mule [e 21.4.15-8 Editor and kitchen sink -- Mule bi

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 27 Nov 2004 16:59:36 +0900
From: Fumitoshi UKAI <email address hidden>
To: <email address hidden>
Subject: Re: Bug#283192: Not respond in some cases

At Sat, 27 Nov 2004 13:49:21 +0900,
Ryuichi Arafune wrote:

> migemo cannot work in som ecases. Please test the following.
>
>
> type 'migemo /usr/share/migemo/migemo-dict'
>
> try 'a'
> response: many characters which shuld be pronouced "a" appear.
> try 'ai'
> responce: many characters which shuld be pronouced "ai" appear.
> But...
> try 'aki'
> responce: No responce.
> I believe this problem should be set as important because of unusability
> of this package.

confirmed

ruby1.8 1.8.1+1.8.2pre2-7 works and ruby1.8 1.8.1+1.8.2pre3 reproduce
this bug.

Regards,
Fumitoshi UKAI

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 29 Nov 2004 13:55:01 +0900
From: Fumitoshi UKAI <email address hidden>
To: <email address hidden>
Subject: ruby's bug.

reassign 283192 ruby1.8
tags 283192 grave
retitle 283192 [ruby1.8] dup'ed string may be modified
thanks

Package: ruby1.8
Version: 1.8.1+1.8.2pre3-1
Severity: grave

In ruby1.8 1.8.1+1.8.2pre3-1, modifycation on string that is dupped from
original string may modify original string.

For example,
 % ruby -e 'a="str"; b=a.dup; b[0]=?S; p a'
 "Str"

It should be "str".

This bug affects various ruby programs such as migemo (Bug#283192).

For more detailed discussion, see upstream development mailing-list
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-dev/24984
(in Japanese). It is confirmed by upstream author Matz, and will be
fixed in next release.

For a workaround of Bug#283192, use optimize level 0, that is,
"migemo -O0 /usr/share/migemo/migemo-dict.idx" or downgrade ruby1.8.

Regards,
Fumitoshi UKAI

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 29 Nov 2004 18:39:56 +0900
From: Fumitoshi UKAI <email address hidden>
To: <email address hidden> (Debian Bug Tracking System)
Subject: Re: Processed: ruby's bug.

severity 283192 grave
tags 283192 confirmed fixed-upstream
thanks

Download full text (12.6 KiB)

Source: ruby1.8
Source-Version: 1.8.1+1.8.2pre3-2

We believe that the bug you reported is fixed in the latest version of
ruby1.8, which is due to be installed in the Debian FTP archive:

irb1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/irb1.8_1.8.1+1.8.2pre3-2_all.deb
libbigdecimal-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libbigdecimal-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libcurses-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libcurses-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libdl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdrb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libdrb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
liberb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/liberb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libgdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libgdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libiconv-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libiconv-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libopenssl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libopenssl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libpty-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libpty-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libracc-runtime-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libracc-runtime-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libreadline-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libreadline-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
librexml-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/librexml-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libruby1.8-dbg_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8-dbg_1.8.1+1.8.2pre3-2_i386.deb
libruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libsdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsoap-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libsoap-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libstrscan-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libstrscan-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsyslog-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libsyslog-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libtcltk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libtcltk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libtest-unit-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libtest-unit-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libtk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libtk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libwebrick-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libwebrick-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libxmlrpc-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libxmlrpc-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libyaml-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libyaml-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libzlib-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libzlib-ruby1.8_1.8.1+1.8.2pre3-2_i386...

Debian Bug Importer (debzilla) wrote :
Download full text (12.8 KiB)

Message-Id: <email address hidden>
Date: Mon, 06 Dec 2004 13:32:13 -0500
From: akira yamada <email address hidden>
To: <email address hidden>
Subject: Bug#283192: fixed in ruby1.8 1.8.1+1.8.2pre3-2

Source: ruby1.8
Source-Version: 1.8.1+1.8.2pre3-2

We believe that the bug you reported is fixed in the latest version of
ruby1.8, which is due to be installed in the Debian FTP archive:

irb1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/irb1.8_1.8.1+1.8.2pre3-2_all.deb
libbigdecimal-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libbigdecimal-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libcurses-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libcurses-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libdl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libdrb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libdrb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
liberb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/liberb-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libgdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libgdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libiconv-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libiconv-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libopenssl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libopenssl-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libpty-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libpty-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libracc-runtime-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libracc-runtime-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libreadline-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libreadline-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
librexml-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/librexml-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libruby1.8-dbg_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8-dbg_1.8.1+1.8.2pre3-2_i386.deb
libruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libsdbm-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsoap-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libsoap-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libstrscan-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libstrscan-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libsyslog-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libsyslog-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libtcltk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libtcltk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libtest-unit-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libtest-unit-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libtk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
  to pool/main/r/ruby1.8/libtk-ruby1.8_1.8.1+1.8.2pre3-2_i386.deb
libwebrick-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libwebrick-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
libxmlrpc-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
  to pool/main/r/ruby1.8/libxmlrpc-ruby1.8_1.8.1+1.8.2pre3-2_all.deb
...

Matt Zimmerman (mdz) wrote :

   ruby1.8 | 1.8.1+1.8.2pre4-1 | http://archive.ubuntu.com hoary/main Packages

Changed in ruby1.8:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.