Ubuntu

FFe: remove ruby-vmc & ruby-json-pure from quantal

Reported by Julian Taylor on 2012-09-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ruby-json-pure (Ubuntu)
Undecided
Unassigned
ruby-vmc (Ubuntu)
Undecided
Unassigned

Bug Description

updated, see comment #2

ruby-json-pure is outdated, unmaintained ubuntu only, ftbs and worst conflicts with ruby-json from debian (bug 935412, bug 1026049)
the only rdep is ruby-vmc

ruby 1.9.1 which ruby-vmc depends on includes ruby-json in its standard library with almost the same version (1.5.1 vs 1.5.4)
So I propose to drop the -pure dependency in favor of the stdlib implementation and then remove ruby-json-pure from the archive.

Stefano Rivera (stefanor) wrote :

Fine with me. Please go ahead.

OK with ruby-json-pure removal (before beta 2, please), too.

Changed in ruby-vmc (Ubuntu):
status: New → Triaged
Julian Taylor (jtaylor) wrote :

after trying to check if ruby-vmc still works with the change I discovered that it requires another ruby gem, interact, which isn't even packaged.
Without it there seems to be little useful functionality in it and people are probably better of using the unpackaged gem.

So I would like to remove ruby-vmc completely from the archive instead of fixing it.

description: updated
summary: - FFe: remove ruby-json-pure dependency
+ FFe: remove ruby-vmc from quantal

Sounds good to me. Remove them both

Changed in ruby-json-pure (Ubuntu):
status: New → Triaged
summary: - FFe: remove ruby-vmc from quantal
+ FFe: remove ruby-vmc & ruby-json-pure from quantal
Scott Kitterman (kitterman) wrote :

Removing packages:
        ruby-json-pure 1.5.1-0ubuntu3 in quantal
                ruby-json-pure 1.5.1-0ubuntu3 in quantal amd64
                ruby-json-pure 1.5.1-0ubuntu3 in quantal armel
                ruby-json-pure 1.5.1-0ubuntu3 in quantal armhf
                ruby-json-pure 1.5.1-0ubuntu3 in quantal i386
                ruby-json-pure 1.5.1-0ubuntu3 in quantal powerpc
Comment: Included in Ruby 1.9.1 standard library. Obsolete.

Changed in ruby-json-pure (Ubuntu):
status: Triaged → Fix Released
Scott Kitterman (kitterman) wrote :

Removing packages:
        ruby-vmc 0.3.18-0ubuntu1 in quantal
                cloudfoundry-client 0.3.18-0ubuntu1 in quantal amd64
                cloudfoundry-client 0.3.18-0ubuntu1 in quantal armel
                cloudfoundry-client 0.3.18-0ubuntu1 in quantal armhf
                cloudfoundry-client 0.3.18-0ubuntu1 in quantal i386
                cloudfoundry-client 0.3.18-0ubuntu1 in quantal powerpc
                ruby-vmc 0.3.18-0ubuntu1 in quantal amd64
                ruby-vmc 0.3.18-0ubuntu1 in quantal armel
                ruby-vmc 0.3.18-0ubuntu1 in quantal armhf
                ruby-vmc 0.3.18-0ubuntu1 in quantal i386
                ruby-vmc 0.3.18-0ubuntu1 in quantal powerpc
Comment: Non-working due to missing dependencies. Unmaintained Ubuntu only package. Bug #1045460

Changed in ruby-vmc (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers