FTBFS with openssl 3.0

Bug #1981456 reported by Nick Rosbrook
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ruby-jwt (Debian)
Confirmed
Unknown
ruby-jwt (Ubuntu)
New
Undecided
Unassigned

Bug Description

Build log: https://launchpadlibrarian.net/609963160/buildlog_ubuntu-kinetic-amd64.ruby-jwt_2.3.0-1_BUILDING.txt.gz

ruby-jwt appears to be working on support for openssl 3.0 [1][2], so this should eventually be fixed by a new upstream version (or the patches could be cherry-picked when [2] is merged).

[1] https://github.com/jwt/ruby-jwt/issues/495
[2] https://github.com/jwt/ruby-jwt/pull/496

Nick Rosbrook (enr0n)
tags: added: update-excuse
Changed in ruby-jwt (Debian):
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.