package ruby-json-pure (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/ruby/vendor_ruby/json.rb', which is also in package ruby-json 1.6.3-1

Bug #1026049 reported by Tom vN on 2012-07-18
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ruby-json-pure (Ubuntu)
Undecided
Unassigned

Bug Description

installing ruby-json-pure yielded the following error:
Unpacking ruby-json-pure (from .../ruby-json-pure_1.5.1-0ubuntu3_all.deb) ...
dpkg: error processing /var/cache/apt/archives/ruby-json-pure_1.5.1-0ubuntu3_all.deb (--unpack):
 trying to overwrite '/usr/lib/ruby/vendor_ruby/json.rb', which is also in package ruby-json 1.6.3-1

It seems both packages share many files in common however they aren't set as conflicting in their deb files.

I encountered this error with Vagrant installed and depending on ruby-json while trying to install cloudfoundry-client which depends on ruby-json-pure.

I'm running Ubuntu 12.04
ruby-json is version 1.6.3-1
ruby-json-pure wants to be version 1.5.1-0ubuntu3

A conflict in the package would be good but I'd be even happier if there were a way to get Vagrant and the cloudfoundry client packages installing happily on the same host.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: ruby-json-pure (not installed)
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
Uname: Linux 3.2.0-26-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
Date: Tue Jul 17 16:08:07 2012
DuplicateSignature:
 Unpacking ruby-json-pure (from .../ruby-json-pure_1.5.1-0ubuntu3_all.deb) ...
 dpkg: error processing /var/cache/apt/archives/ruby-json-pure_1.5.1-0ubuntu3_all.deb (--unpack):
  trying to overwrite '/usr/lib/ruby/vendor_ruby/json.rb', which is also in package ruby-json 1.6.3-1
ErrorMessage: trying to overwrite '/usr/lib/ruby/vendor_ruby/json.rb', which is also in package ruby-json 1.6.3-1
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: ruby-json-pure
Title: package ruby-json-pure (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/ruby/vendor_ruby/json.rb', which is also in package ruby-json 1.6.3-1
UpgradeStatus: No upgrade log present (probably fresh install)

Tom vN (tomvn) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ruby-json-pure (Ubuntu):
status: New → Confirmed
Changed in ruby-json-pure (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for ruby-json-pure (Ubuntu) because there has been no activity for 60 days.]

Changed in ruby-json-pure (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers