[FFe] request for new upstream version

Bug #211910 reported by Gabriele Postorino on 2008-04-04
10
Affects Status Importance Assigned to Milestone
libtorrent (Ubuntu)
Wishlist
Unassigned
rtorrent (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: rtorrent

New upstream version 0.8.0 adds DHT method to rtorrent.

DHT is a method for trackerless system where every peer acts as a tracker sharing distributed hash tables.
This is already implemented by the BitTorrent, µTorrent, BitComet, KTorrent and Deluge clients.

rtorrent 0.8.0 depends on libtorrent 0.12.0

Luca Falavigna (dktrkranz) wrote :

This requires a FFe for both libtorrent and rtorrent.

Changed in rtorrent:
importance: Undecided → Wishlist
Changed in libtorrent:
importance: Undecided → Wishlist
Luca Falavigna (dktrkranz) wrote :

This is upstream changelog, valid for both packages.

It is not available in the packages, but in libtorrent-devel mailing list:
http://rakshasa.no/pipermail/libtorrent-devel/2008-January/001470.html

Luca Falavigna (dktrkranz) wrote :
Luca Falavigna (dktrkranz) wrote :
Luca Falavigna (dktrkranz) wrote :
Luca Falavigna (dktrkranz) wrote :
StefanPotyra (sistpoty) wrote :

Basically I'm ok with this FFe:

rtorrent is the only rdepends of libtorrent.
and:
[19:32:33] <jdong> sistpoty: looks good to me, having a lightweight client that supports DHT will be good for Hardy

But please tell us first, what testing you have done. Thanks.

Gabriele Postorino (no0tic) wrote :

I'm testing it right now with a trackerless torrent and it's working fine

Cesare Tirabassi (norsetto) wrote :

This is what the DM says about this:

Bryan Donlan wrote:
> Package: rtorrent
> Version: 0.7.9-1+b1
> Severity: wishlist
>
> A new version (0.8.0) of rtorrent is available from
> http://libtorrent.rakshasa.no/downloads/
>
Hi Bryan,

That's the unstable release and I refuse to use it because of the
instability of this version and constant changes.

Regards.
- --
Jose Luis Rivas. San Cristóbal, Venezuela. PGP: 0xCACAB118

John Dong (jdong) wrote :

I think this is a good candidate for a FFe. Right now we don't have a lightweight or headless client that supports DHT so this feature will fill a niche. The reverse deps are self-contained so it'd have little to no impact on the rest of the archive.

Scott Kitterman (kitterman) wrote :

Ack #2 and approved.

Changed in libtorrent:
status: New → Confirmed
Changed in rtorrent:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libtorrent - 0.12.0-0ubuntu1

---------------
libtorrent (0.12.0-0ubuntu1) hardy; urgency=low

  * New upstream release.
  * New SONAME, affected files changed accordingly.
  * debian/patches/update-changelog.patch:
    - Updated with new changelog.
  * debian/rules:
    - Add DEB_INSTALL_CHANGELOGS_ALL to install ChangeLog (LP: #194188).
  * debian/control:
    - Update Maintainer field as per spec.
  * Feature Freeze exception granted as per LP: #211910.

 -- Luca Falavigna <email address hidden> Sun, 06 Apr 2008 23:34:20 +0200

Changed in libtorrent:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rtorrent - 0.8.0-0ubuntu1

---------------
rtorrent (0.8.0-0ubuntu1) hardy; urgency=low

  * New upstream release.
  * debian/control:
    - Build-depend on libtorrent-dev (>=0.12.0).
    - Update Maintainer field as per spec.
  * debian/debian/rtorrent.links:
    - Adjust link to match new libtorrent SONAME.
  * Feature Freeze exception granted as per LP: #211910.

 -- Luca Falavigna <email address hidden> Sun, 06 Apr 2008 23:35:09 +0200

Changed in rtorrent:
status: Confirmed → Fix Released
Bryan Donlan (bdonlan) wrote :

Just an FYI,

I've been using a selfmade build of this on my debian (testing) server and it seems to have a number of crash bugs. See eg, http://libtorrent.rakshasa.no/ticket/1221

Also, although it was not marked as such when I filed the request in debian's tracker, upstream has since clarified this as a development/unstable release on their website. I'm not certain that it's appropriate for an LTS release...

Well it's already uploaded, so I guess we need to get some testing done ASAP.

Daniel Hahler (blueyed) wrote :

We might want to get 0.8.2/0.12.2 for Ubuntu 8.04.1, which contain bugfixes etc.

I'm just uploading them to Intrepid.

Gabriele Postorino (no0tic) wrote :

I have been using the 0.8.0 since end of march without a single crash.
I checked some days ago in debian sid for a package update to merge it in intrepid but there weren't any.
Are you building from upstream?

Daniel Hahler (blueyed) wrote :

I had rtorrent crashing today, so I've investigated (but could not find the root cause).

The Debian maintainer does not want to ship the experimental/unstable branch, so we're "ahead of Debian", until it gets declared as stable. Therefore, yes, I've updated the packages using "uscan/uupdate" and added a patch to both for GCC 4.3 (from upstream bugtracker).

The most important changes appear to be:
* Fixed an alignment bug in the DHT code.
* Fixed a memory corruption bug in scgi_task.cc.

* Fixed EINTR handling in execute command. Patch by anonymous.
* Fixed a couple of memory leaks in xmlrpc.cc. Reported by Novik.
* Initial seeding support added. Patch by Josef Drexler.

Scott Kitterman (kitterman) wrote :

This bug is done (fixed). Further comments about issues relate to rtorrent in this bug aren't going to result in anything happening.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.