Please sync rtorrent 0.7.9-1 and libtorrent 0.11.9-1 (universe) from Debian unstable (main).

Bug #198222 reported by Daniel Hahler on 2008-03-04
12
Affects Status Importance Assigned to Milestone
libtorrent (Ubuntu)
Wishlist
Unassigned
rtorrent (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/rtorrent
 affects ubuntu/libtorrent
 status confirmed
 importance wishlist
 subscribe ubuntu-archive

Please sync rtorrent 0.7.9-1 (universe) and libtorrent 0.11.9-1 (universe)
from Debian unstable (main).

LibTorrent 0.11.9 and rTorrent 0.7.9 are bugfix releases with the following
upstream changes:
 * Improved detection of unnecessary handshakes to decrease the load when
   using PEX.
 * Limit the number of PEX connections to 8 per download.
 * Fixed several bugs in PEX.
 * Fixed several sigc++ 2.1 compile errors.
 * Print to the log when close_on_diskspace gets triggered.

Changelog of rtorrent since current hardy version 0.7.8-1:

rtorrent (0.7.9-1) unstable; urgency=low

  * debian/control:
   + Specified minimum libxmlrpc-c3 version to >=1.06. (Closes: #449271)
   + Build-depends on libtorrent updated to 0.11.9.
  * debian/rules:
   + Added `-fno-strict-aliasing`. (Closes: #453100)
  * debian/control:
   + Updated to Standards-Version 3.7.3, no modifications needed.
  * New rtorrent.rc shipped is up-to-date. (Closes: #448998)

 -- Jose Luis Rivas <email address hidden> Sun, 16 Dec 2007 19:48:29 -0430

Changelog of libtorrent since current hardy version 0.11.9-1:

libtorrent (0.11.9-1) unstable; urgency=low

  * New upstream version.
  * debian/rules:
   + Removed `-03` flag, CDBS automatically replaces it with `-02`,
   the memory leak issue was fixed in 0.11.x versions.
   + Added the exclusion of the doc `NEWS` since there's nothing useful
   inside. (Closes: #444120)
   + Added `-fno-strict-aliasing` compilation option because of issue
   with gcc-4.2.0 that produces segfault. (Closes: #446988)
  * debian/patches/update-changelog.patch:
   + Updated with the new changelog.
  * debian/control:
   + Updated to Standards-Version 3.7.3, no modifications needed.

- -- Jose Luis Rivas <email address hidden> Sun, 16 Dec 2007 19:09:02 -0430

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)

iD8DBQFHzKB5fAK/hT/mPgARAjUqAKDdUVxEzUv7iNS0WkpLAV+iQg/PzQCffhIr
y0WWl5UnDNP9/j5WgyguFuI=
=cRS+
-----END PGP SIGNATURE-----

Daniel Hahler (blueyed) on 2008-03-04
Changed in rtorrent:
importance: Undecided → Wishlist
status: New → Confirmed
Jonathan Riddell (jr) wrote :

[Updating] libtorrent (0.11.8-1 [Ubuntu] < 0.11.9-1 [Debian])
 * Trying to add libtorrent...
  - <libtorrent_0.11.9-1.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <libtorrent_0.11.9-1.dsc: downloading from http://ftp.debian.org/debian/>
  - <libtorrent_0.11.9.orig.tar.gz: downloading from http://ftp.debian.org/debian/>

Changed in libtorrent:
status: Confirmed → Fix Released
Jonathan Riddell (jr) wrote :

[Updating] rtorrent (0.7.8-1 [Ubuntu] < 0.7.9-1 [Debian])
 * Trying to add rtorrent...
  - <rtorrent_0.7.9-1.dsc: downloading from http://ftp.debian.org/debian/>
  - <rtorrent_0.7.9.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <rtorrent_0.7.9-1.diff.gz: downloading from http://ftp.debian.org/debian/>

Changed in rtorrent:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers