FFe: multiarch dependencies of libcurl, needed for proper functioning of flashplugin-installer

Bug #826601 reported by Steve Langasek on 2011-08-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cyrus-sasl2 (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
openldap (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
openssl (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
php-sasl (Ubuntu)
High
Steve Langasek
Oneiric
High
Steve Langasek
php5 (Ubuntu)
High
Steve Langasek
Oneiric
High
Steve Langasek
rtmpdump (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Only upon removing ia32-libs from my system have I discovered that flashplugin-nonfree does not work unless a 32-libt libcurl is available that it can dlopen (bug #780573). libcurl itself is multiarch-ready, but three of its dependencies are not: librtmp0, libldap-2.4-2, and libssl1.0.0.

Risk of regression from openldap and openssl conversion is somewhat higher than the risk from the other two sets of multiarch FFes requested, because these libraries are lower in the stack and we're now a few days farther after Feature Freeze. Although none of these libraries have plugin paths, I know for certain that php5 is going to regress (FTBFS) because it uses both openssl and openldap and its build system is not multiarch-proof. There may be other similar issues elsewhere in the archive that I don't know about. Best chance of finding those regressions, given the broad scope of the reverse-build-dependencies, would be to have any FFe included in an archive rebuild.

The benefit of this change is that it is most assuredly the last piece needed in order to cross-install flashplugin-viewer with nspluginwrapper, taking out another significant cause of ia32-libs installation on end users systems.

Steve Langasek (vorlon) wrote :

I've uploaded a multiarch-converted openldap to Debian unstable this evening.

Martin Pitt (pitti) wrote :

Steve says that while PHP's build system is ugly, and library paths need to be hand-edited in the m4 files, it's not a problem to fix it.

As this just missed FF by three days, at this point I consider this appropriate still.

Changed in openldap (Ubuntu):
status: New → Confirmed
Changed in openssl (Ubuntu):
status: New → Confirmed
Changed in rtmpdump (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openssl - 1.0.0d-2ubuntu2

---------------
openssl (1.0.0d-2ubuntu2) oneiric; urgency=low

  * Build for multiarch. LP: #826601.
 -- Steve Langasek <email address hidden> Mon, 15 Aug 2011 01:58:35 -0700

Changed in openssl (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rtmpdump - 2.3-2ubuntu1

---------------
rtmpdump (2.3-2ubuntu1) oneiric; urgency=low

  * Build for multiarch. LP: #826601.
 -- Steve Langasek <email address hidden> Mon, 15 Aug 2011 02:14:00 -0700

Changed in rtmpdump (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openldap - 2.4.25-1.1ubuntu3

---------------
openldap (2.4.25-1.1ubuntu3) oneiric; urgency=low

  * Cherry-pick multiarch support from Debian (LP: #826601):
    - Bump to compat level 7, so we don't have to spell out debian/tmp in
      every single .install file
    - Build for multiarch.
 -- Steve Langasek <email address hidden> Mon, 15 Aug 2011 02:23:43 -0700

Changed in openldap (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

I'm very sorry to say that there is one more library needed for libcurl multiarch installability, which apt hid from me until the other libraries had all been fixed. libldap-2.4-2 depends on libsasl2-2, so cyrus-sasl2 would also require a multiarch conversion to get the benefit here.

cyrus-sasl2 has a moderate number (58) of reverse-build-deps, but again aside from php5 these should all have already gone through the multiarch transition due to other build-dependencies or have multiarch-safe build systems. I can do a manual rebuild test to catch any new build failures just to be sure.

cyrus-sasl2 does have a plugin path, but already has upstream support for configuring multiple search directories. I've built locally with a fallback path configured, and confirmed that modules will be correctly found in either of /usr/lib/sasl2 or /usr/lib/$arch/sasl2 paths.

If we don't want to take cyrus-sasl2 on this FFe, then it's probably better to roll back the multiarch support in openldap as well for this cycle since that would give us various build failures without any actual benefit. However, we're so very close now to having flashplugin multiarch-able that I think we should go ahead here.

Scott Kitterman (kitterman) wrote :

Ack. Please go ahead after you do your rebuild test.

Changed in cyrus-sasl2 (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

No build regressions found as a result of cyrus-sasl2 conversion except for the expected php5 (and php-sasl). Three packages failed to build because of the qt multiarch conversion (expected, in progress); two (qemu-kvm, qemu-linaro) ftbfs because of the pulseaudio multiarch conversion; *cyrus-imapd-* fail trying to find the GSSAPI libraries, probably due to missing build-dependencies; ekiga FTBFS due to a libnotify API change. Three more universe packages FTBFS with unsatisfiable build-deps. These will all be picked up in the archive rebuild.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cyrus-sasl2 - 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2

---------------
cyrus-sasl2 (2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2) oneiric; urgency=low

  * Build for multiarch. LP: #826601.
 -- Steve Langasek <email address hidden> Mon, 15 Aug 2011 15:30:56 -0700

Changed in cyrus-sasl2 (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) on 2011-08-15
Changed in php5 (Ubuntu):
status: New → Triaged
importance: Undecided → High
Steve Langasek (vorlon) on 2011-08-16
Changed in php5 (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
Changed in php-sasl (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Steve Langasek (vorlon)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package php5 - 5.3.6-13ubuntu2

---------------
php5 (5.3.6-13ubuntu2) oneiric; urgency=low

  * debian/rules: build with --with-openssl instead of --with-openssl=/usr,
    to autodetect libraries in multiarch directories.
  * debian/patches/temporary-path-fixes-for-multiarch.patch: add ldap
    multiarch checks. LP: #826601.
 -- Steve Langasek <email address hidden> Tue, 16 Aug 2011 06:14:55 +0000

Changed in php5 (Ubuntu Oneiric):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package php-sasl - 0.1.0-1ubuntu2

---------------
php-sasl (0.1.0-1ubuntu2) oneiric; urgency=low

  * Check for libsasl in the multiarch directory. LP: #826601.
 -- Steve Langasek <email address hidden> Tue, 16 Aug 2011 20:29:42 +0000

Changed in php-sasl (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers