'8812au': Exec format error

Bug #1541743 reported by aanno
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
rtl8812au (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

This is a bug report against wily:

$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 15.10
Release: 15.10
Codename: wily

My USB3 Wifi Adapter (TP-Link AC 1200, Archer T4UH Version 1.0) only works with kernel 4.2.0-18-generic. In all other cases (e.g. for the latest kernel), the following happens:

$ sudo modprobe -v --force 8812au
insmod /lib/modules/4.2.0-27-generic/updates/dkms/8812au.ko
modprobe: ERROR: could not insert '8812au': Exec format error

When I get this error, I also find the following line in dmesg:

[ 164.444534] 8812au: disagrees about version of symbol module_layout

I'm using the Ubuntu provided package for 8812au (that will be compiled with dkms):

$ dkms status
rtl8812au, 4.3.8.12175.20140902+dfsg, 4.2.0-18-generic, x86_64: installed
rtl8812au, 4.3.8.12175.20140902+dfsg, 4.2.0-27-generic, x86_64: installed
rtl8812au, 4.3.8.12175.20140902+dfsg, 4.4.0-040400-generic, x86_64: installed
vboxhost, 5.0.14, 4.2.0-18-generic, x86_64: installed
vboxhost, 5.0.14, 4.2.0-27-generic, x86_64: installed
vboxhost, 5.0.14, 4.4.0-040400-generic, x86_64: installed

(As you can see from above, I also tried a vanilla 'mainline' kernel, but with the same result.)

Instead of the error I expect the kernel module 8812au to work with (at least) all 'official' wily kernel (e.g. 4.2.0-27-generic).

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rtl8812au (Ubuntu):
status: New → Confirmed
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

That means that the module rebuild process didn't actually follow your kernel update, and it shows that the module is not compatible with your current kernel.

Can you try reinstalling the package to see if it works better? Simply sudo apt-get install --reinstall rtl8812au-dkms.

Revision history for this message
Fujii Hironori (fujii-hironori) wrote :

Evertime kernel is updated, this problem occurs.
I do like following steps to recompile:

dkms stauts
sudo dkms remove rtl8812au/4.3.8.12175.20140902+dfsg -k $(uname -r)
sudo dkms install rtl8812au/4.3.8.12175.20140902+dfsg
sudo modprobe 8812au

Revision history for this message
Simon Waite (opless) wrote :

Confirming that this also happens in Xenial.

rtl8812au-dkms/xenial,xenial,now 4.3.8.12175.20140902+dfsg-0ubuntu2 all

dkms remove rtl8812au/4.3.8.12175.20140902+dfsg --all
dkms install rtl8812au/4.3.8.12175.20140902+dfsg
modprobe 8812au

However it doesn't detect my 8821.

Perhaps updating this module to something a little more recent will help?

This repo does work, however https://github.com/Grawp/rtl8812au_rtl8821au

Revision history for this message
Ben Cordes (cordes-ben) wrote :

This bug is still happening in both artful and bionic.

Confirming that every time the kernel updates, the driver fails to load.
Confirming that running dpkg-reconfigure "fixes" it.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers