default rt73 wireless driver in ubuntu 8.04 hardy heron doesn't like channel 13

Bug #248148 reported by finbarr69 on 2008-07-13
4
Affects Status Importance Assigned to Milestone
rt73 (Ubuntu)
Undecided
Unassigned

Bug Description

I spent ages (days) on this, reinstalling drivers, changing usb wireless adaptors etc. Then I discovered the default installation of Ubuntu 8.04 Hardy Heron (RT73 driver for my Edimax EW7318UG) will not show a wireless network on channel 13 (and possibly 12). I guess this is related to what channels are allowed in certain countries. Not only will it not show channel 13 in a scan, but it will not connect if you specify the SSID and password manually.

In the end I had to change my wireless router to another channel (5 worked instantly).

I was tearing my hair out over this. I don't know how to fix it, but guess it either needs to allow those extra channels, or have a big notice saying it won't detect channel 13 (and 12?). Channel 13 is the highest channel that exists in the UK, but in the US, I believe 12 and 13 are disallowed. Japan allows channel 14 also.

hope that helps !

Brian

Sebastian Bator (eremit7) wrote :

I had the same problem. My solution was using the drivers from serialmonkey.

Are you sure the driver in Hardy is this package? The RT73 package locks like being uploaded new for Intrepid. In the source code I found a explanation for changing CountryRegion. It's in modules/iwpriv_usage.txt. However it did'nt work in Hardy.

Changed in rt73:
status: New → Confirmed

Yeah, RT73.

Imho, it should work out of the box, and setting the country should have a
gui if it doesn't automatically pick it up from the system settings (the
country is set during the O/S installation, so the package should know it).
:-)

I tried the serialmonkey drivers, and although I got them compiled and
loaded (eventually after a long battle - so many packages needed installed
before I could get it to compile, and several weird error messages that
needed much googling), they still didn't connect. Don't know why
serialmonkey can't supply it as an rpm ready to go.

Thanks and Warmest Regards,

Brian

On Sun, Jul 20, 2008 at 3:09 PM, eremit7 <email address hidden> wrote:

> I had the same problem. My solution was using the drivers from
> serialmonkey.
>
> Are you sure the driver in Hardy is this package? The RT73 package locks
> like being uploaded new for Intrepid. In the source code I found a
> explanation for changing CountryRegion. It's in
> modules/iwpriv_usage.txt. However it did'nt work in Hardy.
>
> ** Changed in: rt73 (Ubuntu)
> Status: New => Confirmed
>
> --
> default rt73 wireless driver in ubuntu 8.04 hardy heron doesn't like
> channel 13
> https://bugs.launchpad.net/bugs/248148
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "rt73" source package in Ubuntu: Confirmed
>
> Bug description:
> I spent ages (days) on this, reinstalling drivers, changing usb wireless
> adaptors etc. Then I discovered the default installation of Ubuntu 8.04
> Hardy Heron (RT73 driver for my Edimax EW7318UG) will not show a wireless
> network on channel 13 (and possibly 12). I guess this is related to what
> channels are allowed in certain countries. Not only will it not show
> channel 13 in a scan, but it will not connect if you specify the SSID and
> password manually.
>
> In the end I had to change my wireless router to another channel (5 worked
> instantly).
>
> I was tearing my hair out over this. I don't know how to fix it, but guess
> it either needs to allow those extra channels, or have a big notice saying
> it won't detect channel 13 (and 12?). Channel 13 is the highest channel
> that exists in the UK, but in the US, I believe 12 and 13 are disallowed.
> Japan allows channel 14 also.
>
> hope that helps !
>
> Brian
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers