rsyslog 4.2.0-1ubuntu1 breaks in postinst due to use of local outside of function

Bug #401060 reported by Nizar Kerkeni on 2009-07-18
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
rsyslog (Ubuntu)
High
Loïc Minier

Bug Description

Binary package hint: rsyslog

crash after daily update of karmic alpha 64 bits.

ProblemType: Package
Architecture: amd64
Date: Sat Jul 18 12:41:50 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Package: rsyslog 4.2.0-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
SourcePackage: rsyslog
Title: package rsyslog 4.2.0-1ubuntu1 failed to install/upgrade: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Uname: Linux 2.6.31-3-generic x86_64

Related branches

Nizar Kerkeni (nizarus) wrote :
Steffen Röcker (sroecker) wrote :

I can confirm this.
To fix it edit /var/lib/dpkg/info/rsyslog.postinst and remove local before the variables.

Changed in rsyslog (Ubuntu):
status: New → Confirmed
Peter Júnoš (petoju) wrote :

I attach fixed file (I forgot to make backup before editing, so I cannot submit patch).

Rolf Leggewie (r0lf) on 2009-07-18
tags: added: karmic
removed: amd64
Changed in rsyslog (Ubuntu):
importance: Undecided → High
Loïc Minier (lool) on 2009-07-20
summary: - package rsyslog 4.2.0-1ubuntu1 failed to install/upgrade: le sous-
- processus script post-installation install? a retourn? une erreur de
- sortie d'?tat 1
+ rsyslog 4.2.0-1ubuntu1 breaks in postinst due to use of local outside of
+ function
Changed in rsyslog (Ubuntu):
assignee: nobody → Loïc Minier (lool)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rsyslog - 4.2.0-1ubuntu2

---------------
rsyslog (4.2.0-1ubuntu2) karmic; urgency=low

  * Prefix Vcs-* fields with "XSBC-Original-" as we don't use git for the
    Ubuntu packages.
  * Strip local from rsyslog's postinst as it shouldn't be used outside of
    functions; LP: #401060.

 -- Loic Minier <email address hidden> Mon, 20 Jul 2009 14:30:14 +0200

Changed in rsyslog (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers