please disable xconsole configuration in 50-default.conf to fix "rsyslogd-2007: action 'action 10' suspended, next retry is ..."

Bug #1746012 reported by Jamie Strandboge on 2018-01-29
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
rsyslog (Ubuntu)
Undecided
Julian Andres Klode

Bug Description

I've noticed this for a long time but never looked into it. My logs have a bunch of entries of the form:

rsyslogd-2007: action 'action 10' suspended, next retry is Mon Jan 29 04:08:13 2018 [v8.16.0 try http://www.rsyslog.com/e/2007 ]

This is caused by these lines in /etc/rsyslog.d/50-default.conf:

# The named pipe /dev/xconsole is for the `xconsole' utility. To use it,
# you must invoke `xconsole' with the `-file' option:
#
# $ xconsole -file /dev/xconsole [...]
#
# NOTE: adjust the list below, or you'll go crazy if you have a reasonably
# busy site..
#
daemon.*;mail.*;\
 news.err;\
 *.=debug;*.=info;\
 *.=notice;*.=warn |/dev/xconsole

/dev/xconsole is not setup by default in Ubuntu. Commenting out the above and restarting rsyslog resolves the issue.

This issue was reported to Debian:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=745492

and they disabled xconsole configuration by default in 8.14.0-2, however subsequent Ubuntu merges left the configuration in debian/50-default.conf.

summary: - rsyslogd-2007: action 'action 10' suspended, next retry is Mon Jan 29
- 04:08:13 2018 [v8.16.0 try http://www.rsyslog.com/e/2007 ]
+ rsyslogd-2007: action 'action 10' suspended, next retry is ...
summary: - rsyslogd-2007: action 'action 10' suspended, next retry is ...
+ please disable xconsole configuration in 50-default.conf to fix
+ "rsyslogd-2007: action 'action 10' suspended, next retry is ..."
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rsyslog (Ubuntu):
status: New → Confirmed
Changed in rsyslog (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Julian Andres Klode (juliank)
Changed in rsyslog (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rsyslog - 8.32.0-1ubuntu3

---------------
rsyslog (8.32.0-1ubuntu3) bionic; urgency=medium

  * tmpfiles.d: Let var.conf to create /var/log with 'd' directive, and
    only adjust the permissions of /var/log with 'z' directive, thus
    avoiding warnings about duplicate lines for path /var/log. LP:
    #1730028

rsyslog (8.32.0-1ubuntu2) bionic; urgency=medium

  * Ensure correct permissions on files that rsyslog writes to. LP:
    #1761630
  * Drop upgrade scripts from pre-xenial.

 -- Dimitri John Ledkov <email address hidden> Mon, 09 Apr 2018 14:44:54 +0100

Changed in rsyslog (Ubuntu):
status: Fix Committed → Fix Released
kamiccolo (kamicc) wrote :

Affected on 16.04 as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers