rsyslog GnuTLS error -50

Bug #1673717 reported by halfgaar on 2017-03-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rsyslog (Debian)
Fix Released
Unknown
rsyslog (Ubuntu)
Medium
Brian Murray

Bug Description

Exactly the same as this:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=832995

Error:

> rsyslogd-2078: unexpected GnuTLS error -50 in nsd_gtls.c:530: The
> request is invalid. [v8.16.0 try http://www.rsyslog.com/e/2078 ]

Provided patch in https://github.com/rsyslog/rsyslog/issues/732 works.

Please apply patch or upgrade rsyslog.

Ubuntu 16.04 AMD64
Rsyslog 8.16.0-1ubuntu3

halfgaar (wiebe-halfgaar) wrote :

What is this bug's destiny?

Changed in rsyslog (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rsyslog (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

The Ubuntu Stable Release Update process requires a test case, http://wiki.ubuntu.com/StableReleaseUpdates, if you provide one I'll be happy to upload the fix.

tags: added: xenial
Malte Schmidt (maltris) wrote :

Test case

Step 1:

Create a rsyslog-config using gtls:

/etc/rsyslog.d/10-tlstest.conf

Step 2:

To generate the needed ca-, key-, cert-files, follow the guide at http://www.rsyslog.com/doc/v8-stable/tutorials/tls.html#certificates

Step 3:

Setup a client, which relays logs to the server that was just set up

Step 4:

Check the rsyslog-log for the errors mentioned in the initial post.

Brian Murray (brian-murray) wrote :

This actually seems to affect all supported releases of Ubuntu as rsyslog hasn't been updated since the 8.16 release in early 2016.

Changed in rsyslog (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in rsyslog (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rsyslog - 8.16.0-1ubuntu10

---------------
rsyslog (8.16.0-1ubuntu10) bionic; urgency=medium

  * fix-tls-connection-errrors.patch: Resolve unexpected GnuTLS error -50.
    (LP: #1673717)

 -- Brian Murray <email address hidden> Mon, 06 Nov 2017 15:05:10 -0800

Changed in rsyslog (Ubuntu):
status: Triaged → Fix Released
Changed in rsyslog (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.