Please merge rsyslog 8.16.0-1 (main) from Debian unstable (main)

Bug #1539483 reported by Louis Bouchard on 2016-01-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rsyslog (Ubuntu)
Wishlist
Louis Bouchard

Bug Description

merge bug

Louis Bouchard (louis) on 2016-01-29
Changed in rsyslog (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
assignee: nobody → Louis Bouchard (louis-bouchard)
Louis Bouchard (louis) wrote :

debdiff : previous merge to current

Louis Bouchard (louis) wrote :

Debian current to new merge debdiff

Louis Bouchard (louis) wrote :

Updated d-u debdiff

Louis Bouchard (louis) wrote :

updated u-u debdiff

tags: added: patch
Martin Pitt (pitti) wrote :

Thanks Louis, looks and works fine now! Uploaded.

Changed in rsyslog (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package rsyslog - 8.16.0-1ubuntu1

---------------
rsyslog (8.16.0-1ubuntu1) xenial; urgency=low

  * Merge from Debian unstable (LP: #1539483). Remaining changes:
    - debian/00rsyslog.conf Install tmpfiles.d snippet to ensure that the syslog
      group can write into /var/log/.
    - debian/50-default.conf: set of default rules for syslog
    - debian/rsyslog.conf:
      + enable $RepeatedMsgReduction to avoid bloating the syslog file.
      + enable $KLogPermitNonKernelFacility for non-kernel klog messages
      + Run as rsyslog:rsyslog, set $FileOwner to syslog
      + Remove rules moved to 50-default.conf
    - Add disabled by default AppArmor profile:
      + add debian/usr.sbin.rsyslogd profile
      + debian/usr.sbin.rsyslogd: allow 'w' on /run/systemd/notify
    - debian/rules:
      + use dh_apparmor to install profile before rsyslog is
      + Fix LDFLAGS to avoid segfault on receipt of first message
      + Avoid buiding specific packages that rely on Universe deps restarted
      + Disable liblogging-stdlog since liblogging-stdlog-dev is in Universe
      + Build with --disable-silent-rules to get useful build logs.
      + Disable build with dropped packages
    - debian/control:
      + suggests apparmor (>= 2.3)
      + Build-Depends on dh-apparmor
      + Drop Build-Depends for Universe Packages
      + Drop Suggests for unbuilt packages
      + Add Depends for adduser, ucf and lsb-base.
      + Add versioned dependency on lsb-base for the use of init_is_upstart.
    - debian/rsyslog.install:
      + install profile to /etc/apparmor.d
      + Install default rules and tmpfiles.d config file
      + Drop install for files in packages that are not built
    - debian/rsyslog.dirs: install /etc/apparmor.d/force-complain,
      /etc/apparmor.d/disable and /etc/apparmor.d/local
    - debian/rsyslog.preinst: disable profile on clean installs.
    - debian/rsyslog.postinst:
      + Adapt script to use ucf for Ubuntu's conffiles
      + fix ownership of /var/spool/rsyslog.
      + Create syslog user and add it to adm group
      + Adapt privileges for /var/log
    - debian/rsyslog.postrm:
      + Remove file in postrm on purge. manage with ucf.
    - debian/rsyslog.logcheck.ignore.server: Suppress warning about duplicate
      tmpfiles.d line for /var/log, from our debian/00rsyslog.conf.
    - Drop rsyslog-mongodb package, depends on libmongo-client which is not
      in main.
    - Drop mmnormalize module, which depends on liblognorm from universe.
    - Drop kafka package, depends on librdkafka from universe.
    - Drop rsyslog-czmq, depends on libczmq-dev from universe.
  * Dropped changes:
    - debian/rsyslog.preinst: disable profile when upgrading from earlier than
      when we shipped the profile as such a condition no longer exists
    - debian/rsyslog.init: Adjust rsyslog init script to detect upstart,
      making the upstart patches upstreamable to Debian.
    - debian/control: Drop ubuntu-specific lsb-base version dependancy since
      init_is_upstart is no longer used.
    - debian/rsyslog.logrotate: Drop "service rsyslog rotate" delta.
      invoke-rc.d is slightly better as it respects pol...

Read more...

Changed in rsyslog (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers