default config still using a legacy keyword: KLogPermitNonKernelFacility

Bug #1531622 reported by Simon Déziel on 2016-01-06
186
This bug affects 36 people
Affects Status Importance Assigned to Milestone
rsyslog (Ubuntu)
Medium
Unassigned

Bug Description

/etc/rsyslog.conf contains:

  $KLogPermitNonKernelFacility on

But this no longer supported and trigger this log message:

 Jan 5 08:56:16 simon-laptop rsyslogd-2222: command 'KLogPermitNonKernelFacility' is currently not permitted - did you already set it via a RainerScript command (v6+ config)? [v8.14.0 try http://www.rsyslog.com/e/2222 ]

Error 2222 is described as "legacy parameter no longer permitted".

This legacy parameter causes config syntax checks (rsyslogd -N1) to fail.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: rsyslog 8.14.0-2ubuntu2
ProcVersionSignature: Ubuntu 4.3.0-5.16-generic 4.3.3
Uname: Linux 4.3.0-5-generic x86_64
ApportVersion: 2.19.3-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Jan 6 15:47:15 2016
SourcePackage: rsyslog
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.logcheck.ignore.d.server.rsyslog: [deleted]

Simon Déziel (sdeziel) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rsyslog (Ubuntu):
status: New → Confirmed
Changed in rsyslog (Ubuntu):
importance: Undecided → Medium
Stephen Jahl (sjahl) wrote :

I can confirm that this is also happening in the latest version of Ubuntu 15.10.

Tomasz Konefal (twkonefal-j) wrote :

I can confirm that this is also happening in the latest version of Ubuntu 16.04.

SunBear (sunbear-c22) wrote :

I can confirm this also happens in my Ubuntu 16.04 LTS install.

May 6 08:20:41 Eliot rsyslogd-2222: command 'KLogPermitNonKernelFacility' is currently not permitted - did you already set it via a RainerScript command (v6+ config)? [v8.16.0 try http://www.rsyslog.com/e/2222 ]

vikash (vika.sh) wrote :

This is happening in ec2 ami for Ubuntu 16.04 as well.

G.M. (sexxxenator) wrote :

I can confirm too on freshly dist-upgraded Ubuntu 16.04 LTS

Trebacz (david-trebacz) wrote :

Is a temporary fix just to comment out the line:
KLogPermitNonKernelFacility on
in the configuration file /etc/rsyslog.conf ?

Canale Grande (canalegrande) wrote :

Happens on Ubuntu Server 16.04 LTS:

Sep 1 11:54:07 Servername rsyslogd: [origin software="rsyslogd" swVersion="8.16.0" x-pid="2168" x-info="http://www.rsyslog.com"] start
Sep 1 11:54:07 Servername rsyslogd-2222: command 'KLogPermitNonKernelFacility' is currently not permitted - did you already set it via a RainerScript command (v6+ config)? [v8.16.0 try http://www.rsyslog.com/e/2222 ]

Simon Déziel (sdeziel) wrote :

I'm not sure if the version is good for the Xenial debdiff, let me know if there is anything.

Simon Déziel (sdeziel) wrote :
description: updated
Simon Déziel (sdeziel) wrote :

I updated the 2 debdiffs to remove useless space in the config file.

The attachment "lp1531622-yakkety.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Simon Déziel (sdeziel) wrote :

Xenial debdiff with the proper version number, thanks stgraber.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rsyslog - 8.16.0-1ubuntu5

---------------
rsyslog (8.16.0-1ubuntu5) yakkety; urgency=medium

  * Use new syntax to enable non-kernel klog messages (LP: #1531622)

 -- Simon Deziel <email address hidden> Thu, 08 Sep 2016 16:57:33 +0000

Changed in rsyslog (Ubuntu):
status: Confirmed → Fix Released
Musbach (frank-musbach) wrote :

How about fixing it for 16.04 LTS? It is still in the latest kernel 4.4.0-62-generic. Thanks

ake sandgren (ake-sandgren) wrote :

Yes, please fix for 16.04.

Ivar Smolin (okul) wrote :

Please fix for 16.04

mc0e (xgcsufw02) wrote :

Ditto What Ivar et. al. said. 16.04.

Andreas Hasenack (ahasenack) wrote :

The configuration change is correct, but I think it's not working in the end. Upstream has a bug about it:

https://github.com/rsyslog/rsyslog/issues/477

And I filed https://bugs.launchpad.net/ubuntu/+source/rsyslog/+bug/1703987 for the ubuntu packages.

Eric G (erickg) wrote :

Still seems to be a problem for 16.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.