Getting error message: error in rsync protocol data stream (code 12) at io.c(605) [sender=3.0.9]

Bug #988144 reported by AlexOnVinyl on 2012-04-25
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
rsync (Ubuntu)
Undecided
Unassigned

Bug Description

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
Precise 12.04LTS

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center

Installed: 3.0.9-1ubuntu1
  Candidate: 3.0.9-1ubuntu1
  Version table:
 *** 3.0.9-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What you expected to happen

I was using rsync to backup my Home DIrectorys' contents and at one point in the backup it gave me this error:

     Downloads/Windows.7.Ultimate.32-64Bit.(2011-02-09).iso
  3809312768 83% 21.03MB/s 0:00:35
     rsync: writefd_unbuffered failed to write 4 bytes to socket [sender]: Broken pipe (32)
     rsync: connection unexpectedly closed (70735 bytes received so far) [sender]
     rsync error: error in rsync protocol data stream (code 12) at io.c(605) [sender=3.0.9]

This only came about when it was trying to copy my Windows ISO from my directory over to my backup drive that I have formatted in EXT4 - so I'm not sure of the issue it's having.

This is the command I used to backup:

rsync --progress -rEog --exclude Videos/ --exclude converted_music/ --exclude VirtualBox\ VMs/ --exclude virtual-drives/ --exclude Backup_of_boot_sectors/ --exclude examples.desktop --exclude Music/ --exclude .ecryptfs --exclude .VirtualBox/ --exclude .thumbnails/ --exclude .thunderbird/ --exclude .vidalia/ --exclude .teamviewer/ --exclude Templates/ --exclude sources.list --exclude wary-5.3.iso --exclude Public/ --exclude .cache/ /home/alex/ /media/backup/12.04-Precise-backup_4.23.2012/

Please look into this for me.

Thank you

Funky Future (funky-future) wrote :

i received the last error message when the destination-volume was almost full.

what kind of filesystem are you backing up to?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rsync (Ubuntu):
status: New → Confirmed
Sven (sassman) wrote :

This also happens to me on 12.10

lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10

apt-cache policy rsync
rsync:
  Installiert: 3.0.9-3ubuntu1
  Kandidat: 3.0.9-3ubuntu1
  Versionstabelle:
 *** 3.0.9-3ubuntu1 0
        500 http://de.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

Maciej (macmac) wrote :

I also have with the following configuration:
- rsync daemon at: Ubuntu 12.04.2 LTS, 64-bit, rsync package 3.0.9-1ubuntu1
- rsync client at freenas, release FreeNAS-8.3.1-RELEASE-x64 (r13452). "rsync --version" gives: "rsync version 3.0.9 protocol version 30"

I noticed, that it worked PERFECTLY, until I tried to send a file > 100 GB.
It also works, when I try rsync with -W option at client side.

Peter Grandi (pg-8) wrote :

This happens for me too with files of a few GB sometimes on ULTS 14 with RSYNC 3.1.0.

> It also works, when I try rsync with -W option at client side.

Same, and for me it works also when specifying '--block-size 4096'.

What this makes me suspect is that the remote 'rsync' process takes too long to send back the list of block checksums to the local 'rsync' in some situations, and a smaller checksum granularity, or asking for checksums to not be computed avoids that.

Peter Grandi (pg-8) wrote :

> the remote 'rsync' process takes too long to send back the
> list of block checksums to the local 'rsync' in some situations

As to that a quick web search indicates previous reports:

https://unix.stackexchange.com/questions/68775/rsync-timed-out 3
«It looks like the server times out on the SSH connection level.»
«Since the timeout appears to happen when rsync is creating the checksums»

https://bugzilla.samba.org/show_bug.cgi?id=7195
«it seems - in my case at least - to be related to the delta-xfer algorithm»

Pablo Piaggio (papibe) wrote :

This is happening again on: xenial

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.2 LTS
Release: 16.04
Codename: xenial

$ uname -a
Linux vaughan 4.4.0-83-generic #106-Ubuntu SMP Mon Jun 26 17:54:43 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ rsync --version
rsync version 3.1.1 protocol version 31
Copyright (C) 1996-2014 by Andrew Tridgell, Wayne Davison, and others.
Web site: http://rsync.samba.org/
Capabilities:
    64-bit files, 64-bit inums, 64-bit timestamps, 64-bit long ints,
    socketpairs, hardlinks, symlinks, IPv6, batchfiles, inplace,
    append, ACLs, xattrs, iconv, symtimes, prealloc

rsync comes with ABSOLUTELY NO WARRANTY. This is free software, and you
are welcome to redistribute it under certain conditions. See the GNU
General Public Licence for details.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.