Wrong error message when using --delete-delay

Bug #516241 reported by Jonas Pedersen on 2010-02-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rsync (Ubuntu)
Low
Thierry Carrez

Bug Description

Binary package hint: rsync

When using --delete-delay option I get below error. The error message is mentioning --delete-during option and not --delete-delay option. It should of course mention --delete-delay, if this issue also applies to --delete-delay.

jonas@miraculix:~/develop/scripts$ sudo ./backupMiraculix
sending incremental file list
rsync: readlink_stat("/home/jonas/.gvfs") failed: Permission denied (13)
FATAL I/O ERROR: dying to avoid a --delete-during issue with a pre-3.0.7 receiver.
rsync error: requested action not supported (code 4) at flist.c(1795) [sender=3.0.7]

The command I am using is:
/usr/bin/rsync -azv --numeric-ids --stats --bwlimit=700 --partial --exclude=/home/jonas/noBackup --delete-delay /home -e /usr/bin/ssh root@majestix:/storage/backup/miraculix

ProblemType: Bug
Architecture: amd64
Date: Tue Feb 2 21:24:31 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: rsync 3.0.7-1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_DK.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.16-generic
SourcePackage: rsync
Uname: Linux 2.6.32-12-generic x86_64

Jonas Pedersen (jonasped) wrote :
Jonas Pedersen (jonasped) wrote :

Poked a bit around in the source code and it looks like the error message should be displayed if using --delete-delay. I have attached a debdiff for the package correcting the error text.

Jonas Pedersen (jonasped) wrote :

Please sponsor this debdiff.

Thierry Carrez (ttx) wrote :

Hey Jonas, thanks for your patch. Three minor changes you should apply to your debdiff :

- Set "Maintainer:" to "Ubuntu Developers" rather than "Ubuntu Core Developers" to follow the new spec
- "XSBC-Original-Maintainer::" should just have one colon ("XSBC-Original-Maintainer:")
- The patch should only special-case --delete-delay, so that an error always goes out, even in the event upstream adds a third variation of delete_during to the mix. Something like (pseudocode):

- rprintf(dying to avoid a --delete-during);
+ if(delete_during == 2) {
+ rprintf(dying to avoid a --delete-delay);
+ }
+ else {
+ rprintf(dying to avoid a --delete-during);
+ }

What do you think ?

Changed in rsync (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Jonas Pedersen (jonasped) wrote :

Sorry for the late reply. I agree with your suggestions. I have attached a new debdiff.

tags: added: patch
Thierry Carrez (ttx) on 2010-03-30
Changed in rsync (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
status: Confirmed → In Progress
Thierry Carrez (ttx) wrote :

Slightly modified patch so that the default case in the if/else is the current case (--delete-during), and to fix the error message in the delete-delay case, and uploaded.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rsync - 3.0.7-1ubuntu1

---------------
rsync (3.0.7-1ubuntu1) lucid; urgency=low

  * Correct error message when using --delete-delay (LP: #516241), patch
    originally from Jonas Pedersen
 -- Thierry Carrez <email address hidden> Tue, 30 Mar 2010 10:41:28 +0200

Changed in rsync (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers