screensavers do not appear in selection-list

Bug #537011 reported by GophrenOli on 2010-03-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xscreensaver
Invalid
Undecided
Unassigned
rss-glx (Ubuntu)
Medium
Unassigned
Lucid
Undecided
Unassigned
xscreensaver (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: rss-glx

Hi, I am not sure if this new bug-entry is really necessary - I added my comment to bug 9740 (https://bugs.launchpad.net/ubuntu/+source/rss-glx/+bug/9740), which has been fixed already in past.

But in the current version of xubuntu 10.4 (today I got a bunch of update-packages) comparable appears:

no rss-glx screensavers are in the selection-list, neither in xscreensaver, nor in gnome-screensaver.

ProblemType: Bug
Architecture: i386
Date: Thu Mar 11 01:16:37 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: rss-glx 0.9.0-2ubuntu3
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic-pae
SourcePackage: rss-glx
Uname: Linux 2.6.32-16-generic-pae i686

WORKAROUND:
See comment #7 below -
    Run /usr/bin/rss-glx_install, which will look at your existing
~/.xscreensaver and add any missing entries. You probably want to back that
file up as the script is only lightly tested.

GophrenOli (gophrenoli) wrote :
tags: added: regression-potential
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I did install the package 'rss-glx' to confirm this issue. I then restarted the computer to insure the changes would take effect. The following screensavers are not installed/listed in Applications -> Settings -> Screensaver :
Biof
Busy Spheres
Colorfire
Cyclone
Drempels
Euphoria
Feedback
Fieldlines
Flocks
Flux
Helios
Hufo's Smoke
Hufo's Tunnel
Hyperspace
Lattice
Lorenz Attractor
MatrixView
Plasma
Skyrocket
Solarwinds
SpirographX
Sundancer2

Thanks for taking the time to make Ubuntu better!

Changed in rss-glx (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I've been unable to recreate this bug report on Lucid using the same version of rss-glx which really hasn't changed since Karmic. Additionally, I'm using gnome-screensaver version 2.29.92-0ubuntu1. Charlie did you check this with gnome-screensaver?

Changed in rss-glx (Ubuntu):
status: Confirmed → Incomplete
Charlie Kravetz (charlie-tca) wrote :

I installed Xubuntu Lucid on my 1.5GHz P4; 1GB RAM; NVidia 6200 w/256MB memory, then installed gnome-screensaver. Xscreensaver is now the default in Xubuntu. I then installed the rss-glx package. The list of screensavers I gave above are not there. Maybe it is something with Xubuntu and Xscreensaver installed.

Changed in rss-glx (Ubuntu):
status: Incomplete → Confirmed
Charlie Kravetz (charlie-tca) wrote :

Verified using new images, 2010-03-15 Lucid Xubuntu. Installed Xubuntu, updated and installed hardware drivers. I then installed gnome-screensaver and rss-glx. None of the screensavers in the above list are added to my Applications -> Settings -> Screensaver .

Brian Murray (brian-murray) wrote :

I've been unable to recreate this with a Gnome desktop environment so imagine it is Xubuntu specific.

Charlie Kravetz (charlie-tca) wrote :

Brian: my apologies for not checking the documentation first.

GophrenOli:

Okay, Reading the documentation for rss-glx, there is a README.xscreensaver file with the following information in it:

EITHER ------------------------------------------------------------------------
    Run /usr/bin/rss-glx_install, which will look at your existing
~/.xscreensaver and add any missing entries. You probably want to back that
file up as the script is only lightly tested :)

OR ----------------------------------------------------------------------------

    Manually add the following lines after the line that starts with "programs:"
in ~/.xscreensaver.

-- Cut Here --
  GL: "Cyclone" cyclone --root \n\
  GL: "Euphoria" euphoria --root \n\
  GL: "Fieldlines" fieldlines --root \n\
  GL: "Flocks" flocks --root \n\
  GL: "Flux" flux --root \n\
  GL: "Helios" helios --root \n\
  GL: "Hyperspace" hyperspace --root \n\
  GL: "Lattice" lattice --root \n\
  GL: "Plasma" plasma --root \n\
  GL: "Skyrocket" skyrocket --root \n\
  GL: "Solarwinds" solarwinds --root \n\
  GL: "Colorfire" colorfire --root \n\
  GL: "Hufo's Smoke" hufo_smoke --root \n\
  GL: "Hufo's Tunnel" hufo_tunnel --root \n\
  GL: "Sundancer2" sundancer2 --root \n\
  GL: "BioF" biof --root \n\
  GL: "BusySpheres" busyspheres --root \n\
  GL: "SpirographX" spirographx --root \n\
  GL: "MatrixView" matrixview --root \n\
  GL: "Lorenz" lorenz --root \n\
-- End Here --

Changed in rss-glx (Ubuntu):
status: Confirmed → Invalid
Brian Murray (brian-murray) wrote :

Well, the virtual machine I was testing with did not have a "~/.xscreensaver" (but the screensavers still appeared) and I'd imagine if that script does need to be run that it should be run as a part of the package installation.

Charlie Kravetz (charlie-tca) wrote :

Needs the list of rss-glx screensavers added to the default ~/.xscreensaver file

Changed in xscreensaver (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Brian Murray (brian-murray) wrote :

Interestingly on a 9.10 install of Xubuntu there is no ~/.xscreensaver file and just installing the package makes the rss-glx screensavers show up.

Charlie Kravetz (charlie-tca) wrote :

Okay, here is the ~/.xscreensaver file before adding rss-glx. Please compare it to the next attachment. If you had gone into Applications -> Settings -> Screensaver , it would have created the file for you. It is created the first time the user chooses any preferences for the screensaver.

Charlie Kravetz (charlie-tca) wrote :

At this point, is there any possibility of finding out how to get this fixed for all users? If you search this file for those screensaver names listed from the readme file above, every one of them is indeed missing.

tags: added: iso-testing

I'm using Kubuntu 10.04 and I don't see all of the rss-glx screensavers.

tags: added: regression-release
removed: regression-potential
Changed in xscreensaver (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
Charlie Kravetz (charlie-tca) wrote :

Marking the xscreensaver upstream task as invalid. Upstream has provided documentation with the application that describes how to make this work. Since 'xscreensaver' and 'rss-glx' are separate packages, the necessary file must be run locally when the 'rss-glx' package is installed.

description: updated
Changed in xscreensaver:
status: New → Invalid
GophrenOli (gophrenoli) wrote :

Propably this comment is useless to you. - You absolutely do not need to explain me anything, nevertheless:

I understand nothing of the current results ("Upstream", "the necessary file"), but I hope a standard-user or a "stupid-one" like me will be able to use just the Synaptic-tool for installing the rss-glx screensavers, after *something* has been fixed in year 2010, cause I dont want to install this or that by executing some special scripts locally. Would be really, really, really great.

GophrenOli (gophrenoli) wrote :

Of course, right after sending the useless comment above, I did what comment #7 told me, including the backup-part:

And it worked 100% fine with my Xubuntu lucid - test-installation.

So, in my summary: Would be great to get that installed simply by using the Synaptic-tool.

GophrenOli (gophrenoli) wrote :

Completing this session, here is my ~/.xscreensaver - just for someones information - after running the mentioned script:
/usr/bin/rss-glx_install

jozi (jozi) wrote :

i am using kubuntu 10.4 (kscreensaver) and having the same problem. also tried that script and got that:

jozi@lipwig:~$ sh /usr/bin/rss-glx_install
/usr/bin/rss-glx_install: 2: use: not found
/usr/bin/rss-glx_install: 4: Syntax error: "{" unexpected (expecting "then")

the way bugs are handled in ubuntu (well, especially kubuntu, as canonical doesn't seem to be interested in it) makes me really count down the days until sqeeze becomes stable and i can wipe that buggy kubuntu off my boxes again. and i thought vista was a regression...

This is how I fixed my rss screensavers for 10.04.

install rss-glx screensavers

This file has the corrected info:
http://kde-look.org/content/show.php/KDE4+Entries+for+RSS+%26+XScreenSaver?content=92544

After I get everything the way I want, I keep a backup of the folders below for kde 4.x.
So, when 10.10 comes out, I just copy the folders below if RSS screensavers don't work.

copy backup of screensavers to:
/usr/lib/xscreensaver
/usr/share/applications/screensavers
/usr/share/applnk/system/screensavers
/usr/share/xscreensaver/config
/usr/share/kde4/services/ScreenSavers

All rss-glx screensavers should be installed

I'm using Kubuntu 10.04.

JT (spikyjt) wrote :

Running /usr/bin/rss-glx_install or manually editing .xscreensaver did nothing for me. However, the correct desktop entries are in /usr/share/applnk/System/ScreenSavers/ (note the case of ScreenSavers) and copying the contents of that directory into /usr/share/kde4/services/ScreenSavers/ did the trick.

For complete clarity:

sudo cp /usr/share/applnk/System/ScreenSavers/*.desktop /usr/share/kde4/services/ScreenSavers/

is the command required. I'm on Kubuntu 10.04 and installed xscreensavers as well as rss-glx

Might I suggest that this is really a shortcoming in the setup of kde? Would it not be more helpful for /usr/share/kde4/services/ScreenSavers/ to symlink to /usr/share/applnk/System/ScreenSavers/ and have all of its standard contents in there? Using a system wide location is surely preferable?

Charlie Kravetz (charlie-tca) wrote :

@JT: xscreensaver was written for GTK, which Kubuntu is not using. This is an issue directly with KDE, instead of the application.

Adolfo Jayme (fitojb) on 2013-04-29
Changed in xscreensaver (Ubuntu Lucid):
status: Triaged → Won't Fix
Changed in rss-glx (Ubuntu Lucid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers