armel build failure (package not yet in the archive)

Bug #300257 reported by Matthias Klose on 2008-11-20
2
Affects Status Importance Assigned to Milestone
rss-glx (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: rss-glx

http://launchpadlibrarian.net/19804728/buildlog_ubuntu-jaunty-armel.rss-glx_0.8.1-10ubuntu2_FAILEDTOBUILD.txt.gz

./configure --with-configdir=/usr/share/xscreensaver/config \
  --with-kdessconfigdir=/usr/share/applnk/System/ScreenSavers \
  --bindir=\${prefix}/lib/xscreensaver \
  --host=arm-linux-gnueabi --build=arm-linux-gnueabi \
  --prefix=/usr --mandir=\${prefix}/share/man \
  --infodir=\${prefix}/share/info CFLAGS="-Wall -g -O2" \
  CXXFLAGS="-Wall -g -O2" LDFLAGS="-Wl,--as-needed"
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gawk... (cached) mawk
checking for arm-linux-gnueabi-gcc... arm-linux-gnueabi-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether arm-linux-gnueabi-gcc accepts -g... yes
checking for arm-linux-gnueabi-gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of arm-linux-gnueabi-gcc... gcc3
checking for arm-linux-gnueabi-g++... arm-linux-gnueabi-g++
checking whether we are using the GNU C++ compiler... yes
checking whether arm-linux-gnueabi-g++ accepts -g... yes
checking dependency style of arm-linux-gnueabi-g++... gcc3
checking for a BSD-compatible install... /usr/bin/install -c
configure: error: cannot run /bin/bash ./config.sub
make: *** [config.status] Error 1
dpkg-buildpackage: failure: debian/rules build gave error exit status 2

Related branches

Matthias Klose (doko) on 2008-11-20
Changed in rss-glx:
importance: Undecided → High
status: New → Confirmed
Changed in rss-glx:
assignee: nobody → hobbsee
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rss-glx - 0.8.2-1ubuntu2

---------------
rss-glx (0.8.2-1ubuntu2) jaunty; urgency=low

  * Remove the symlinks in the clean rule, and rerun autogen.sh, so
    the package knows about the new libtool locations. (LP: #300257)
  * Add automake to build-depends to fix FTBFS
  * Add --disable-sound configure flag to debian/rules, as we don't keep
    the dependencies on openal nor freeglut (both universe packages).
  * Add PKG_CONFIG="/usr/bin/pkg-config" to configure.in, so it actually runs
    pkg-config, to fix FTBFS.

 -- Sarah Hobbs <email address hidden> Sat, 22 Nov 2008 21:33:28 +1100

Changed in rss-glx:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers