package rsplib-legacy-wrappers (not installed) failed to install/upgrade: trying to overwrite '/usr/share/man/man1/terminal.1.gz', which is also in package ubuntu-terminal-app 0.7.218ubuntu2

Bug #1651161 reported by Nikola Lozanovski on 2016-12-19
96
This bug affects 14 people
Affects Status Importance Assigned to Milestone
rsplib (Ubuntu)
High
Unassigned
ubuntu-terminal-app (Ubuntu)
High
Unassigned

Bug Description

Tried to install rsplib-legacy-wrappers but failed.

ProblemType: Package
DistroRelease: Ubuntu 16.10
Package: rsplib-legacy-wrappers (not installed)
ProcVersionSignature: Ubuntu 4.8.0-30.32-generic 4.8.6
Uname: Linux 4.8.0-30-generic x86_64
ApportVersion: 2.20.3-0ubuntu8.2
AptOrdering:
 rsplib-legacy-wrappers:amd64: Install
 NULL: ConfigurePending
Architecture: amd64
Date: Mon Dec 19 16:20:28 2016
DpkgTerminalLog:
 Preparing to unpack .../rsplib-legacy-wrappers_3.0.1-1ubuntu3_amd64.deb ...
 Unpacking rsplib-legacy-wrappers (3.0.1-1ubuntu3) ...
 dpkg: error processing archive /var/cache/apt/archives/rsplib-legacy-wrappers_3.0.1-1ubuntu3_amd64.deb (--unpack):
  trying to overwrite '/usr/share/man/man1/terminal.1.gz', which is also in package ubuntu-terminal-app 0.7.218ubuntu2
ErrorMessage: trying to overwrite '/usr/share/man/man1/terminal.1.gz', which is also in package ubuntu-terminal-app 0.7.218ubuntu2
InstallationDate: Installed on 2016-11-07 (41 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
RelatedPackageVersions:
 dpkg 1.18.10ubuntu1
 apt 1.3.3
SourcePackage: rsplib
Title: package rsplib-legacy-wrappers (not installed) failed to install/upgrade: trying to overwrite '/usr/share/man/man1/terminal.1.gz', which is also in package ubuntu-terminal-app 0.7.218ubuntu2
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rsplib (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2017-04-03
Changed in ubuntu-terminal-app (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Thomas Dreibholz (dreibh) wrote :

rsplib-legacy-wrapper is a package with deprecated wrapper scripts, particularly one with name "terminal". The program names had been updated (e.g. to "rspterminal") a long, long time ago. rsplib-legacy-wrapper should therefore just be removed.

I created updated packages in my PPA at https://launchpad.net/%7Edreibh/+archive/ubuntu/ppa/+packages?field.name_filter=rsplib&field.status_filter=published&field.series_filter= .

tags: added: zesty
tags: added: manpage package-conflict
Download full text (3.3 KiB)

What is this? i am searchig a update problem....No i thinks the Prblems:

I have not only at 16.10 an update problem but also with Ubuntu 17.10 I
also notice more and more that the updates are always running Winiger and
error messages. Also, I can not solve with Ubuntu forums such as Ubuntu
Wiki with problem solving and assistance much of the ever-growing problems,
even through the terminal! It is becoming more and more complicated to
understand the problems with the system, or the errors are often only
empty. The clarity of the applications are too confusing, also because of
the way one takes care of the system processing. The Updater is the biggest
problem and that's why the LTS 16.10 Ubuntu version is also something of
bug-laden behavior! So I think about the change of the whole operating
system. Because sometimes works my compatible Samsung 16.10 ML printer with
linux driver Compatible driver or my scanner not, then again my webcam turn
nicht.Dieses is getting worse. Since I can even bring in the terminal
nothing more hardware to run, a different time is Libre Office functionally
limited or crashes ...

Hans Joachim Desserud <email address hidden> schrieb am Mo., 13. Nov.
2017 um 21:41 Uhr:

> ** Tags added: manpage package-conflict
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1722952).
> https://bugs.launchpad.net/bugs/1651161
>
> Title:
> package rsplib-legacy-wrappers (not installed) failed to
> install/upgrade: trying to overwrite
> '/usr/share/man/man1/terminal.1.gz', which is also in package ubuntu-
> terminal-app 0.7.218ubuntu2
>
> Status in rsplib package in Ubuntu:
> Confirmed
> Status in ubuntu-terminal-app package in Ubuntu:
> Confirmed
>
> Bug description:
> Tried to install rsplib-legacy-wrappers but failed.
>
> ProblemType: Package
> DistroRelease: Ubuntu 16.10
> Package: rsplib-legacy-wrappers (not installed)
> ProcVersionSignature: Ubuntu 4.8.0-30.32-generic 4.8.6
> Uname: Linux 4.8.0-30-generic x86_64
> ApportVersion: 2.20.3-0ubuntu8.2
> AptOrdering:
> rsplib-legacy-wrappers:amd64: Install
> NULL: ConfigurePending
> Architecture: amd64
> Date: Mon Dec 19 16:20:28 2016
> DpkgTerminalLog:
> Preparing to unpack .../rsplib-legacy-wrappers_3.0.1-1ubuntu3_amd64.deb
> ...
> Unpacking rsplib-legacy-wrappers (3.0.1-1ubuntu3) ...
> [1mdpkg: [0m error processing archive
> /var/cache/apt/archives/rsplib-legacy-wrappers_3.0.1-1ubuntu3_amd64.deb
> (--unpack):
> trying to overwrite '/usr/share/man/man1/terminal.1.gz', which is also
> in package ubuntu-terminal-app 0.7.218ubuntu2
> ErrorMessage: trying to overwrite '/usr/share/man/man1/terminal.1.gz',
> which is also in package ubuntu-terminal-app 0.7.218ubuntu2
> InstallationDate: Installed on 2016-11-07 (41 days ago)
> InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64
> (20161012.2)
> RelatedPackageVersions:
> dpkg 1.18.10ubuntu1
> apt 1.3.3
> SourcePackage: rsplib
> Title: package rsplib-legacy-wrappers (not installed) failed to
> install/upgrade: trying to overwrite '/usr/share/man/man1/terminal.1.gz',
> which is also in package ubuntu-t...

Read more...

Thomas Dreibholz (dreibh) wrote :

rsplib-legacy-wrappers is a long-obsolete package that wrapped the original names "terminal", "server" and "registrar" to their new names "rspterminal", "rspserver" and "rspregistrar" for old scripts. The motivation of the renaming to "rsp*" was of course to avoid conflicts with other "terminal" applications, etc.. Since all wrappers printed an unambiguous notification of their deprecation, it should be perfectly fine to remove rsplib-legacy-wrappers now.

The attached patch solves the issue for all current Ubuntu versions by simply removing the wrapper package "rsplib-legacy-wrappers".

Thomas Dreibholz (dreibh) wrote :

Alternative fix, particularly recommended for Ubuntu Bionic, is to upgrade rsplib from version 3.0.1 to version 3.1.8. In upstream rsplib newer than 3.0.1, the legacy wrappers are also removed since a long time.

I provide packages of rsplib-3.1.8 in my PPA for Trusty to Bionic:
https://launchpad.net/~dreibh/+archive/ubuntu/ppa/+packages?field.name_filter=rsplib&field.status_filter=published&field.series_filter=

The attachment "The patch solving the issue" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
David M. Mora (9.5matakoue) wrote :

Thanks! 👍

On Thu, Nov 16, 2017 at 9:20 PM, Ubuntu Foundations Team Bug Bot <
<email address hidden>> wrote:

> The attachment "The patch solving the issue" seems to be a debdiff. The
> ubuntu-sponsors team has been subscribed to the bug report so that they
> can review and hopefully sponsor the debdiff. If the attachment isn't a
> patch, please remove the "patch" flag from the attachment, remove the
> "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe
> the team.
>
> [This is an automated message performed by a Launchpad user owned by
> ~brian-murray, for any issue please contact him.]
>
> ** Tags added: patch
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1731880).
> https://bugs.launchpad.net/bugs/1651161
>
> Title:
> package rsplib-legacy-wrappers (not installed) failed to
> install/upgrade: trying to overwrite
> '/usr/share/man/man1/terminal.1.gz', which is also in package ubuntu-
> terminal-app 0.7.218ubuntu2
>
> Status in rsplib package in Ubuntu:
> Confirmed
> Status in ubuntu-terminal-app package in Ubuntu:
> Confirmed
>
> Bug description:
> Tried to install rsplib-legacy-wrappers but failed.
>
> ProblemType: Package
> DistroRelease: Ubuntu 16.10
> Package: rsplib-legacy-wrappers (not installed)
> ProcVersionSignature: Ubuntu 4.8.0-30.32-generic 4.8.6
> Uname: Linux 4.8.0-30-generic x86_64
> ApportVersion: 2.20.3-0ubuntu8.2
> AptOrdering:
> rsplib-legacy-wrappers:amd64: Install
> NULL: ConfigurePending
> Architecture: amd64
> Date: Mon Dec 19 16:20:28 2016
> DpkgTerminalLog:
> Preparing to unpack .../rsplib-legacy-wrappers_3.0.1-1ubuntu3_amd64.deb
> ...
> Unpacking rsplib-legacy-wrappers (3.0.1-1ubuntu3) ...
> [1mdpkg: [0m error processing archive /var/cache/apt/archives/
> rsplib-legacy-wrappers_3.0.1-1ubuntu3_amd64.deb (--unpack):
> trying to overwrite '/usr/share/man/man1/terminal.1.gz', which is
> also in package ubuntu-terminal-app 0.7.218ubuntu2
> ErrorMessage: trying to overwrite '/usr/share/man/man1/terminal.1.gz',
> which is also in package ubuntu-terminal-app 0.7.218ubuntu2
> InstallationDate: Installed on 2016-11-07 (41 days ago)
> InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64
> (20161012.2)
> RelatedPackageVersions:
> dpkg 1.18.10ubuntu1
> apt 1.3.3
> SourcePackage: rsplib
> Title: package rsplib-legacy-wrappers (not installed) failed to
> install/upgrade: trying to overwrite '/usr/share/man/man1/terminal.1.gz',
> which is also in package ubuntu-terminal-app 0.7.218ubuntu2
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/rsplib/+bug/
> 1651161/+subscriptions
>

Simon Quigley (tsimonq2) on 2017-11-25
Changed in ubuntu-terminal-app (Ubuntu):
status: Confirmed → Invalid
Changed in rsplib (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers