rpy fails to import in oneiric due to version mismatch

Bug #883204 reported by beakerbreaker on 2011-10-28
34
This bug affects 16 people
Affects Status Importance Assigned to Milestone
rpy (Debian)
Fix Released
Unknown
rpy (Ubuntu)
Medium
Unassigned
Maverick
Medium
Julian Taylor
Oneiric
Medium
Julian Taylor

Bug Description

rpy needs to be rebuilt against R 2.13.1. One can't import the python module as it is built against R 2.13.0 which does not exist in oneiric anymore.

TESTCASE:
apt-get install python-rpy
python -c "import rpy"

expected result:
sucessful import no further output

oneiric result:
traceback:
  File "/usr/lib/python2.7/dist-packages/rpy.py", line 134, in <module>
    """ % RVERSION)
RuntimeError: No module named _rpy2131

Development fix:
will need to be fixed in precise, this will happen automatically with 2.40 migrates from debian but will require further observing to prevent it from breaking again for the release.

Stable fix:
a simple rebuild fixes the issue

Original report:
When I try to load the rpy module using the versions of r-base and python-rpy that ship with oneiric, I get:
>>> import rpy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/dist-packages/rpy.py", line 134, in <module>
    """ % RVERSION)
RuntimeError: No module named _rpy2131

      RPy module can not be imported. Please check if your rpy
      installation supports R 2.13.1. If you have multiple R versions
      installed, you may need to set RHOME before importing rpy. For
      example:

      >>> from rpy_options import set_options
      >>> set_options(RHOME='c:/progra~1/r/rw2011/')
      >>> from rpy import *

This appears to be a recurrence of bug 667795, which affected maverick. I assume the problem is just that rpy was built for the wrong version of R (expects 2.13.0, but 2.13.1 was shipped with oneiric). Indeed, other oneiric users are reporting the same issue in the thread for 667795, but I am reporting this separately because there doesn't appear to be anyone taking notice of those comments since the host bug is closed.

Julian Taylor (jtaylor) on 2011-10-28
Changed in rpy (Ubuntu):
status: New → Triaged
importance: Undecided → High
Julian Taylor (jtaylor) on 2011-10-28
description: updated
Julian Taylor (jtaylor) on 2011-10-28
description: updated
Stefano Rivera (stefanor) wrote :

Uploaded rebuild to oneiric-proposed. Please copy-up.

Changed in rpy (Ubuntu Oneiric):
assignee: nobody → Julian Taylor (jtaylor)
importance: Undecided → Medium
Changed in rpy (Ubuntu):
importance: High → Medium
Changed in rpy (Ubuntu Oneiric):
status: New → Fix Committed
assignee: Julian Taylor (jtaylor) → nobody
assignee: nobody → Julian Taylor (jtaylor)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rpy (Ubuntu Maverick):
status: New → Confirmed
Changed in rpy (Ubuntu Maverick):
status: Confirmed → Fix Committed
assignee: nobody → Julian Taylor (jtaylor)
importance: Undecided → Medium
Changed in rpy (Debian):
status: Unknown → New
beakerbreaker (beakerbreaker) wrote :

Thanks for the quick action on this!

Hello beakerbreaker, or anyone else affected,

Accepted rpy into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Hello beakerbreaker, or anyone else affected,

Accepted rpy into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Ciccio (franapoli) wrote :

Works for me, thank you.

Ciccio (franapoli) wrote :

(Oneiric)

Martin Pitt (pitti) on 2011-11-02
tags: added: verification-done-oneiric
beakerbreaker (beakerbreaker) wrote :

Works for me as well (also in oneiric). Thanks!

Changed in rpy (Debian):
status: New → Fix Released
Brian Murray (brian-murray) wrote :

I was able to recreate this bug report using python-rpy version 1.0.3-14 in Maverick. I then installed version 1.0.3-14build0.1 from -proposed and verified that I could now import rpy.

tags: added: verification-done-maverick
removed: verification-needed
tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rpy - 1.0.3-14build0.1

---------------
rpy (1.0.3-14build0.1) maverick-proposed; urgency=low

  * No-change rebuild for R 2.11.1 (LP: #883204)
 -- Stefano Rivera <email address hidden> Fri, 28 Oct 2011 21:07:03 +0200

Changed in rpy (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rpy - 1.0.3-18build0.1

---------------
rpy (1.0.3-18build0.1) oneiric-proposed; urgency=low

  * No-change rebuild fro R 2.13.1 (LP: #883204)
 -- Stefano Rivera <email address hidden> Fri, 28 Oct 2011 20:50:40 +0200

Changed in rpy (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.