rpy python module does not support the R shipped version (2.11.1)

Bug #667795 reported by Jérémy Subtil on 2010-10-28
76
This bug affects 15 people
Affects Status Importance Assigned to Milestone
rpy (Debian)
Fix Released
Unknown
rpy (Ubuntu)
Medium
Unassigned
Nominated for Maverick by Jérémy Subtil

Bug Description

In the Python interpreter, we get the following trace by importing the rpy module:

>>> import rpy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.6/dist-packages/rpy.py", line 134, in <module>
    """ % RVERSION)
RuntimeError: No module named _rpy2111

      RPy module can not be imported. Please check if your rpy
      installation supports R 2.11.1. If you have multiple R versions
      installed, you may need to set RHOME before importing rpy. For
      example:

      >>> from rpy_options import set_options
      >>> set_options(RHOME='c:/progra~1/r/rw2011/')
      >>> from rpy import *

Indeed, the rpy package is built for R 2.11.0, and not R 2.11.1 that is shipped with Ubuntu Maverick.

$ dpkg -L python-rpy | grep -e "_rpy.*\.so"
/usr/lib/python2.6/dist-packages/_rpy2110.so

A fix has been released in Debian few months ago, in source version 1.0.3-15.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: python-rpy 1.0.3-14
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Thu Oct 28 15:23:04 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: rpy

Jérémy Subtil (bigmadwolf) wrote :
Jérémy Subtil (bigmadwolf) wrote :

MikeM is also experiencing this bug (cf. question 131480), so I marked it as confirmed.

Changed in rpy (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

thanks for your bug report. setting triaged since the issue is an upstream one and the upstream bug is linked already.

Changed in rpy (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Jérémy Subtil (bigmadwolf) wrote :

To fix this bug, package python-rpy 1.0.3-15 should be synced from Debian.

Jérémy Subtil (bigmadwolf) wrote :

python-rpy 1.0.3-15 is currently available in Debian Squeeze: http://packages.debian.org/squeeze/python-rpy

Jakob (jakob-g) wrote :

Hi,

I am working with python and rpy. I would like to know whether there is a way of installing python-rpy 1.0.3-15.

Thanks!

Jérémy Subtil (bigmadwolf) wrote :

Hi,

I uploaded in my PPA the python-rpy 1.0.3-15 Debian package: ppa:bigmadwolf/misc

A friend of mine tried this package and reported it was working fine.

Note that this is only a workaround, a so easy bug to fix thanks to a Debian sync *MUST* be fixed in Ubuntu Maverick, it shouldn't be needed to wait for Ubuntu Natty.

Almacha (almacha) wrote :

Installing the debian package as sugested by Jérémy Subtil works for me. Precisely:
1. I downloaded the debian python-rpy package from the page given by Jérémy Subtil
2. I uninstalled the ubuntu python-rpy package
3. I installed the downloaded debian package (dpkg -i filename.deb)

Thanks for this solution.

Chris Lasher (chris.lasher) wrote :

Thanks to Jérémy for the PPA. Why hasn't this been fixed in Maverick, though?

Changed in rpy (Debian):
status: Unknown → Fix Released
Ciccio (franapoli) wrote :

Bug still present in Oneiric, but the fix by Jérémy Subtil does not seem to work anymore (python 2.6 required).

Maggie Ryn (czarnuszka22) wrote :

Hi, Im really new to this forum and in general to Ubuntu and Im a girl ;-)
Ive just upgraded to Ubuntu 11.10 (Gnome) and I also encountered this problem.

I checked in synaptic package manager and rpy was installed but didn't want to be imported to python
spitting out the same statements as above. I just manged to fix it.
What I did, Ive followed advice from amaneiro (amaneiro) on 2008-02-07:

https://bugs.launchpad.net/ubuntu/+source/rpy/+bug/128180/comments/17

I have R 2.13.0 (my own installation from source) and Python 2.7.2+, which came with oneric.

This bug was fixed in Natty but has reoccurred in oneric :-(

Good luck!

Stefano Rivera (stefanor) wrote :

Hi, sorry we missed this. Tracking the necessary rebuilds in bug #883204.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.