Job rpcbind.service/start deleted to break ordering cycle

Bug #1580523 reported by Laurent Bonnaud on 2016-05-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rpcbind (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

Here is the error:

[ 12.295037] systemd[1]: remote-fs-pre.target: Found ordering cycle on remote-fs-pre.target/start
[ 12.295043] systemd[1]: remote-fs-pre.target: Found dependency on rpcbind.service/start
[ 12.295045] systemd[1]: remote-fs-pre.target: Found dependency on rpcbind.socket/start
[ 12.295047] systemd[1]: remote-fs-pre.target: Found dependency on sysinit.target/start
[ 12.295048] systemd[1]: remote-fs-pre.target: Found dependency on zfs-fuse.service/start
[ 12.295050] systemd[1]: remote-fs-pre.target: Found dependency on remote-fs.target/start
[ 12.295052] systemd[1]: remote-fs-pre.target: Found dependency on remote-fs-pre.target/start
[ 12.295054] systemd[1]: remote-fs-pre.target: Breaking ordering cycle by deleting job rpcbind.service/start
[ 12.295056] systemd[1]: rpcbind.service: Job rpcbind.service/start deleted to break ordering cycle starting with remote-fs-pre.target/start

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: rpcbind 0.2.3-0.2
Uname: Linux 4.5.3-040503-lowlatency x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: KDE
Date: Wed May 11 11:46:51 2016
JournalErrors:
 -- Logs begin at Wed 2016-05-11 11:46:34 CEST, end at Wed 2016-05-11 11:46:46 CEST. --
 May 11 11:46:34 hostname /usr/lib/gdm3/gdm-x-session[2998]: QXcbWindow: Unhandled client message: "_NET_CURRENT_DESKTOP"
 May 11 11:46:46 hostname /usr/lib/gdm3/gdm-x-session[2998]: QXcbWindow: Unhandled client message: "_NET_CURRENT_DESKTOP"
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: rpcbind
UpgradeStatus: Upgraded to xenial on 2016-03-31 (40 days ago)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rpcbind - 0.2.3-0.4

---------------
rpcbind (0.2.3-0.4) unstable; urgency=medium

  * Non-maintainer upload.
  * debian/rcpbind.service: Add WantedBy=multi-user.target, this should ensure
    that rpcbind daemon is started before nis (Closes: #805167, LP: #1558196)

 -- Laurent Bigonville <email address hidden> Tue, 31 May 2016 11:55:08 +0200

Changed in rpcbind (Ubuntu):
status: New → Fix Released

This bug is now fixed in Debian (thanks Laurent !) but not yet in Ubuntu.

Changed in rpcbind (Ubuntu):
status: Fix Released → Confirmed
Laurent Bigonville (bigon) wrote :

It's part of my 0.2.3-0.3 upload so it should be fixed now in Yakkety

Changed in rpcbind (Ubuntu):
status: Confirmed → Fix Released
Norbert (nrbrtx) wrote :

Possible duplicate of bug 1487679.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers