TERM enviroment variable not set

Bug #651578 reported by Francesco Mosca on 2010-09-29
12
This bug affects 3 people
Affects Status Importance Assigned to Milestone
roxterm (Debian)
Unknown
Unknown
roxterm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: roxterm

in maverick, since last update (1.18.5-2ubuntu1_amd64) the TERM env variable isn't set anymore, even if 'xterm' is specified in the profile settings.

Related branches

Tony Houghton (h-realh) wrote :

Can you let me know whether any of the other variables roxterm is supposed to set/modify are working? They are:

COLORTERM
WINDOWID
ROXTERM_ID
ROXTERM_NUM
ROXTERM_PID
DISPLAY

David Zanetti (dave2-wetstring) wrote :

I also see this bug. The other variables mentioned appear to be fine, just TERM reporting as "dumb".

Version: 1.18.5-2ubuntu1
Architecture: amd64

Martin Jackson (mhjacks) wrote :

I see this too.

This causes some serious issues with my zshrc, as it uses terminfo settings to bind keys - not having TERM set causes zshrc to error out.

My symptoms seem identical to David Zanetti's above - the other settings are set, but not TERM. Even when I set TERM to something other than xterm (e.g. xterm-color) roxterm doesn't set it:

env | grep -i rox
COLORTERM=roxterm
ROXTERM_NUM=5
ROXTERM_ID=0x10c0800
ROXTERM_PID=15682
mjackson@anduril ~ %

Tony Houghton (h-realh) wrote :

Strangely I could only reproduce this by running Maverick's binary in the UNR beta. If I compiled it myself from the deb source, even without changing anything, TERM got set correctly.

I did spot a fault in the code though, which is probably responsible. Patch attached.

Martin Jackson (mhjacks) wrote :

FYI - workaround is to set TERM manually.

I do this in /etc/zshrc like so (same code should work in bash or other bourne-style shells):

if [ ! "$TERM" ]; then
        export TERM=xterm
fi

Tony Houghton (h-realh) wrote :

I think there are more problems besides 621927. I've still been having problems even after applying the env_replace patch. It's almost impossible to debug because it only affects packaged versions when run via the desktop file. If I try to run it from another shell or recompile it independently of the packaging and symlink that to /usr/bin the bug magically disappears.

I noticed that vte_terminal_form_command() is deprecated for vte_terminal_fork_command_full() so I started using that and if I rebuild 1.18.5 with this change I don't get the problem so I hope this fixes it, but I have my doubts :-(.

I've made the patch so that it can just be added with quilt after env_replace. It has to change configure and config.h.in for this to work (adding to my difficulties!).

Tony Houghton (h-realh) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package roxterm - 1.18.5-3ubuntu1

---------------
roxterm (1.18.5-3ubuntu1) natty; urgency=low

  * Merge from debian unstable (LP: #665583). Remaining changes:
    - Add patch by Tony Houghton to use vte accessor functions
  * debian/patches/fork_full: Add patch by Tony Houghton to use
    vte_terminal_fork_command full if possible
  * debian/patches/vte_accessors: Refresh patch

roxterm (1.18.5-3) unstable; urgency=low

  * Fix setting of env variables (Closes: #598971) (LP: #651578)
 -- Angel Abad <email address hidden> Tue, 26 Oct 2010 14:35:29 +0200

Changed in roxterm (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.