package rott 1.1-3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #411262 reported by U Das on 2009-08-10
248
This bug affects 53 people
Affects Status Importance Assigned to Milestone
rott (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Philip Muškovac
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: rott

The shareware data files download gives an error, after the integrity check.
This happens because the ftp link to the shareware zip is wrong in the post-installation script and thus the package configuration fails and leaves the package in a broken state.

To reproduce:
Install the rott package and choose 'Yes' when asked to install the shareware data files.

This can be fixed by changing the ftp link like described in comment #1.

This bug has been fixed in debian/unstable and testing too. So the package should be synced for lucid.

ProblemType: Package
Architecture: i386
Date: Mon Aug 10 10:54:47 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 1
NonfreeKernelModules: nvidia
Package: rott 1.1-3
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SourcePackage: rott
Title: package rott 1.1-3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
Uname: Linux 2.6.31-5-generic i686

U Das (nxb76z7f001) wrote :
Eladio Gálvez (eladiogalvez) wrote :

The package definition should be fixed, the old url to shareware levels was in:

     ftp://ftp.3drealms.com/pub/share/1rott13.zip

And now they moved to / ftp, the new url to shareware levels is:

    ftp://ftp.3drealms.com/share/1rott13.zip

Philip Muškovac (yofel) on 2009-11-03
Changed in rott (Ubuntu):
status: New → Confirmed
Philip Muškovac (yofel) wrote :

fix the broken link in the postinst script.

John Dong (jdong) wrote :

ACK from motu-sru for the above debdiff to karmic-proposed, assuming that archive-managers want to copy it from proposed->lucid.

P.S. Philip, don't forget to forward this bugfix upstream to Debian, if they're not aware already.

Philip Muškovac (yofel) wrote :

New debdiff for karmic.

description: updated
John Dong (jdong) wrote :

ACK from MOTU-SRU for the revised debdiff.

Debian has the bug fixed already; will be propagated to Lucid by sync.

Accepted into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in rott (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Eladio Gálvez (eladiogalvez) wrote :

The info in EnableProposed is not clear for install only selective software, Hendrik added a comment about this.

I tested install rott and was installed correctly, and i can play without problem.

Log about install process:

# apt-get install rott
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se actualizarán los siguientes paquetes:
  rott
1 actualizados, 0 se instalarán, 0 para eliminar y 77 no actualizados.
1 no instalados del todo o eliminados.
Necesito descargar 309kB de archivos.
Se liberarán 61,4kB después de esta operación.
Des:1 http://archive.ubuntu.com karmic-proposed/multiverse rott 1.1-3ubuntu0.1 [309kB]
Descargados 309kB en 1s (219kB/s)
Preconfigurando paquetes ...
(Leyendo la base de datos ... 00%
196421 ficheros y directorios instalados actualmente.)
Preparando para reemplazar rott 1.1-3 (usando .../rott_1.1-3ubuntu0.1_i386.deb) ...
Desempaquetando el reemplazo de rott ...
Procesando disparadores para man-db ...
Procesando disparadores para menu ...
Procesando disparadores para desktop-file-utils ...
Configurando rott (1.1-3ubuntu0.1) ...
--2009-11-15 14:22:58-- ftp://ftp.3drealms.com/share/1rott13.zip
           => `/usr/share/games/rott/1rott13.zip'
Resolviendo ftp.3drealms.com... 74.208.171.241
Conectando a ftp.3drealms.com|74.208.171.241|:21... conectado.
Identificándose como anonymous ... ¡Conectado!
==> SYST ... hecho. ==> PWD ... hecho.
==> TYPE I ... hecho. ==> CWD /share ... hecho.
==> SIZE 1rott13.zip ... 3668139
==> PASV ... hecho. ==> RETR 1rott13.zip ... hecho.
Longitud: 3668139 (3,5M)

     0K .......... .......... .......... .......... .......... 1% 53,9K 66s
    50K .......... .......... .......... .......... .......... 2% 69,8K 57s

  3500K .......... .......... .......... .......... .......... 99% 78,1K 0s
  3550K .......... .......... .......... .. 100% 66,4K=52s

2009-11-15 14:23:56(69,0 KB/s) - `/usr/share/games/rott/1rott13.zip' guardado [3668139]

Procesando disparadores para menu ...

Download full text (3.6 KiB)

ok

2009/11/15 Eladio Gálvez <email address hidden>

> The info in EnableProposed is not clear for install only selective
> software, Hendrik added a comment about this.
>
> I tested install rott and was installed correctly, and i can play
> without problem.
>
> Log about install process:
>
> # apt-get install rott
> Leyendo lista de paquetes... Hecho
> Creando árbol de dependencias
> Leyendo la información de estado... Hecho
> Se actualizarán los siguientes paquetes:
> rott
> 1 actualizados, 0 se instalarán, 0 para eliminar y 77 no actualizados.
> 1 no instalados del todo o eliminados.
> Necesito descargar 309kB de archivos.
> Se liberarán 61,4kB después de esta operación.
> Des:1 http://archive.ubuntu.com karmic-proposed/multiverse rott
> 1.1-3ubuntu0.1 [309kB]
> Descargados 309kB en 1s (219kB/s)
> Preconfigurando paquetes ...
> (Leyendo la base de datos ... 00%
> 196421 ficheros y directorios instalados actualmente.)
> Preparando para reemplazar rott 1.1-3 (usando
> .../rott_1.1-3ubuntu0.1_i386.deb) ...
> Desempaquetando el reemplazo de rott ...
> Procesando disparadores para man-db ...
> Procesando disparadores para menu ...
> Procesando disparadores para desktop-file-utils ...
> Configurando rott (1.1-3ubuntu0.1) ...
> --2009-11-15 14:22:58-- ftp://ftp.3drealms.com/share/1rott13.zip
> => `/usr/share/games/rott/1rott13.zip'
> Resolviendo ftp.3drealms.com... 74.208.171.241
> Conectando a ftp.3drealms.com|74.208.171.241|:21... conectado.
> Identificándose como anonymous ... ¡Conectado!
> ==> SYST ... hecho. ==> PWD ... hecho.
> ==> TYPE I ... hecho. ==> CWD /share ... hecho.
> ==> SIZE 1rott13.zip ... 3668139
> ==> PASV ... hecho. ==> RETR 1rott13.zip ... hecho.
> Longitud: 3668139 (3,5M)
>
> 0K .......... .......... .......... .......... .......... 1% 53,9K 66s
> 50K .......... .......... .......... .......... .......... 2% 69,8K 57s
>
> 3500K .......... .......... .......... .......... .......... 99% 78,1K 0s
> 3550K .......... .......... .......... .. 100% 66,4K=52s
>
> 2009-11-15 14:23:56(69,0 KB/s) - `/usr/share/games/rott/1rott13.zip'
> guardado [3668139]
>
>
> Procesando disparadores para menu ...
>
> --
> package rott 1.1-3 failed to install/upgrade: subprocess installed
> post-installation script returned error exit status 1
> https://bugs.launchpad.net/bugs/411262
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “rott” package in Ubuntu: Confirmed
> Status in “rott” source package in Karmic: Fix Committed
>
> Bug description:
> Binary package hint: rott
>
> The shareware data files download gives an error, after the integrity
> check.
> This happens because the ftp link to the shareware zip is wrong in the
> post-installation script and thus the package configuration fails and leaves
> the package in a broken state.
>
> To reproduce:
> Install the rott package and choose 'Yes' when asked to install the
> shareware data files.
>
> This can be fixed by changing the ftp link like described in comment #1.
>
> This bug has been fixed in debian/unstable and testing too. So the package
> should be synced for lucid.
>
> ProblemT...

Read more...

Martin Pitt (pitti) on 2009-11-15
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rott - 1.1-3ubuntu0.1

---------------
rott (1.1-3ubuntu0.1) karmic-proposed; urgency=low

  * debian/rott.postinst
    + The shareware zip moved to /share/ on the ftp,
      fix the download link again. (LP: #411262)
 -- Philip Muskovac <email address hidden> Wed, 11 Nov 2009 18:12:11 +0100

Changed in rott (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied karmic-proposed to lucid.

Changed in rott (Ubuntu):
status: Confirmed → Fix Released
Changed in rott (Ubuntu Karmic):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rott - 1.1-3ubuntu0.1

---------------
rott (1.1-3ubuntu0.1) karmic-proposed; urgency=low

  * debian/rott.postinst
    + The shareware zip moved to /share/ on the ftp,
      fix the download link again. (LP: #411262)
 -- Philip Muskovac <email address hidden> Wed, 11 Nov 2009 18:12:11 +0100

Changed in rott (Ubuntu Karmic):
status: Fix Committed → Fix Released

---------- Mensaje reenviado ----------
De: <email address hidden>
Fecha: 9 de septiembre de 2011 21:08
Asunto: Un artículo de http://www.la2da.cl enviado por
<email address hidden>
Para: <email address hidden>

ya lo sabia
------------------------------
Para ver la página, haz click en la imagen:
<http://www.la2da.cl/modulos/catalogo/Paginas/2011/09/09/LUCSGDI53SG0909.htm>
------------------------------
NOTA: El e-mail que firma este correo no ha sido validado, por lo que puede
que no sea real.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions