ROTT freezes after a short while

Bug #298992 reported by Jack Jones on 2008-11-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rott (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: rott

Hi there,

I don't know if anyone ever tried this package, but it seems to have a serious bug. It runs perfectly fine at the beginning, but the whole game freezes after a few seconds and simply does nothing anymore. This happens everytime, no matter what I set before. I always have to kill that process after that :-/

The terminal output doesn't show anything unusual:

---[snip]---
Rise of the Triad Startup Version 1.4
 Shareware Version
Z_INIT: 8950000 bytes
IN_Startup: Mouse Present
    Adding /usr/share/games/rott/HUNTBGIN.WAD.
    Adding /usr/share/games/rott/REMOTE1.RTS.
W_Wad: Wad Manager Started NUMLUMPS=2103
RT_DRAW: Tables Initialized
MU_Startup:
SD_SetupFXCard:
SD_Startup:
RT_MAIN: Fonts Initialized
RT_MSG: Message System Started
RT_VIEW: Colormaps Initialized
---[/snip]---

Can anyone confirm this?

Growlor (da-computa-guy) wrote :

I am experiencing the same behavior: game appears to launch successfully, but after a few seconds it freezes. I am running Ubuntu x86-64 v 8.10 on a dual-core AMD (Turion tl-58) box with integrated ATI (x1250) graphics if that matters.

Antonio Salazar (asalazarmx) wrote :

Same here. I'm using a clean install of Ubuntu 9.04 on a Sony VAIO FZ250FE with a Centrino Duo processor.
I tried compiling the latest version or ROTT for Linux from the icculus.org site, and it exhibits the same freezing behavior. It doesn't freeze the whole system, and can be forcefully killed.

Antonio Salazar (asalazarmx) wrote :

Installed Timidity as mister_k81 on this thread (http://ubuntuforums.org/archive/index.php/t-627983.html) suggests, and it doesn't freeze anymore.
Timidity is a suggested dependence of RotT, maybe it should be mandatory as without it it doesn't work.

Mathieu Comandon (strycore) wrote :

i agree with Antonio.
Since the package is unusable without timidity, it should be a mandatory dependency of the rott package
It's pretty damn simple to fix it

Changed in rott (Ubuntu):
status: New → Confirmed
Evgeni Golov (evgeni) wrote :

Strictly speaking: no, timidity is not a mandatory dependency of rott.
rott can (or should) be able to run without timidity with disabled sound.
You can check this by calling "rott nosound" in a terminal, that will start rott without sounds and it shouldnt hang anymore.

I will investigate further and try to fix up the thing if I'll be able to understand it fully - people who know SDL_Mixer are highly wellcome to help :)

Jon Dowland (jond) wrote :

This sounds like exactly the same issue as #101936 LP in prboom (debbugs #472087), penguin command (debian #298982)...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers