In Ubuntu 12.04 Rosegarden,Ardour and Hydrogen crash with segmentation fault at startup

Bug #993817 reported by Guest One on 2012-05-03
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
rosegarden (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu 12.04 (fresh install) when i try to start Rosegarden, Ardour or Hydrogen they crash with just the message "segmentation fault".
This is very frustrating for an LTS release and interrupt my productivity.
Can you fix this please? Thank you very much!

Guest One (g.one) wrote :

Nobody has crashes at startup with Ardour,Rosegarden and Hydrogen?

Guest One (g.one) wrote :

From logs:

 kernel: [ 3395.714625] show_signal_msg: 27 callbacks suppressed
 kernel: [ 3395.714632] rosegarden[2556]: segfault at 0 ip b5ff0e78 sp b29feaa0 error 4 in libc-2.15.so[b5ef3000+19f000]

 kernel: [ 3713.425398] ardour-2.8.12[2733]: segfault at 0 ip b622be78 sp bf87a7c0 error 4 in libc-2.15.so[b612e000+19f000]

 kernel: [ 3802.927271] hydrogen[2835]: segfault at 0 ip b5fe4e78 sp bfb64990 error 4 in libc-2.15.so[b5ee7000+19f000]

Ton (ton-venhuizen) wrote :

Hi, I run Ubuntu on a laptop and a PC, on both Audacity also crashes (and Hydrogen, Rosegarden, Ardour). Synths and jack however run fine.

Guest One (g.one) wrote :

Same situation here Ton.
Jack and Zynaddsubfx run fine.
Some dev can help us? (maybe Ubuntu Studio devs?)

Ton (ton-venhuizen) wrote :

Just discovered that guitar tab program "Songwrite" also crashes. The guitar tab program "tuxguitar" however launches fine. Maybe this can give a clue about the problem. Ubuntu studio desktop did not solve the problem.. help!

Guest One (g.one) wrote :

Ton:

sudo apt-get remove libcsound64-5.2

and your software will return to run.
This is my solution for now.
But... i can't accept this tricks on an LTS.
No devs have interest in this bug?

Scott Lavender (slavender) wrote :

jeff,

i'll look into this soon or poke someone else about it.

Ton (ton-venhuizen) wrote :

Hi Jeff,

sudo apt-get remove libcsound64-5.2 partly worked,
Audacity, Ardour, Hydrogen and Rosegarden running again.
Songwrite still crashes, so still something's wrong.
As you said, deleteing a library doesn't seem to be a structural solution.

Nevertheless, thanks for the solution. I can do my music things again on Ubuntu!

Ton

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rosegarden (Ubuntu):
status: New → Confirmed
Ton (ton-venhuizen) wrote :

Just for the record, my Ubuntu was not a fresh install but an upgrade from 11.10

Marcos Wasem (mwasem) wrote :

I have had this problem only with Rosegarden. No problem with Ardour and Hydrogen. The message I get when starting from terminal is:

GLib (gthread-posix.c): Unexpected error from C library during 'pthread_setspecific': Invalid argument. Aborting.

Marcos Wasem (mwasem) wrote :

I've finally got it working after I upgraded to version 12.04 that I found in quantal repositories. It works as a charm. Maybe you shold consider to move the upgrade to proposed?

Matthias (funny-hangman-gmx) wrote :

Hi, I had the same problem with rosegarden:
GLib (gthread-posix.c): Unexpected error from C library during 'pthread_setspecific'

It was a conflict with guitarix 0.22.3-1 --> uninstall works for me.

Marcos Wasem (mwasem) wrote :

Too bad! I need guitrix madly! Anyway, as of today Rosegarden 12.04 is in KX Studio PPA, it worked for me without uninstalling anything. Thanks for the tip anyway.

kamensky (kamensky) wrote :

Rosegarden crashed sporadli always recording a long midi part or handling/move/editing with midi-part. I change the Xfce GUI to something other like Gnome. Now it works very stable wouw great before it was not a great sh....

SO it could be somethng x-server<=>XFCE<=>QT ?

cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04 LTS"

uname -r
3.2.0-23-lowlatency

rosegarden 11.11.42
qt 4.7.4

kamensky (kamensky) wrote :

Sorry the same with Gnome: segmentation fault

[seqman] SequenceManager::event() with user event

[seqman] SequenceManager::event(): update requested

[seqman] SequenceManager::checkRefreshStatus()

[seqman] SequenceManager::checkRefreshStatus: segments modified by changes to trigger segments are:

Guest One (g.one) wrote :

Some news?

David Boddie (davidb-q) wrote :

Have people tried running the Qt-based applications with a different style, using the "-style Cleanlooks" command line option, for example? Did that help?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers