Rosegarden should depend on timidity

Bug #308303 reported by goto on 2008-12-15
8
Affects Status Importance Assigned to Milestone
rosegarden (Ubuntu)
Undecided
Bhavani Shankar

Bug Description

Binary package hint: rosegarden

Hello,
as the title says. Just installed rosegarden and wondered, why there was no sound. I found in the internet that I had to install timidity. Then sound worked. Everyone who uses rosegarden wants sound too, so it should depend on timidity.
Thanks.

Related branches

Bhavani Shankar (bhavi) wrote :

Hello

Could you please provide a bit more depth so that it can be confirmed and acted upon.

Regards

goto (gotolaunchpad) wrote :

Rosegarden is an application for playing and modifying .midi files. I installed it via sudo apt-get install rosegarden, but when I started it, I had no sound in this application.
After searching the web with google I found a hint: I had to install timidity. I installed that package and then the sound worked. So I think, that timidity should be installed automatically if rosegarden gets installed.
Thanks!

Bhavani Shankar (bhavi) wrote :

Okay! can anyone please confirm?

I have not yet gotten sound working with Rosegarden (it's much more difficult than Windows counterparts!); however, this is basically correct.

The only problem is that there are two options.

Timidity is one, and Timidity depends on Freepats, which is a set of free-licensed soundfonts. Probably the most complete (or only) free soundfont set, but is still incomplete.

The other option is Fluidsynth. My understanding is that Fluidsynth CANNOT work with Freepats, and needs non-free, third-party soundfonts, which can be found on various websites.

So for easy and painless setup, Timidity is probably the best option, but supposedly would result in a lower quality than Fluidsynth with a third-party soundfont would.

Zhang Weiwu (zhangweiwu) wrote :

I just started trying these and getting rosegarden working is surprisingly difficult in my case. I'd even compare the difficulty to Apache configuration with ssl + authenticate against openldap database for a newbie who just managed to understand & configure vsftpd. There are a lot of cases that this works, that doesn't etc and strange behavior.

As of dependency, reading documents (especially this one: http://wiki.debian.org/DebianEdu/Documentation/Manuals/Rosegarden/Setup) you can see rosegarden expects professional users, and assume you have hardware midi device. This is IMHO basically a wrong approch because new user has to manage to get it work before deciding going professional and buy hardware devices, whlie there is no second Linux free software with similiar function but orient beginner so they had to begin with professional software. But, if you make rosegarden depends on timidity it might make professional users who hate to have timidity running pissed off.

Personally I don't mind piss off some "professional users" and sometimes I would love to do so when they cannot think user-oriented. I'd vote a "yes" on this but still want to share above information with you.

Bhavani Shankar (bhavi) wrote :

I d test out rosegarden rather and report back

Changed in rosegarden (Ubuntu):
status: New → In Progress
assignee: nobody → Bhavani Shankar (bhavi)
Bhavani Shankar (bhavi) wrote :

here are the debs created

https://edge.launchpad.net/~bhavi/+archive/experimental/+build/1132877

Please test it out .....

Jaap Versteegh (j-r-versteegh) wrote :

Depending on timidity may not be a good idea, because people with midi hardware or soundcards that support midi in hardware probably don't need or even want a software midi synthesizer like timidity.
Rosegarden should *suggest* timidity, which it doesn't do currently (jaunty)

Zhang Weiwu (zhangweiwu) wrote :

I recently learned fluidsync can also be used as software synthesizer except it doesn't come with any sound font, unlike timidity that can play music on its own (because of the package it depends). In short there is more than one way to do software synthesize.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rosegarden - 1:10.02-0ubuntu1

---------------
rosegarden (1:10.02-0ubuntu1) lucid; urgency=low

  * New upstream release:
    - Remove build-dependency on kdelibs5-dev (Rosegarden no longer uses KDE)
    - Remove build-dependency on cmake; no longer used
    - Add build-depends on libqt4-dev, libsm-dev, libsndfile1-dev,
      libsamplerate0-dev, and xutils-dev
    - Remove debian/patches, all patches either merged or irrelevant. Also
      remove dpatch build-depend
    - Update .install files for new upstream release
    - Remove manpages for now-nonexistant binaries
    - Remove debian/x-rosegarden.desktop, upstream seems to support this now
    - Remove konqueror as an optional depend for rosegarden, any www-browser
      will do, and Konqueror has no significance now that Rosegarden doesn't
      use KDE for launching the browser
    Fixes LP: #521706
  * Switch packaging to dh short rules:
    - Bump debhelper version to 7.3.16
    - Bump compat to 7
    - Add manpages file for the rosegarden manpage
  * Switch to source format 3.0 (quilt)
  * Bump Standards-Version to 3.8.4
  * Add dependency on samplerate-programs (LP: #360812)
  * Recommend timidity. Don't worry, you can opt to not install it by passing
    --no-install-recommends to apt while installing rosegarden (LP: #308303)
 -- Jonathan Thomas <email address hidden> Tue, 16 Feb 2010 20:51:59 -0500

Changed in rosegarden (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers