Please sync rootstrap (universe) from Debian unstable (main)

Bug #130640 reported by Michael Bienia on 2007-08-06
8
Affects Status Importance Assigned to Milestone
rootstrap (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: RIPEMD160

 affects ubuntu/rootstrap
 status confirmed
 subscribe ubuntu-archive

Please sync rootstrap (universe) from Debian unstable (main).
Changelog since current gutsy version 0:

rootstrap (0.3.24-3) unstable; urgency=low

  * build also on amd64
  * use debian/compat and bump debhelper dependency

 -- Mattia Dongili <email address hidden> Sun, 27 May 2007 20:48:44 +0900

rootstrap (0.3.24-2) unstable; urgency=low

  * install Etch by default (Closes: #400135)

 -- Mattia Dongili <email address hidden> Fri, 24 Nov 2006 18:31:59 +0100

rootstrap (0.3.24-1) unstable; urgency=low

  * correctly write the timezone file in the guest FS (Closes: #388055)
  * try to print descriptive error messages when a module fails
    (Closes: #388061)
  * use /dev/ubda not /dev/ubd0 in /etc/fstab (Closes: #388121)
  * allow debconf preseeding using files both in $WORKDIR or $HOST
    (Closes: #387679)
  * fix apt_preferences emtpy line handling. (Closes: #372901)
  * document umlargs in rootstrap.conf.
  * disable logfile usage if debugging is enabled.

 -- Mattia Dongili <email address hidden> Sun, 12 Nov 2006 18:05:42 +0100

rootstrap (0.3.23-1) unstable; urgency=low

  * test for base-config executable in the base-config module
    (Closes: #374582).
  * fix reiserfs invocation, thanks to Andreas Beckmann (Closes: #372828).
  * allow mounting the hostfs to /lib/modules. (Closes: #377035);
  * fix root password handling in base-config.
  * unmount /proc after using it in modules/uml. (Closes: #372905)
  * disable hwclock on the newly created image, thanks to Matthew Palmer.
    (Closes: #311037)
  * allow using the --force-yes apt switch to install from untrusted
    sources. (Closes: #372937)
  * allow configuring /etc/apt/preferences and /etc/apt/apt.conf in the target
    FS, thanks to Andreas Beckmann. (Closes: #372901)
  * allow preseeding Debconf values. (Closes: #372906)
  * the manpage has been fed enough. (Closes: #294214)

 -- Mattia Dongili <email address hidden> Thu, 31 Aug 2006 20:51:43 +0200

rootstrap (0.3.22-1) unstable; urgency=low

  * ubd dev missing: updated mkfs and mount modules to create it (Closes: #342694)
  * updated Standards depedency to the latest (3.7.2)
  * drop versioned dependencies on user-mode-linux allows rootstrap to work
    with kernel-package self-built kernels.
    (Closes: #275410) (Closes: #282914) (Closes: #320410)
  * ensure that the UML kernel is able to find uml_net (Closes: #304461)
  * add reference of the hostfs need on man page (Closes: #300221)
  * implement a "sources" option for the [debian] modules to
    let users give their favourite repositories (Closes: #172296)

 -- Stefano Melchior <email address hidden> Sun, 21 May 2006 23:19:38 +0200

rootstrap (0.3.21-1) unstable; urgency=low

  * If there are no processes left running which use the target
    filesystem, don't let the (failing) fuser call abort the entire script
    (Closes: #255531)

 -- Matt Zimmerman <email address hidden> Mon, 21 Jun 2004 12:08:06 -0700

rootstrap (0.3.20-1) unstable; urgency=low

  * Only pay attention to the [network]/gateway option when not using
    uml=dhcp
  * Divert start-stop-daemon, as debootstrap does, while installing
    packages with apt
  * Use fuser to kill off any processes using the target root fs, so that
    it can be unmounted

 -- Matt Zimmerman <email address hidden> Sun, 6 Jun 2004 11:28:16 -0700

rootstrap (0.3.19-1) unstable; urgency=low

  * The initialsize/freespace settings seem to confuse people; increase
    initialsize and set freespace to zero, to get a 1GB sparse image with
    no resizing by default (Closes: #205972)

 -- Matt Zimmerman <email address hidden> Sun, 14 Mar 2004 18:34:20 -0800

rootstrap (0.3.18-1) unstable; urgency=low

  * New base-config module, which invokes base-config to configure the
    base system. This currently only works on sarge+ because it uses
    debconf-set-selections, and it doesn't really work there either due to
    limitations in base-config (it doesn't honor some important pre-seeded
    debconf responses)
  * Set default root password to 'rootstrap' in base-config module
    (Closes: #224430)
  * New tasksel module
  * Fix -u/--umlargs, rename to --umlarg and have it only take one argument

 -- Matt Zimmerman <email address hidden> Mon, 16 Feb 2004 11:33:31 -0800

rootstrap (0.3.17-1) unstable; urgency=low

  * Make "imagefile" one word on the man page, so it's clear that it's a
    single argument
  * -s is in megabytes, like initialsize in rootstrap.conf
  * Make the network/control parameter, used with the daemon transport,
    optional, since UML now has a reasonable compiled-in default

 -- Matt Zimmerman <email address hidden> Fri, 19 Sep 2003 21:42:37 -0400

rootstrap (0.3.16-1) unstable; urgency=low

  * Set the hostname in the rootstrapped system, rather than
    leaving it blank (some packages can't install without a hostname).
    Thanks to Mike Snitzer for working this out
    rootstrap still doesn't really configure the base system (suggestions
    welcome; see #211397)
  * set -e on more modules

 -- Matt Zimmerman <email address hidden> Wed, 17 Sep 2003 10:19:47 -0400

rootstrap (0.3.15-1) unstable; urgency=low

  * Add -c/--config option to specify a config file to read

 -- Matt Zimmerman <email address hidden> Mon, 15 Sep 2003 19:15:28 -0400

rootstrap (0.3.14-1) unstable; urgency=low

  * [modules/debian] Transfer DNS configuration into resolv.conf in the
    generated system
  * Correctly remount the hostfs-root read-only
  * Make some of the modules more robust, and run with set -e
  * [modules/{debian,network}] DHCP support for networking configuration
  * [rootstrap.conf] Don't exclude dhcp-client anymore
  * Change daemon transport syntax to match new interface (no more
    separate data socket)

 -- Matt Zimmerman <email address hidden> Sun, 14 Sep 2003 20:46:43 -0400

rootstrap (0.3.13-1) unstable; urgency=low

  * Fix ext3 handling (mkfs.ext3 works fine without -j)
    (Closes: #199882)
  * Add support for uml_switch networking (Closes: #207631)

 -- Matt Zimmerman <email address hidden> Mon, 1 Sep 2003 13:42:15 -0400

rootstrap (0.3.12-1) unstable; urgency=low

  * Increase default initalsize to 256, which is enough room for
    base+build-essential+umlrun on i386. Note that this is created
    sparsely, and shrunk down to reflect freespace if it is not used
  * Depend on more recent user-mode-linux, for new hostfs-root syntax
    (Closes: #197480)
  * Really fix the stupid man page problem (Closes: #191767)

 -- Matt Zimmerman <email address hidden> Thu, 19 Jun 2003 16:03:02 -0400

rootstrap (0.3.11-1) unstable; urgency=low

  * When network configuration is enabled in the debian module, configure
    the loopback interface as well
  * Fiddle with man page so that it doesn't eat a line of input.
    I hate groff (Closes: #191767)
  * Add network/slirp config option, primarily for use with the patch in
    #175093 (hopefully will be merged soon)

 -- Matt Zimmerman <email address hidden> Sat, 3 May 2003 13:54:51 -0400

rootstrap (0.3.10-1) unstable; urgency=low

  * Fix the debian module's 'install' directive to be non-interactive
  * Patch from Brian May to invoke dpkg in the target rather than using
    dpkg --root (Closes: #189355)
  * Handle building on a block device a bit more gracefully (I hope)
    (Closes: #188047)

 -- Matt Zimmerman <email address hidden> Sun, 20 Apr 2003 15:39:38 -0400

rootstrap (0.3.9-1) unstable; urgency=low

  * Use new syntax for mounting root hostfs
  * Only clobber regular files (Closes: #185672)

 -- Matt Zimmerman <email address hidden> Fri, 4 Apr 2003 21:12:49 -0500

rootstrap (0.3.8-1) unstable; urgency=low

  * Use DEBIAN_FRONTEND=noninteractive, not Noninteractive
    (Closes: #175958)
  * Preconfigured tap support (Closes: #166152)
  * Use long integers so that larger image sizes work (Closes: #183375)
  * Add vim magic comment (Closes: #183350)
  * Suggests: slirp

 -- Matt Zimmerman <email address hidden> Tue, 4 Mar 2003 19:39:49 -0500

rootstrap (0.3.7-1) unstable; urgency=low

  * Add support for the slirp transport. For this to be really useful,
    you must rebuild slirp with the FULL_BOLT option for reasonable
    performance. However, once this is done, networking works with no
    address configuration or root access.

 -- Matt Zimmerman <email address hidden> Thu, 9 Jan 2003 21:37:46 -0500

rootstrap (0.3.6-1) unstable; urgency=low

  * Update and clarify man page
  * Fix one-character error which prevent the -u/--umlargs option fram working

 -- Matt Zimmerman <email address hidden> Mon, 21 Oct 2002 22:16:05 -0400

rootstrap (0.3.5-1) unstable; urgency=low

  * Add support to the debian module for saving the network configuration
    to /etc/network/interfaces
  * Add pointer to GPL in copyright (thanks, linda)

 -- Matt Zimmerman <email address hidden> Sat, 21 Sep 2002 18:43:48 -0400

rootstrap (0.3.4-1) unstable; urgency=low

  * Fix default configuration to use a valid Debian mirror.
    Thanks to <email address hidden> for pointing this out.
  * s/DEBCONF_FRONTEND/DEBIAN_FRONTEND/ so that we correctly get the
    noninteractive frontend. This should cut down greatly on debconf
    warnings.
  * Fix a bug whereby if a module was overloaded by a local version, the
    original was still run. Chaos ensued when both modules executed.

 -- Matt Zimmerman <email address hidden> Thu, 25 Jul 2002 13:36:09 -0400

rootstrap (0.3.3-1) unstable; urgency=low

  * Don't fail if no network configuration is specified. This allows
    installations from local mirrors and CDs.
    (Closes: #151478)
  * Be more conservative, and fail the entire build process if any module
    fails. This makes it harder to overlook important errors.
  * Clarify documentation for the debian/mirror option, which must be a
    URL understood by debootstrap (Closes: #151482)

 -- Matt Zimmerman <email address hidden> Sun, 30 Jun 2002 19:41:56 -0400

rootstrap (0.3.2-1) unstable; urgency=low

  * Mount the working directory as a separate hostfs filesystem, rather
    than assuming it will be available via the root-hostfs mount. This
    makes it possible to use /tmp as your workspace on the host
    (Closes: #147712)

 -- Matt Zimmerman <email address hidden> Thu, 23 May 2002 20:02:09 -0400

rootstrap (0.3.1-2) unstable; urgency=low

  * Fix build-depends to reflect that we use docbook-to-man again
    (Closes: #146590)

 -- Matt Zimmerman <email address hidden> Fri, 10 May 2002 23:57:08 -0400

rootstrap (0.3.1-1) unstable; urgency=low

  * Fix the mkisofs module so that it works with the new hostfs setup
  * Remove build-dependency on mkcramfs
  * Update uml module to add an fstab entry for /proc

 -- Matt Zimmerman <email address hidden> Tue, 7 May 2002 23:10:43 -0400

rootstrap (0.3-1) unstable; urgency=low

  * Get rid of the cramfs hack, instead use tmpfs filesystems to overlay
    the parts of the host filesystem that we don't want (such as /etc)
  * Fix all modules to use $TARGET instead of /target, as the target mount
    point has moved (and could again). All custom modules must be updated
    to use $TARGET.
  * Add a setting to rootstrap.conf to allow configuration of a nameserver
    (Closes: #143171)

 -- Matt Zimmerman <email address hidden> Wed, 17 Apr 2002 22:15:55 -0400

rootstrap (0.2.4-1) unstable; urgency=low

  * Build the man page with docbook-to-man instead of docbook2man, because
    the latter seems to garble the output (Closes: #140857)
  * Append /sbin:/usr/sbin to PATH when building, to ensure that mkcramfs
    can be found (Closes: #142130)

 -- Matt Zimmerman <email address hidden> Wed, 10 Apr 2002 23:19:25 -0400

rootstrap (0.2.3-1) unstable; urgency=low

  * New code release
    - Fix a bug in the creation of ubd devices by the uml module

 -- Matt Zimmerman <email address hidden> Thu, 28 Mar 2002 22:13:26 -0500

rootstrap (0.2.2-1) unstable; urgency=low

  * New code release
    - Add an option to the debian module to install additional packages
      with apt
    - Make the installation of uml kernel modules an optional behaviour
    - Use DEBCONF_FRONTEND=Noninteractive to suppress warning messages
      about debconf falling back to it from other frontends
    - Manually create a ubd0 device for UML, since potato's MAKEDEV
      doesn't understand ubd
    - Append /sbin:/usr/sbin to PATH so that we can always find tune2fs if
      it is installed (Closes: #138398)

 -- Matt Zimmerman <email address hidden> Sat, 16 Mar 2002 16:14:01 -0500

rootstrap (0.2.1-1) unstable; urgency=low

  * New code release
    - Pass devfs=mount to UML when booting the initial filesystem, since
      the latest packages do not mount it by default

 -- Matt Zimmerman <email address hidden> Wed, 13 Mar 2002 09:26:42 -0500

rootstrap (0.2-1) unstable; urgency=low

  * New code release
    - Includes man page (Closes: #137849)
    - No need to try to remount root read-only now that cramfs is used
      (old cruft)
    - Removed unused -p option; I forget what it was intended to do
  * Depend on debootstrap >= 0.1.16.4, because that version fixes
    --include

 -- Matt Zimmerman <email address hidden> Tue, 12 Mar 2002 23:54:25 -0500

rootstrap (0.1-1) unstable; urgency=low

  * Initial Release.

 -- Matt Zimmerman <email address hidden> Tue, 29 Jan 2002 03:58:56 -0500

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.4 (GNU/Linux)

iQCVAwUBRrcee6PP1313boLqAQOyCgP8D3xo8TWWYGDcBog7Oz8IagC9MpdAOsZG
RMUeI4/m3UqrdQgKhiHqPeCIH0QHXlZO61fMPGQmMCVBya/XpJl7uGsY+l76EwHN
dSzY6gWkJPw5sSZU9z6/DORBE76voypir6jLnOa/Is1l16JzkbfPWecNTxduE+Lg
FzQePBklHIc=
=9JqD
-----END PGP SIGNATURE-----

Jonathan Riddell (jr) wrote :

Closing, this is blacklisted with comment "benc: we do our own kernel"

Changed in rootstrap:
status: Confirmed → Invalid
John Schofield (jschofield) wrote :

Not including rootstrap means that pbuilder-uml can never be useful.

If rootstrap will not be included in Ubuntu, this case: https://bugs.launchpad.net/ubuntu/+source/pbuilder/+bug/106949
should probably be resolved by removing pbuilder-uml from Ubuntu, as it can't work without rootstrap.

(Note that I'd REALLY like to be able to use pbuilder-uml, as there isn't another good way to build packages in a clean environment as non-root.)

Daniel Hahler (blueyed) wrote :

Re-opening and subscribing Ben Collins.
Ben, can you please explain why "rootstrap" has been blacklisted exactly? As said above, it's a requirement for pbuilder-uml (bug 106949).

Changed in rootstrap:
importance: Undecided → Wishlist
status: Invalid → New
Martin Pitt (pitti) on 2008-03-07
Changed in rootstrap:
status: New → Incomplete
Jonathan Riddell (jr) wrote :

blacklist removed after checking with benc. synced.

Getting binaries for hardy...
[Updating] rootstrap (0 [Ubuntu] < 0.3.24-4 [Debian])
 * Trying to add rootstrap...
  - <rootstrap_0.3.24.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <rootstrap_0.3.24-4.dsc: downloading from http://ftp.debian.org/debian/>
  - <rootstrap_0.3.24-4.diff.gz: downloading from http://ftp.debian.org/debian/>

Changed in rootstrap:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers