Fails to display video after grub (kernel lacks video output)

Bug #745947 reported by Patrick Domack on 2011-03-30
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rootskel (Ubuntu)
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: debian-installer

Attempt to install natty amd64/i386 fails after menu selection in gfxboot when using ESXi 4.1update1 (with 4mb video or auto video ram options), due to video issue with linux kernel.

Using nomodeset has no effect.

Removing the vga=788 option causes it to boot and work in text mode.
This wasn't an issue with the alpha installs.
---
Architecture: amd64
DistroRelease: Ubuntu 11.04
InstallationMedia: Ubuntu-Server 11.04 "Natty Narwhal" - Beta 1 amd64 (20110329.2)
InstallationMedia_: Ubuntu-Server 11.04 "Natty Narwhal" - Beta 1 amd64 (20110329.2)
Lsusb: Error: command ['lsusb'] failed with exit code 1:
MachineType: VMware, Inc. VMware Virtual Platform
MemoryUsage:
 total used free shared buffers cached
 Mem: 504292 225080 279212 0 11112 123708
 -/+ buffers/cache: 90260 414032
 Swap: 522236 0 522236
Package: debian-installer (not installed)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-virtual root=UUID=9b806988-5e10-4684-a533-ec500fb8f1c9 ro quiet
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-virtual root=UUID=9b806988-5e10-4684-a533-ec500fb8f1c9 ro quiet
ProcVersionSignature: Ubuntu 2.6.38-7.39-virtual 2.6.38
ProcVersionSignature_: Ubuntu 2.6.38-7.39-virtual 2.6.38
Tags: natty natty
Uname: Linux 2.6.38-7-virtual x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 10/13/2009
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 6.00
dmi.board.name: 440BX Desktop Reference Platform
dmi.board.vendor: Intel Corporation
dmi.board.version: None
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr6.00:bd10/13/2009:svnVMware,Inc.:pnVMwareVirtualPlatform:pvrNone:rvnIntelCorporation:rn440BXDesktopReferencePlatform:rvrNone:cvnNoEnclosure:ct1:cvrN/A:
dmi.product.name: VMware Virtual Platform
dmi.product.version: None
dmi.sys.vendor: VMware, Inc.

Related branches

tags: added: iso-testing
Changed in debian-installer (Ubuntu Natty):
importance: Undecided → High
Colin Watson (cjwatson) wrote :

I initially reassigned this over to grub2, but that was a mistake - you're talking about booting the installer here, and that doesn't use GRUB.

vga=788 is a *lot* faster on some systems, and makes the installer a great deal more pleasant to use. I wonder how we can resolve this without losing that property?

affects: debian-installer (Ubuntu Natty) → grub2 (Ubuntu Natty)
affects: grub2 (Ubuntu Natty) → debian-installer (Ubuntu Natty)
description: updated
Colin Watson (cjwatson) wrote :

Also, you said "due to video issue with linux kernel". Has this been filed anywhere as a bug on the Linux kernel? Can you provide a link to details?

Patrick Domack (patrickdk) wrote :

Yep, this bug report, this is a kernel issue to me atleast, not grub.

I tried about 10 other options to vga=, but none work.

Changed in debian-installer (Ubuntu Natty):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Tim Gardner (timg-tpi) wrote :

Patrick - it would be handy if we could get some HW specifics using 'apport-collect 745947'

apport information

tags: added: apport-collected natty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Tim Gardner (timg-tpi) wrote :

Unfortunately, or fortunately depending on your point of view, VMware Workstation 7.1.3 seems to work fine.

Tim Gardner (timg-tpi) wrote :

Have acquired ESXi and am getting it installed.

Changed in debian-installer (Ubuntu Natty):
assignee: Canonical Kernel Team (canonical-kernel-team) → Tim Gardner (timg-tpi)
status: New → In Progress
affects: debian-installer (Ubuntu Natty) → linux (Ubuntu Natty)
Patrick Domack (patrickdk) wrote :

Odd, I get the same result on VMware Workstation, 7.1.2 and 7.1.4, 64bit installed on 10.04

I tried it with and without 3d graphics enabled.

And with both iso images, i386 and amd64.

Tim Gardner (timg-tpi) wrote :

Patrick - what are the host HW specifics? I've not been able to see any issues using the Natty i386 daily CDROM ISO from April 4, 10.04 host (2.6.32-32-generic), VMware Workstation 7.1.4, nVidia GeForce 9800 GX2 (using the binary driver). I've tried both "Easy Install" as well as going through the debian-installer text menu (by using the 'I will install the operating system later' option).

One change that may be affecting you came out with 2.6.38-7.36: "[Config] switch CONFIG_FB_VESA back to module".

Patrick Domack (patrickdk) wrote :

For esx 4.1update1, it's dell r410 servers

For workstation:
  intel E8600, 8gig ram, GeForce 9300 GE (using nvidia driver 260.19.26)

I never use the easy install option.

When cd boots, I select english, then Install Ubuntu Server, screen resizes larger, and that is all I ever see, besides the cd and disk access led's blinking.

I have no idea how you get the text menu, it's all graphics.

Tim Gardner (timg-tpi) wrote :

Ah, the _server_ CDROM. I've gotta start reading for content.

OK, I can reproduce this bug. In fact, its also happening on bare metal (Intel Emerald class server), though the symptom is that the display just goes blank. The same fix (remove vga=788) allows it to boot into the installer.

Tim Gardner (timg-tpi) wrote :

After working with Colin Watson, using VMware Workstation as a reproducer, we found that vesafb was not getting loaded. You can experiment with this by replacing 'quiet --' with 'BOOT_DEBUG=3', then blindly entering 'modprobe vesafb'.

This regression is almost surely due to the modularization of vesafb (CONFIG_FB_VESA=m) which prevents adverse graphics interaction with Plymouth on the desktop. One possible workaround is to revert this change for the -server flavour, e.g., CONFIG_FB_VESA=y. The desktop install does not use the 'vga=788' boot option.

Sean Sheedy (sean-thesheedys) wrote :

I am also seeing this issue in VMware Fusion 3.1.2 on a MacBook Pro, using the 11.04 i386 Beta1 DVD image, in a text-mode installation.

The installation appears to "hang" almost immediately after text-mode installation is selected.

The installation screen will appear and installation can be continued using the methods already suggested (removing 'vga=788' from the boot command line, or loading vesafb from a shell enabled by the BOOT_DEBUG=3 option) or by blindly switching to a second virtual console and enabling vesafb there (see below.)

If one selects a command-line-only text-mode installation (by selecting text-mode installation, then F4 and the command-line option), and completing the installation using one of these workarounds (selecting default options to the extent possible), then when the installed VM is booted, no text is shown until fn-ctrl-alt-F1 is pressed.

Details:

VMware host:
- VMware Fusion 3.1.2 (current version)
- Late 2006 MacBook Pro host (model A1212)
- T7600 Core 2 Duo CPU
- ATI Mobility Radeon X1600
- 3 GB SDRAM
- Using Ubuntu disk image: ubuntu-10.10-dvd-i386.iso

To duplicate:
- In VMware Fusion 3.1.2, create a new virtual machine using the default settings and specifying the beta1 ISO as the OS image. Uncheck "Easy Install" if that option is presented.
- Start the virtual machine and observe that the installer presents the initial installation menu correctly.
- Select the text-mode installation option, hit return to start the installation.
- Observe the display resize and then hang. Sometimes the installation menu remains displayed (also resized) and sometimes only a single underscore is displayed at the top-left corner.
- To recover the display and continue the installation, after the "hang", blindly press fn-ctrl-alt-F2, hit return, and type 'modprobe vesafb'. The virtual console will appear; press fn-ctrl-alt-F1 to return to the installation console (thanks for the tips above.)

I experience a similar problem on a Sony VAIO Z12, using Ubuntu Desktop 11.04 beta. After selecting the first option in the Live CD menu ("try ubuntu", or such), I quickly get a black screen. Minutes later, a beautiful GNOME desktop appears. I experience the same black screen during shutdown. I would have thought the system had hung if it wasn't for optical drive activity. ;)

The Z12 has two graphics cards, one nvidia and one intel, and I can control which one is activated via BIOS. I only noticed this issue when intel is being used. With nvidia, I could see stuff on the screen during boot. So maybe this is a conflict between vga= and intel cards.

Colin Watson (cjwatson) wrote :

While this was triggered by a linux change, I think it's a d-i bug, not a linux bug. The root problem is that debian-installer-startup's stdin is /dev/console, which rootskel thinks indicates a serial console. When I do the same test in kvm, I find that debian-installer-startup's stdin is /dev/tty0.

I'm trying to narrow down the cause of this discrepancy at the moment.

Colin Watson (cjwatson) wrote :

Tim: reverting the change for the -server flavour would do no good, incidentally. The server *installer* uses the -generic kernel.

Tim Gardner (timg-tpi) wrote :

Colin - Given your opinion that this is not a kernel bug, I'm quite happy to reassign to the debian-installer package.

affects: linux (Ubuntu Natty) → debian-installer (Ubuntu Natty)
Changed in debian-installer (Ubuntu Natty):
assignee: Tim Gardner (timg-tpi) → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

As ever, the fix was easy once I spent several hours finding the right place. ;-)

affects: debian-installer (Ubuntu Natty) → rootskel (Ubuntu Natty)
Colin Watson (cjwatson) wrote :

Justin: Please file a separate bug, as the problem you describe is unrelated to this one (even if the symptoms may appear similar).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rootskel - 1.94ubuntu1

---------------
rootskel (1.94ubuntu1) natty; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Provide the ability to choose a remote logging host and port if
      specified on the kernel command line.
    - Build for ppc64 and create a lib64 symlink there.
    - Apply configurable console colors in d-i virtual terminals.

rootskel (1.94) unstable; urgency=low

  [ Samuel Thibault ]
  * src/lib/debian-installer/exit-hurd: pass -f to busybox to make it simply
    call reboot(), which DTRT.

  [ Jurij Smakov ]
  * Set DEB_HOST_ARCH_OS in src/Makefile to make sure that everything builds
    correctly without help from dpkg-buildpackage.

  [ Colin Watson ]
  * Bump the amount of data reopen-console-linux reads from the kernel ring
    buffer from 64KiB to 256KiB. This fixes console detection on (at least)
    VMware Workstation (LP: #745947).
 -- Colin Watson <email address hidden> Thu, 07 Apr 2011 22:50:53 +0100

Changed in rootskel (Ubuntu Natty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers