Ubuntu

libRlapack.so: cannot open

Reported by studentz on 2008-09-03

This bug report was converted into a question: question #44070: libRlapack.so: cannot open .

2
Affects Status Importance Assigned to Milestone
rkward (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: rkward

Thanks for a wonderful GUI of R..Here is my problem: After I upgraded
( I do not remember which packages) the app is not working anymore. I
reinstalled, downgraded the app without any success.

This is the message after launched in a console:

/usr/bin/rkward.bin: error while loading shared libraries:
libRlapack.so: cannot open shared object file: No such file or directory
(I looked for the file in my file system and home and it is not present)

Platform

Ubuntu Hardy

rkward_0.4.9-2ubuntu0.1_i386.deb 02-May-2008 03:04 870K
rkward_0.5.0b-2_i386.deb 14-Jun-2008 10:05 927K

Thanks

Cesare Tirabassi (norsetto) wrote :

This is not a bug, looks like you have messed up your system by mixing packages from our official repository and those from another repo (CRAN ?).
You should really not have a mixed R system, its the best recipe for this kind of problems, either stick fully to the hardy ones or to the ones from CRAN.

Changed in rkward:
status: New → Invalid
studentz (studenz) wrote :

Even may be you are right, you answer doesn't help at all.
Here is how I solved my problem:
the library is located in
 /usr/lib/R/modules
 but is named lapack.so
next I copy the file in the same folder with the right name
sudo cp lapack.so libRlapack.so
make a symbolic link of this file and move to
/usr/lib
 voila it is working
thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions