Ristretto is the default MIME handler for PGM files, even though it cannot display them

Bug #1771227 reported by Alistair Buxton on 2018-05-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ristretto
Fix Released
Medium
ristretto (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce:

1. Be running Xubuntu 18.04 with defaults
2. Download these example PGM files:
    http://people.sc.fsu.edu/~jburkardt/data/pgma/apollonian_gasket.ascii.pgm
    http://people.sc.fsu.edu/~jburkardt/data/pgmb/baboon.pgm
3. Double click on them in Thunar.

Expected result:

The images should be displayed in a suitable application.

Actual result:

Ristretto opens and displays no image, as if it had been run with no arguments.

Opening the files through the Ristretto file->open menu also fails, as does running "ristretto <file>" from the command line.

The files open correctly in GIMP.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ristretto 0.8.2-1ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue May 15 00:19:27 2018
InstallationDate: Installed on 2018-05-07 (7 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
SourcePackage: ristretto
UpgradeStatus: No upgrade log present (probably fresh install)

Alistair Buxton (a-j-buxton) wrote :

Beginning with 0.8.2 version Ristretto ceased to open PPM files. I was advised on the forums that this problem looks similar to another one that already has been resolved:

https://bugzilla.xfce.org/show_bug.cgi?id=13489

Thanks in advance.

Alistair Buxton (a-j-buxton) wrote :

Neither the linked bug nor the forum post seem relevant. I have no problem displaying PPM and PNM files. Only PGM files are a problem. It is a different format and as far as I can tell Ristretto has never supported it.

https://en.wikipedia.org/wiki/Netpbm_format

I assumed that it is the same core issue. Furthermore, Ristretto 0.8.0 in Xubuntu 16.04.5 is able to display those two example PGM files.

Changed in ristretto:
importance: Unknown → Medium
status: Unknown → Confirmed

Hi, is the problem still there in version 0.8.3?

In , Gitbot (gitbot) wrote :

Igor referenced this bugreport in commit 4d03ad59054fa48a0615ea0c055574ebe777442d

Fix opening of PPM files

https://git.xfce.org/apps/ristretto/commit?id=4d03ad59054fa48a0615ea0c055574ebe777442d

Changed in ristretto:
status: Confirmed → Fix Released

This bug seems to be derived from the Ubuntu bug https://bugs.launchpad.net/ubuntu/+source/ristretto/+bug/1771227 in which case the title should have really been "PGM files are not opened".

However, regardless of that, the commit above does fix opening PGM files.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ristretto - 0.8.4-0ubuntu1

---------------
ristretto (0.8.4-0ubuntu1) disco; urgency=medium

  * New upstream bugfix release
    - Fix displaying PGM files (LP: #1771227)
  * d/patches/lp1756191.patch:
    - Dropped, included upstream.

 -- Sean Davis <email address hidden> Mon, 08 Apr 2019 21:36:30 -0400

Changed in ristretto (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.