ristretto can not open BMP files

Bug #1762242 reported by pqwoerituytrueiwoq
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ristretto (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

This appears to be caused by a mime type issue
here is a existing report:
https://www.bountysource.com/issues/45489646-ristretto-fails-to-load-bmp-libmagic-gives-wrong-mime-type
here is the patch
https://git.xfce.org/apps/ristretto/commit/?id=751834055dfc8831bfe06ed5e493c69b8347668a
ristretto really should get this patch, I do not know why it has not been picked up yet
Maybe someone decided to blame libmagic for giving the wrong mime type instead?

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ristretto 0.8.2-1
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
ApportVersion: 2.20.9-0ubuntu2
Architecture: amd64
CasperVersion: 1.392
CurrentDesktop: XFCE
Date: Sun Apr 8 20:14:57 2018
LiveMediaBuild: Xubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180401)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
SourcePackage: ristretto
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
pqwoerituytrueiwoq (pqwoerituytrueiwoq) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ristretto - 0.8.2-1ubuntu1

---------------
ristretto (0.8.2-1ubuntu1) devel; urgency=medium

  * d/p/lp1762242.patch: (LP: #1762242)
    - Add an upstream commit to fix loading of bmp files.

 -- Unit 193 <email address hidden> Mon, 09 Apr 2018 00:21:37 -0400

Changed in ristretto (Ubuntu):
status: New → Fix Released
Revision history for this message
pqwoerituytrueiwoq (pqwoerituytrueiwoq) wrote :

This bug is back - xUbuntu 20.04
The cause may be different
there are no errors, when you open a bmp file it open the current folder and shows non-bmp images

Revision history for this message
pqwoerituytrueiwoq (pqwoerituytrueiwoq) wrote :

ristretto:
  Installed: 0.10.0-1
  Candidate: 0.10.0-1
  Version table:
 *** 0.10.0-1 500
        500 http://us.archive.ubuntu.com/ubuntu focal/universe amd64 Packages
        100 /var/lib/dpkg/statu

Revision history for this message
pqwoerituytrueiwoq (pqwoerituytrueiwoq) wrote :

I downgraded to ristretto_0.8.2-1ubuntu1_amd64 and it did not fix the issue, i guess that has to do with mimi type text the software is getting

Revision history for this message
pqwoerituytrueiwoq (pqwoerituytrueiwoq) wrote :

~$ file --mime-type ./firestrike-12666.png && file --mime-type ./MSI_SnapShot.bmp
/media/chad/Samsung USB/firestrike-12666.png: image/png
/media/chad/Samsung USB/MSI_SnapShot.bmp: application/octet-stream

Revision history for this message
pqwoerituytrueiwoq (pqwoerituytrueiwoq) wrote :

This is clearly a upstream issue, the library is no longer able to even identify a bmp as a image at all
https://bugs.launchpad.net/ubuntu/+source/file/+bug/1879019

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints