Thumbnail sidebar shows error icons in place of some images.

Bug #1756191 reported by Alistair Buxton on 2018-03-15
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
ristretto
Fix Released
Medium
ristretto (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce:
    cd /usr/share/icons/gnome/16x16/categories
    xdg-open system-help.png

Result:
    ristretto opens the icon and displaysit, and opens a sidebar which displays other images in the folder. But some of those images just show errors. See screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ristretto 0.8.2-1
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Mar 15 21:57:41 2018
InstallationDate: Installed on 2018-03-15 (0 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180315)
SourcePackage: ristretto
UpgradeStatus: No upgrade log present (probably fresh install)

Instead of thumbnails, the same icons with a crossed red circle

Created attachment 7049
Instead of thumbnails, the same icons with a crossed red circle

Hello!
Is it possible to somehow correct this display so that instead of signs there are real thumbnails?

Same problem here with Ristretto 0.8.2.
When there are some thumbnails for a folder (i.e. generated by Thunar) then Ristretto will display them. But Ristretto 0.8.2 will not start generation of thumbnails.

With Ristretto 0.8.0 this worked well.

Alistair Buxton (a-j-buxton) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ristretto (Ubuntu):
status: New → Confirmed

Testing Bionic, Ristretto 0.8.2.
Same here. Please see: http://i.imgur.com/7EAoxRm.png

Sean Davis (bluesabre) wrote :

It appears that ristretto is not automatically generating thumbnails for these icons. If you open Thunar in the same directory, then open ristretto, the thumbnails are present.

Sean Davis (bluesabre) wrote :

I can confirm that this affects files in the home directory as well. Does ristretto create thumbnails, or is it maybe creating them in a legacy location?

slumbergod (slumbergod) wrote :

Is this a problem with ristretto or tumbler? I can delete the caches at ~/.cache/thumbails and ~/thumbnails and it seems to work properly for a while but then stops again.

miguel lopes (miguellopes01) wrote :

to install (trumbler-plugins-extra) and that solves the problem

Changed in ristretto:
importance: Unknown → Medium
status: Unknown → Confirmed
Sean Davis (bluesabre) wrote :

I tested install tumbler-plugins-extra, and it made no difference when opening the file directly with ristretto.

Sean Davis (bluesabre) wrote :

I did some additional testing on a fresh install.

1. ~/.thumbnails and ~/.cache/thumbnails do not exist.
2. Open existing images with ristretto, no thumbnails, no thumbnails generated.
3. Open existing images with thunar, thumbnails are generated.
4. Open new images with ristretto, no thumbnails are generated.
5. Manually create ~/.thumbnails
6. Open new images with ristretto, no thumnbnails are generated in either directory.

Based on this, I can conclude that thumbnail generation is not happening in ristretto.

brainwash, from the Xubuntu Bugs team found that reverting https://git.xfce.org/apps/ristretto/commit/?id=69b7459957427aed16caddb699c5b496dfb6deee seems to resolve this issue. I have tested and confirmed. Can we go ahead and do this to restore thumbnail generation?

*** Bug 14790 has been marked as a duplicate of this bug. ***

Igor, can you revert the commit mentioned above, and maybe follow up with a new release? Lots of translations and a few fixes since 0.8.3. Thanks!

In , Gitbot (gitbot) wrote :

Igor referenced this bugreport in commit caf6b19e1eeafe8a1fa219a4c27d37c77563ee3c

Revert "Fix memory leak in thumbnailer if image file not found"

https://git.xfce.org/apps/ristretto/commit?id=caf6b19e1eeafe8a1fa219a4c27d37c77563ee3c

Sean, thanks for pointing out the problematic commit!

But... Does memory leak present now? Should we re-open Bug #12034?

(In reply to Alexander Kurakin from comment #9)
> But... Does memory leak present now? Should we re-open Bug #12034?
I've reopened the bug, thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ristretto - 0.8.3-1ubuntu1

---------------
ristretto (0.8.3-1ubuntu1) disco; urgency=medium

  * d/patches/lp1756191.patch:
    - Fix thumbnail generation from upstream (LP: #1756191)

 -- Sean Davis <email address hidden> Sun, 07 Apr 2019 16:31:49 -0400

Changed in ristretto (Ubuntu):
status: Confirmed → Fix Released
Changed in ristretto:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.